Bug 444534 - RFE: teach dump/restore about ext4 for RHEL5
RFE: teach dump/restore about ext4 for RHEL5
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dump (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Adam Tkac
:
: 504537 733318 (view as bug list)
Depends On: 444533
Blocks: 662543 447797
  Show dependency treegraph
 
Reported: 2008-04-28 18:14 EDT by Eric Sandeen
Modified: 2013-04-30 19:50 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 08:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-04-28 18:14:22 EDT
We're starting to get some testing of ext4 on RHEL5, and we may get it to a tech
preview status by RHEL5.3 - to support this, a few system utilities could use
updates for ext4.

dump/restore won't open an ext4 filesystem.  Need to investigate what all it'll
take to properly support ext4 in dump/restore.

[root@inode ~]# dump -f /mnt/foo/mydump /mnt/test
  DUMP: Date of this level  dump: Mon Apr 28 17:11:13 2008
  DUMP: Dumping /dev/sda8 (/mnt/test) to /mnt/foo/mydump
  DUMP: Unsupported feature(s) 0x40 in filesystem
/dev/sda8: Filesystem has unsupported feature(s) while opening filesystem
  DUMP: The ENTIRE dump is aborted.

I haven't yet looked at dump to see how much fs-knowledge it needs for the
traversal etc.

Thanks,
-Eric
Comment 1 Adam Tkac 2008-05-22 05:07:07 EDT
This is big problem. Dump needs detailed FS knowledge, it operates directly with
inodes. I recommend follow standard scenario - Fedora->(upstream)->RHEL. I'm
affraid I cannot make it to 5.3. Btw ext3 support in dump is still marked as
experimental and upstream doesn't have time for such development.
Comment 2 RHEL Product and Program Management 2008-07-21 19:03:11 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 Adam Tkac 2009-06-22 09:11:47 EDT
*** Bug 504537 has been marked as a duplicate of this bug. ***
Comment 10 Aaron S. Hawley 2009-06-24 13:37:44 EDT
Support for ext4 was submitted in this message to the devel list.

http://sourceforge.net/mailarchive/message.php?msg_name=23730083.post%40talk.nabble.com

A new release happened last Thursday (2008-06-18), here's the announcement.

http://sourceforge.net/mailarchive/message.php?msg_name=20090622175922.GB5862%40galileo
Comment 11 Kenneth Porter 2009-06-24 19:01:24 EDT
A big update, 0.4b42, was released this week that includes ext4 support. Please test it and let upstream know. Here's the release announcement:

http://permalink.gmane.org/gmane.comp.archivers.dump.announce/6
Comment 12 Kenneth Porter 2009-06-24 19:15:02 EDT
I see that the new release has hit Rawhide:

http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/dump-0.4-0.1.b42.fc12.src.rpm
Comment 15 Adam Tkac 2009-09-02 08:40:05 EDT
After discussion ext4 support won't be available in RHEL5.

Ext4 support requires improved e2fsprogs-libs with ext4 support. From e2fsprogs-libs maintainer perspective it will be so difficult and invasive to extend the library thus dump with ext4 will be available in RHEL6.
Comment 16 Adam Tkac 2011-09-14 06:51:24 EDT
*** Bug 733318 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.