Bug 444542 - Fails to display with Radeon Mobility HD 2600
Fails to display with Radeon Mobility HD 2600
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 522271
  Show dependency treegraph
 
Reported: 2008-04-28 19:06 EDT by Martin Ebourne
Modified: 2009-09-09 18:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 522271 (view as bug list)
Environment:
Last Closed: 2008-10-05 07:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log when no xorg.conf was present (1.14 MB, text/plain)
2008-04-28 19:06 EDT, Martin Ebourne
no flags Details

  None (edit)
Description Martin Ebourne 2008-04-28 19:06:33 EDT
Description of problem:
Using the default config of the Fedora 9 preview release install X generally
fails to display on my laptop. If the machine has been powered off for a while
it tends to display correctly and work, but otherwise (eg. after v-c switch, X
restart, suspend-resume, reboot) it almost always fails to initialise the screen
correctly.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.8.0-10.fc9.x86_64

How reproducible:
Most of the time.

Steps to Reproduce:
1. Boot machine from cold
2. If a working X display results restart X
  
Actual results:
LCD goes blank and then fills up with grey from the bottom taking a couple of
seconds. Ends in a light grey steady state with no visible picture.

Expected results:
Normal X display

Additional info:
This is the same both with the default xorg.conf generated by anaconda, or if I
just remove xorg.conf and let Xorg default by itself. I've attached the log from
the default run.

radeonhd works fine (except for no suspend to ram) on this machine.
Comment 1 Martin Ebourne 2008-04-28 19:06:33 EDT
Created attachment 304053 [details]
Xorg log when no xorg.conf was present
Comment 2 Bug Zapper 2008-05-14 06:20:32 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Martin Ebourne 2008-05-19 19:04:58 EDT
Any ideas on this, or anything I can do to help debug it? It is quite
reproducible. Although radeonhd is working for me it doesn't do XV or suspend at
the moment, both of which are a serious pain. ati does do those but only works
about 10% of the time which is completely useless.
Comment 4 Dave Airlie 2008-05-19 20:24:57 EDT
does VT switching help radeon at all?

btw radeon shouldn't do xv on that hardware either, it might do suspend better
though.
Comment 5 Martin Ebourne 2008-05-19 21:38:59 EDT
It generally switches out to the vt but fails again back on the X display. Power
down and wait a while is about the only way out. Seems worse on the F9 release
than it was on the preview release live usb key, though may be just
circumstance. Suspend did work sometimes on the preview release, although often
it would do the same grey screen on resume.

Running radeonhd it always starts to fill the screen with grey from the bottom
left but after 1/2s or so it flicks out of it and draws the screen properly.
Looks likes some mode setting is missing from or not working in radeon?

Any ideas on what else I can try?
Comment 6 Dave Airlie 2008-05-21 20:13:54 EDT
okay I've built some packages I'd like you to test for if you could.

http://people.fedoraproject.org/~airlied/bz444542/

has two subdirs dce3 and refdiv.

I'd appreciate you installing them one by one and seeing if either of them solve
the LCD panel problem you are seeing any better.
Comment 7 Martin Ebourne 2008-05-22 17:42:45 EDT
Awesome - dce3 didn't help but refdiv has fixed it. On bootup the screen starts
filling with grey from bottom left but flicks out of it within a second. After
that switching to and from VT, and suspend to ram all works normally. Thanks!

The next annoying problem is that switching out of X and back (or suspend to
RAM) breaks tapping on the touchpad - it works from X server restart due to me
adding a synaptics section in xorg.conf. For some reason xorg 1.5 doesn't
default to tapping on, which earlier releases did. Not sure which X package to
raise that against.
Comment 8 Fedora Update System 2008-05-23 22:15:11 EDT
xorg-x11-drv-ati-6.8.0-16.fc9 has been submitted as an update for Fedora 9
Comment 9 Martin Ebourne 2008-05-24 07:48:58 EDT
There is still a problem on this hardware. When the display is switched off and
back on (whether by suspend or just a lid close without suspend) sometimes there
is a severe flicker all over the screen. Switching between VTs doesn't fix this. 

Should I raise a new bug for this?
Any extra info that would be useful?
Comment 10 Patrick Steiner 2008-05-24 17:03:56 EDT
xorg-x11-drv-ati-6.8.0-16.fc9 doesnt change anything on my pc


i have a ati hd2400 pro (rv610).

i use the "radeon" xorg driver
Comment 11 Dave Airlie 2008-05-25 20:30:15 EDT
okay Patrick you must have a different bug, can you open a new bug and attach
the xorg logs from -16?

Martin - probably worth raising a new bug for the flicker so it doesn't get lost.
(please close this bug if -16 fixed the problem for you.)
Comment 12 Fedora Update System 2008-05-28 22:43:13 EDT
xorg-x11-drv-ati-6.8.0-16.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-ati'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4517
Comment 13 Martin Ebourne 2008-10-05 07:53:08 EDT
Closing this as fix has been in updates for a while. Entered flicker issue into new bug #465665.

Note You need to log in before you can comment on or make changes to this bug.