Bug 444552 - Shows Shutdown/Reboot/Hibernate for non-CK session
Shows Shutdown/Reboot/Hibernate for non-CK session
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 445723 (view as bug list)
Depends On:
Blocks: K12LTSP F10Target
  Show dependency treegraph
 
Reported: 2008-04-28 22:40 EDT by Warren Togami
Modified: 2008-11-05 23:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 23:06:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 536915 None None None Never

  None (edit)
Description Warren Togami 2008-04-28 22:40:07 EDT
ssh -Y username@localhost /etc/X11/xinit/Xsession

Currently users with a GNOME Desktop launched in this manner are not registered
in ConsoleKit.  See Bug #435521 for more details.

Menus show Shutdown/Reboot/Hibernate etc.  If I select them nothing happens
because PolicyKit is correctly rejecting it.  It is a bug that these options are
offered at all to these users.

gnome-panel-2.22.1.2-6.fc9.x86_64
PolicyKit-0.8-2.fc9.x86_64
ConsoleKit-0.2.10-3.fc9.x86_64

Impact:
Shutdown/Reboot/Hibernate options are offered to thin client users where they
are confusing and wrong.
Comment 1 Ray Strode [halfline] 2008-05-08 20:25:36 EDT
*** Bug 445723 has been marked as a duplicate of this bug. ***
Comment 2 Bug Zapper 2008-05-14 06:20:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Ray Strode [halfline] 2008-10-09 15:49:52 EDT
This should be fixed with the latest gnome-session and gnome-panel builds.

Moving to MODIFIED for Warren to QA.

Moving from F10Blocker to F10Target list since it's only relevant in broken scenarios and only unaesthetic when relevant.
Comment 5 Fedora Update System 2008-10-12 21:13:52 EDT
gnome-panel-2.22.2-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gnome-panel-2.22.2-3.fc9
Comment 6 Fedora Update System 2008-10-15 22:10:41 EDT
gnome-panel-2.22.2-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-panel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8860
Comment 7 Fedora Update System 2008-11-05 23:06:43 EST
gnome-panel-2.22.2-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.