Bug 445723 - gnome shutoff issues
gnome shutoff issues
Status: CLOSED DUPLICATE of bug 444552
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-05-08 15:04 EDT by Josh Lange
Modified: 2015-01-14 18:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-08 20:25:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Josh Lange 2008-05-08 15:04:46 EDT
Description of problem:
in the version of gdm shipping with rawhide, disabling the shutdown/reset/etc
buttons through the /apps/gdm/simple-greeter/disable_restart_buttons does not
prevent gnome from shutting down the system

Actual results:
The buttons properly disappear from the gdm menu,
but once a user logs in, they can still shutdown the system

Expected results:
Gnome should be barred from disabling shutdown.

This is offers a potential avenue to DoS a system.
Comment 1 Josh Lange 2008-05-08 15:06:45 EDT

Expected results:
Gnome should be barred from shutting down the system.
Comment 2 Ray Strode [halfline] 2008-05-08 15:26:31 EDT
Hi, I believe shutdown is managed by policy kit.

if you install PolicyKit-gnome and run /usr/bin/polkit-gnome-authorization and
set Active Console to "no" for "Restart the system" and "Stop the system" in the
consolekit policy, does it work?
Comment 3 Josh Lange 2008-05-08 16:58:04 EDT
Hmm, I see that you are right, though its a bit quirky.

1. The shutdown option doesn't disappear from the system menu once all
shutdown-like options are disallowed (hal.hibernate..reboot..etc and
consolekit.stop..reset). This means that there is no longer any way to remove
this menu item from the gnome panel. (annoyance, really)

2. if you attempt to shut down you are given an error. If you do it again, you
are given the same error 2 times,...etc (totally doesn't matter)
Comment 4 Ray Strode [halfline] 2008-05-08 20:25:35 EDT
ah yes, we already have a bug for that.

*** This bug has been marked as a duplicate of 444552 ***

Note You need to log in before you can comment on or make changes to this bug.