Bug 444556 - In perl, 'use Mysql;' fails with "Can't locate Mysql.pm in @INC"
In perl, 'use Mysql;' fails with "Can't locate Mysql.pm in @INC"
Status: CLOSED DUPLICATE of bug 444558
Product: Fedora
Classification: Fedora
Component: perl-DBD-MySQL (Show other bugs)
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-28 23:30 EDT by Lee Reynolds
Modified: 2008-05-22 10:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-22 10:00:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lee Reynolds 2008-04-28 23:30:59 EDT
Description of problem:
Perl scripts that include 'use Mysql;' fail

Version-Release number of selected component (if applicable):

How reproducible:
Easy to reproduce

Steps to Reproduce:
1. perl -e "use Mysql;"
Actual results:

Can't locate Mysql.pm in @INC (@INC contains:
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 .) at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

Expected results:

No errors.  The syntax above has worked with every version of Redhat/Fedora from
7.3 on.

Additional info: This bug is also in the pre-release version of Fedora 9. 
However it is NOT present in Fedora 7.  My current work-around for this problem
is to compile perl-DBD-MySQL-3.0007-1 from Fedora 7 and install it instead.
Comment 1 Marcela Mašláňová 2008-05-22 10:00:07 EDT

*** This bug has been marked as a duplicate of 444558 ***

Note You need to log in before you can comment on or make changes to this bug.