Bug 444558 - In perl, 'use Mysql;' fails with "Can't locate Mysql.pm in @INC"
In perl, 'use Mysql;' fails with "Can't locate Mysql.pm in @INC"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl-DBD-MySQL (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 444556 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 23:36 EDT by Lee Reynolds
Modified: 2008-05-22 10:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 09:58:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Reynolds 2008-04-28 23:36:56 EDT
Description of problem:
Perl scripts that include 'use Mysql;' fail



Version-Release number of selected component (if applicable):
4.005-8

How reproducible:
Easy to reproduce

Steps to Reproduce:
1. perl -e "use Mysql;"
2.
3.
  
Actual results:

Can't locate Mysql.pm in @INC (@INC contains:
/usr/lib/perl5/5.10.0/i386-linux-thread-multi /usr/lib/perl5/5.10.0
/usr/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/site_perl/5.8.8
/usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.8.8
/usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl .) at -e line 1.
BEGIN failed--compilation aborted at -e line 1.


Expected results:

No errors.  The syntax above has worked with every version of Redhat/Fedora from
7.3 on.


Additional info: This bug is also in Fedora 8 as bug # 444556 
However it is NOT present in Fedora 7.  My current work-around for this problem
is to compile perl-DBD-MySQL-3.0007-1 from Fedora 7 and install it instead.
Comment 1 Bug Zapper 2008-05-14 06:21:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Marcela Mašláňová 2008-05-22 09:58:45 EDT
There was change in code befoer 10 years. It looks like you need 'use
DBD::mysql;' instead of 'use Mysql;'.

From http://search.cpan.org/~capttofu/DBD-mysql-3.0008/lib/Mysql.pm#DESCRIPTION

"As of March 1998, the Msql and Mysql modules are obsoleted by the DBI drivers
DBD::mSQL and DBD::mysql, respectively. You are strongly encouraged to implement
new code with the DBI drivers. In fact, Msql and Mysql are currently implemented
as emulations on top of the DBI drivers."
Comment 3 Marcela Mašláňová 2008-05-22 10:00:08 EDT
*** Bug 444556 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.