Bug 444729 - Kickstart Virtual Machine Crash
Kickstart Virtual Machine Crash
Status: CLOSED DUPLICATE of bug 250427
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
x86_64 Linux
low Severity urgent
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
Depends On:
  Show dependency treegraph
Reported: 2008-04-30 06:37 EDT by Dan Bateman
Modified: 2009-12-14 16:26 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-30 07:50:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xen config file (4.12 KB, text/plain)
2008-04-30 06:37 EDT, Dan Bateman
no flags Details

  None (edit)
Description Dan Bateman 2008-04-30 06:37:05 EDT
Description of problem:
Created a XEN Virutal machine using the the kernel and ramdisk from a RHEL5
Server Xen images directory and kickstarting the machine with RHEL5. Using the
following command:

xm create -c -f jabber on_reboot=destroy
extra="ks=http://pygmalion/rhel5_i386.cfg ksdevice=eth0 noipv6 text" bootloader=""

See attached jabber xen config file.

During the kickstart the install will crash with the following error:

Oops: 0002 [#1]
last sysfs file: /block/ram0/dev
Modules linked in: dm_emc dm_round_robin dm_multipath dm_snapshot dm_mirror
dm_zero dm_mod lock_nolock gfs2 ext3 jbd msdos raid456 xor raid1 raid0 xenblk
xennet iscsi_tcp libiscsi scsi_transport_iscsi sr_mod sd_mod scsi_mod ide_cd
cdrom squashfs pcspkr loop nfs nfs_acl fscache lockd sunrpc vfat fat cramfs
CPU:    0
EIP:    0061:[<c045128d>]    Not tainted VLI
EFLAGS: 00010206   (2.6.18-8.el5xen #1) 
EIP is at copy_page_range+0x638/0x734
eax: c0832000   ebx: 440db045   ecx: 87a82000   edx: d7cc8e40
esi: 000183d4   edi: 440db045   ebp: 80000004   esp: c07bee74
ds: 007b   es: 007b   ss: 0069
Process anaconda (pid: 457, ti=c07be000 task=c0832000 task.ti=c07be000)
Stack: df5058b4 c06f1200 d7cc8e40 440db045 80000004 df117000 c2711000 0efcd000 
       0c200000 0efcd000 1f0d8278 05e4e278 00000000 d83d4000 87a82000 00000000 
       d7cc8e88 c06f1248 c1000000 df0d8300 04aff001 00000005 fabb7027 00000005 
Call Trace:
 [<c041a19f>] copy_process+0xb37/0x1167
 [<c041a810>] do_fork+0x41/0x118
 [<c04250c6>] sigprocmask+0xcc/0xd2
 [<c0402b71>] sys_clone+0x28/0x2d
 [<c0404cff>] syscall_call+0x7/0xb
Code: 00 3b 90 84 00 00 00 74 08 81 fa 80 37 65 c0 75 16 31 f6 8b 9c 24 84 00 00
00 89 f9 89 ea e8 3b ff fa ff 85 c0 74 09 8b 4c 24 38 <89> 69 04 89 39 83 44 24
3c 08 81 84 24 84 00 00 00 00 10 00 00 
EIP: [<c045128d>] copy_page_range+0x638/0x734 SS:ESP 0069:c07bee74
 <0>Kernel panic - not syncing: Fatal exception

This happens at different times during the install process and is not always
able to reproduce.

Version-Release number of selected component (if applicable):
Using the following xen package versions:

How reproducible:

Steps to Reproduce:
1.See Description
Actual results:

Expected results:

Additional info:
Comment 1 Dan Bateman 2008-04-30 06:37:05 EDT
Created attachment 304213 [details]
xen config file
Comment 2 Dan Bateman 2008-04-30 06:39:01 EDT
I should also mention that 
Comment 3 Dan Bateman 2008-04-30 06:43:18 EDT
I should also mention that I have now seen this on a running Virtual Machine -
i.e. not during a kickstart.
Comment 4 Daniel Berrange 2008-04-30 07:50:48 EDT
You are attempting to install a 32-bit guest on a 64-bit host. As per the
RHEL-5.1 release notes, this is not supported and is known to randomly crash.

Resolution of this problem for RHEL-5.2 is being tracked in bug 250427

*** This bug has been marked as a duplicate of 250427 ***

Note You need to log in before you can comment on or make changes to this bug.