Bug 444736 - kbluelock doesn't work
kbluelock doesn't work
Status: CLOSED DUPLICATE of bug 447956
Product: Fedora
Classification: Fedora
Component: kdebluetooth (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gilboa Davara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 08:34 EDT by Juha Tuomala
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-22 19:09:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2008-04-30 08:34:32 EDT
Description of problem:

it crashes with:

process 3258: arguments to dbus_message_new_method_call() were incorrect,
assertion "_dbus_check_is_valid_path (path)" failed in file dbus-message.c line
1074.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
KCrash: Application 'kbluelock' crashing...
KCrash cannot reach kdeinit, launching directly.

Version-Release number of selected component (if applicable):
kdebluetooth-1.0-0.41.beta8.fc9.i386

How reproducible:

always in my box.

Steps to Reproduce:
1. run kbluelock from shell
2. click the radiobox 'lock the screen if....'
3. crash
Comment 1 Gilboa Davara 2008-04-30 10:37:25 EDT
I cannot seem to reproduce this bug on my F8 and I don't have a rawhide machine
@work.

I'll try to reproduce it during the week-end.

- Gilboa
Comment 2 Gilboa Davara 2008-05-04 03:56:17 EDT
Reproduced.
kdebluetooth seems to be incompatible with the current upstream bluez version.
I'll see if I can solve it myself (given the fact that upstream is more-or-less
dead).

- Gilboa
Comment 3 Kevin Kofler 2008-05-04 10:19:13 EDT
Can you figure out where in the source code the failing D-Bus call is located?
Comment 4 Juha Tuomala 2008-05-06 10:46:10 EDT
Well, this doesn't crash anymore. But if i check both boxes for lock operations
and then flip-flop the bt in selected phone, it doesn't do anything, no screen
lock whatsoever.

Subject: crashes --> doesn't work

kdebluetooth-1.0-0.41.beta8.fc9.i386
Comment 5 Juha Tuomala 2008-05-07 03:42:48 EDT
eh...today is odd day number (7th) so it *crashes* again.... grrr. 

same error as in inital comment.
Comment 6 Gilboa Davara 2008-05-08 04:18:53 EDT
kdebluetooth is horribly broken under F9. Seems like a compatibility problem
with that latest bluez.
As upstream is completely dead, I'm trying solve the problem myself.
Hopefully a solution will be found before F9-release. (But I'm not very optimistic.)

- Gilboa
Comment 7 Bug Zapper 2008-05-14 06:25:32 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Steven M. Parrish 2008-06-21 13:14:58 EDT
Is this still an issue?  Please give us an update, and even though upstream may
seam dead go ahead a report it to them and add upstream info to this report.
Comment 9 Gilboa Davara 2008-06-22 19:09:07 EDT

*** This bug has been marked as a duplicate of 447956 ***

Note You need to log in before you can comment on or make changes to this bug.