Bug 447956 - KDE can't find the bluetooth: protocol
KDE can't find the bluetooth: protocol
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kdebluetooth (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gilboa Davara
Fedora Extras Quality Assurance
:
: 444736 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 12:22 EDT by Carl Roth
Modified: 2008-09-21 01:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-21 01:52:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 162492 None None None Never

  None (edit)
Description Carl Roth 2008-05-22 12:22:25 EDT
Description of problem:

When I click on the bluetooth logo in the systray, I was expecting the file
browser to launch into the bluetooth:// navigator (like in F8).  Instead I get a
popup:

  Protocol no supported
  bluetooth

and then I get a blank file browser window.

Bluetooth pairing works fine (via KBluetooth-->Configuration).  My device (a
cellphone in this case) is properly paired with a bluetooth USB dongle on the host.

Is it having trouble finding the bluetooth.protocol file?  The kbluetooth RPM
installs it into /usr/share/services; I also see a /usr/share/kde4/services
directory.

Version-Release number of selected component (if applicable):

kdebluetooth-1.0-0.41.beta8.fc9.x86_64

How reproducible:


Steps to Reproduce:
1. Install kbluetooth
2. Restart desktop or launch /usr/share/autostart/kbluetooth.autostart.desktop
3. Click on bluetooth icon
  
Actual results:


Expected results:


Additional info:
Comment 1 Steven M. Parrish 2008-05-22 16:35:13 EDT
Could not find a matching report upstream.  Please file a bug at
http://bugs.kde.org and add the upstream bug report information to this report.
 We will monitor the upstream bug for resolution.
Comment 2 Carl Roth 2008-05-22 17:34:13 EDT
This is filed as http://bugs.kde.org/show_bug.cgi?id=162492.  I wasn't sure if
this was a kde issue or a packaging issue.
Comment 3 Gilboa Davara 2008-05-29 09:43:26 EDT
kdebluetooth doesn't seem to support the latest version of bluez.
Problem has been reported upstream (long ago), but upstream seems to be dead.
(More-or-less).

I'm trying to free some time, to check if I can fix the problem myself.
For now, I'm over booked :(

Keeping this bug open for now.

- Gilboa
Comment 4 Gilboa Davara 2008-06-22 19:09:08 EDT
*** Bug 444736 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2008-09-20 18:20:59 EDT
kdebluetooth-0.2-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kdebluetooth-0.2-3.fc9
Comment 6 Ville Skyttä 2008-09-21 01:52:22 EDT
As noted by comment 5, kdebluetooth4 is on its way.  It's a necessary update, but unfortunately it currently contains only a subset of the old kdebluetooth's functionality, and one of the missing things is the bluetooth:/ protocol handler.  So as of now, this is not something we can fix and it is expected that the bluetooth:/ protocol is not found, we hope that the functionality will reappear in future kdebluetooth4 releases -> CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.