Bug 444758 - noarch packages are not found by exact name search
noarch packages are not found by exact name search
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
low Severity low
: ---
: ---
Assigned To: Grant Gainey
Stephen Herr
us=23816
:
: 450824 (view as bug list)
Depends On:
Blocks: 446437
  Show dependency treegraph
 
Reported: 2008-04-30 10:22 EDT by Stephen Herr
Modified: 2008-06-26 16:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 16:22:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2008-04-30 10:22:55 EDT
Description of problem:
Some packages will not be found when you search for their name in the package
search.

Version-Release number of selected component (if applicable):
5.0.5

How reproducible:
Always

Steps to Reproduce:
1. Log into RHN
2. Click on package search in the top search bar or navigate to the product
search page (/rhn/channels/software/Search.do)
3. Search for "gnome-user-docs" (or "m17n-db-telugu", or probably a lot of
others I don't know about)
  
Actual results:
Search returns No Packages.

Expected results:
Search finds package

Additional info:
Comment 1 Stephen Herr 2008-04-30 10:28:52 EDT
Additional info:

These packages were discovered by searching for various packages that returned
from the SQL search in bug 222405
(https://bugzilla.redhat.com/show_bug.cgi?id=222405).
Comment 2 Stephen Herr 2008-04-30 14:16:44 EDT
Hokay, so upon looking into this a bit more it appears to only happens to noarch
packages when doing an exact name search. 

At least I think it's only noarch packages, all the packages i've found so far
that exhibit this behavior are noarch. And the search only doesn't work for
exact name searches, if you leave a word off the front or back of the package
search it suddenly becomes findable.
Comment 3 Grant Gainey 2008-05-15 17:14:36 EDT
TEST PLAN:
=========

First - please regression-test, using the test plan for 

https://bugzilla.redhat.com/show_bug.cgi?id=210188

Second - use the reproducer above.
Comment 4 Stephen Herr 2008-05-20 11:29:02 EDT
Verified in Dev
Comment 5 Stephen Herr 2008-06-11 10:54:48 EDT
So it turned out that this doesn't have anything to do with noarch packages at
all, except that most packages that have two '-'s in their name are noarch. The
search regex was expecting all package searches with two '-'s to be in the
name-version-arch format, and so wasn't finding packages in the
name1-name2-name3 format. S'been fixed. 
Comment 6 Stephen Herr 2008-06-11 11:00:41 EDT
*** Bug 450824 has been marked as a duplicate of this bug. ***
Comment 7 Stephen Herr 2008-06-16 11:58:50 EDT
verified in qa

Note You need to log in before you can comment on or make changes to this bug.