Bug 444764 - Enable VOIP in Empathy
Enable VOIP in Empathy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: EasyFix, Reopened
Depends On: 450149 451391
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 10:42 EDT by Christian Schaller
Modified: 2008-07-26 02:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.1.27-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-26 02:00:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tiny patch for telepathy-gabble. %patch0 -p0 merge it fine. (438 bytes, text/plain)
2008-05-01 12:20 EDT, Christian Schaller
no flags Details
Help fix speex voip to not sound like dart vader (1.27 KB, patch)
2008-05-02 07:09 EDT, Christian Schaller
no flags Details | Diff

  None (edit)
Description Christian Schaller 2008-04-30 10:42:03 EDT
The empathy RPM are missing some core run-time dependencies. 

The packages:
gstreamer-plugins-farsight
telepathy-stream-engine

Needs to be installed for the VOIP features to work (including their
sub-dependencies).

This is a problem with the current FC9 prerelease.
Comment 1 Peter Gordon 2008-04-30 17:54:28 EDT
Thanks for the bug report. I'll fix this up tonight after class; or someone can
add these two deps before then if so desired. :)
Comment 2 Brian Pepple 2008-04-30 18:07:49 EDT
I don't believe the version of stream-engine shipping w/ F9 meets the minimum
requirement for empathy.  And since we are in feature freeze for F9, it will be
pushed as an update after our release.

Also, I don't think it make sense to add a hard-dep to empathy, since this can
be a run-time dep.
Comment 3 Peter Gordon 2008-04-30 21:31:13 EDT
Brian, maybe it would be best then to move the VoIP-related files from the main
package into a -voip subpackage; then that subpackage can have these
dependencies in addition to the main package of the same EVR.
Comment 4 Christian Schaller 2008-05-01 04:49:54 EDT
Well regarding making things a hard dependency or not. I know that one early and
very frequent complaint against GStreamer applications like Totem and Rhythmbox
was that 'nothing' worked without installing 'random' other gstreamer-plugins
packages. I think this is a similar case. And while part of is its empathy's
fault, the problem is that you get zero feedback when you try to connect over
VoIP with empathy when these packages are not installed. So unless you hardcode
the dependency there is no solution other than forum crawling and googling for
figuring out what is missing and needs to be installed. 

I would also argue that the people who do install empathy at this point in time
probably do it due to wanting Voip as it don't really offers any chatting
advantages over Pidgin etc.
Comment 5 Christian Schaller 2008-05-01 12:18:53 EDT
Been testing and getting help from Rob McQueen today and finally I got VoIP with
telepathy working on my system. In the end I had to upgrade quite a few packages
compared to what is in FC9 currently:
farsight-0.1.27
telepathy-gabble-0.7.3
telepathy-glib-0.7.6
telepathy-stream-engine-0.5.2

Also Rob pointed out that gstreamer-plugins-farsight
 should probably be a requirement for the farsight RPM and not the empathy one.

I also had to add a small patch to telepathy-gabble. Attaching that here.

Finally there is a bug in the GStreamer speex plugins which has a patch, I will
try to get that merged upstream.
Comment 6 Christian Schaller 2008-05-01 12:20:20 EDT
Created attachment 304320 [details]
Tiny patch for telepathy-gabble. %patch0 -p0 merge it fine.
Comment 7 Christian Schaller 2008-05-01 12:21:12 EDT
Speex patch is currently in this bug:
http://bugzilla.gnome.org/show_bug.cgi?id=465146
Comment 8 Brian Pepple 2008-05-01 19:34:02 EDT
Christian, thanks for the leg work you did on this.  Peter, I'm going to assign
this bug to me, since I was planning to update the tp requirements in F9 next week.
Comment 9 Peter Gordon 2008-05-01 20:10:49 EDT
Sounds like a good plan, then.

Let me know once you've got the TP stuff bumped and I can add the dependencies
in Empathy (or you can do so directly if you'd like).

Thanks, Brian!
Comment 10 Brian Pepple 2008-05-01 20:25:33 EDT
I'll go ahead and do the empathy bit also, since I want these all to be pushed
to bodhi at the same time.
Comment 11 Christian Schaller 2008-05-02 07:09:10 EDT
Hi Brian,
Just thought I should mention that Simon did a new release of telepathy-gabble
yesterday when I mentioned this bug, so we now have: 
http://telepathy.freedesktop.org/releases/telepathy-gabble/telepathy-gabble-0.7.4.tar.gz

Updating to this version means the patch attached to this bugzilla entry is no
longer needed as it is in the mainline. I have added another patch though, a
farsight patch. This patch (together with the GStreamer speex fixes) will make
sure one do not sound like Dart Vader when talking using empathy.
Comment 12 Christian Schaller 2008-05-02 07:09:55 EDT
Created attachment 304373 [details]
Help fix speex voip to not sound like dart vader
Comment 13 Brian Pepple 2008-05-03 21:06:42 EDT
Ok, I've built new version of telepathy-glib, tp-gabble, farsight, gst-farsight,
tp-stream-engine, and empathy.  The only thing left is to patch
gst-plugins-good, which I'll do on Monday after touching base with Bastien. 
Once that is done, I'll add them all to Bodhi (so they're pushed at the same time).

Here's links to the builds for those interested:
http://koji.fedoraproject.org/koji/buildinfo?buildID=47843
http://koji.fedoraproject.org/koji/buildinfo?buildID=47846
http://koji.fedoraproject.org/koji/buildinfo?buildID=47893
http://koji.fedoraproject.org/koji/buildinfo?buildID=47850
http://koji.fedoraproject.org/koji/buildinfo?buildID=47989
http://koji.fedoraproject.org/koji/buildinfo?buildID=47993
Comment 14 Sachin Garg 2008-05-04 00:23:27 EDT
I am not able to do voip with them. When I initiate the call with empathy(linux)
to gtalk(windows), call is terminated as soon as I accept it on the windows. And
when  I initiate it from windows to linux, it just shows the ringing status on
call window.

On ubuntu, hardy. I am able to do voip with windows box.
Comment 15 Fedora Update System 2008-05-04 17:32:24 EDT
telepathy-glib-0.7.6-1.fc9,gstreamer-plugins-farsight-0.12.7-1.fc9,farsight-0.1.27-2.fc9,telepathy-stream-engine-0.5.2-1.fc9,telepathy-gabble-0.7.4-1.fc9,empathy-0.23.1-1.fc9 has been submitted as an update for Fedora 9
Comment 16 Fedora Update System 2008-05-13 11:30:28 EDT
farsight-0.1.27-2.fc9, telepathy-glib-0.7.6-1.fc9, telepathy-stream-engine-0.5.2-1.fc9, gstreamer-plugins-farsight-0.12.7-1.fc9, telepathy-gabble-0.7.4-1.fc9, empathy-0.23.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update farsight telepathy-glib telepathy-stream-engine gstreamer-plugins-farsight telepathy-gabble empathy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3639
Comment 17 Bug Zapper 2008-05-14 06:25:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Fedora Update System 2008-05-28 22:45:00 EDT
farsight-0.1.27-2.fc9, telepathy-glib-0.7.6-1.fc9, telepathy-stream-engine-0.5.2-1.fc9, gstreamer-plugins-farsight-0.12.7-1.fc9, telepathy-gabble-0.7.4-1.fc9, empathy-0.23.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Christian Schaller 2008-06-05 10:25:36 EDT
Ok, tested again now with updated packages. There are still a few remaining
issues. First of all the gstreamer-plugins-farsight package links against
jrtplib, which actually makes it not work. This package needs to be built with
'--disable-jrtlib', I will work to make that the default for the next release.

The other problem is as mentioned above that the Speex RTP support in current
GStreamer is broken. The next gst-plugins-good (which should be 0.10.9) should
have the needed speex RTP fixes. The issue with speex only triggers when speex
is negotiated as the protocol though.
Comment 20 Christian Schaller 2008-06-05 10:43:32 EDT
As a workaround: As long as it's known that speex doesn't work on fedora you can
disable it in farsight by editting /etc/farsight/gstcodecs.conf and setting
id=-1 for speex.

So change what looks in the default config something like:
      
[audio/speex]
      clock-rate=16000
      
to
      
[audio/speex]
      id=-1
       
      This will make farsight  ignore speex as a codec
Comment 21 Fedora Update System 2008-07-26 02:00:51 EDT
farsight-0.1.27-2.fc9, telepathy-glib-0.7.6-1.fc9, telepathy-stream-engine-0.5.2-1.fc9, gstreamer-plugins-farsight-0.12.7-1.fc9, telepathy-gabble-0.7.4-1.fc9, empathy-0.23.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.