Bug 444831 - AttributeError: 'NoneType' object has no attribute 'cursor'
AttributeError: 'NoneType' object has no attribute 'cursor'
Status: CLOSED DUPLICATE of bug 442819
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 17:19 EDT by Lubomir Rintel
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 17:29:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bg (591.75 KB, patch)
2009-07-30 03:32 EDT, sina_egold2005
no flags Details | Diff

  None (edit)
Description Lubomir Rintel 2008-04-30 17:19:10 EDT
Description of problem:

...
---> Package libstdc++-devel.i386 0:4.3.0-8 set to be updated
filelists.sqlite.bz2                                     |  10 MB     00:01     
http://storm.lan/linux/fedora/rawhide/i386/os/repodata/filelists.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 157, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 626, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 649, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 732, in
_resolveRequires
    thisneeds = self._checkInstall(txmbr)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 774, in
_checkInstall
    provs = self.tsInfo.getProvides(*req)
  File "/usr/lib/python2.5/site-packages/yum/transactioninfo.py", line 429, in
getProvides
    result.update(self.getNewProvides(name, flag, version))
  File "/usr/lib/python2.5/site-packages/yum/transactioninfo.py", line 411, in
getNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 295, in
getProvides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 447, in
_computeAggregateDictResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 721, in
getProvides
    return self._search("provides", name, flags, version)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 39, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 700, in _search
    for pkg in self.searchFiles(name, strict=True):
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 39, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 450, in
searchFiles
    cur = cache.cursor()
AttributeError: 'NoneType' object has no attribute 'cursor'


Version-Release number of selected component (if applicable):

yum-3.2.14-10.fc9.noarch
Comment 1 James Antill 2008-04-30 17:29:24 EDT

*** This bug has been marked as a duplicate of 442819 ***
Comment 2 sina_egold2005 2009-07-30 03:32:31 EDT
Created attachment 355645 [details]
bg

bg

Note You need to log in before you can comment on or make changes to this bug.