Bug 444869 - [REGRESSION] Initscripts displays garbage characters when system is set to Romanian
[REGRESSION] Initscripts displays garbage characters when system is set to Ro...
Status: CLOSED DUPLICATE of bug 329071
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 08:22 EDT by Răzvan Sandu
Modified: 2008-05-04 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-04 12:35:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-05-01 08:22:18 EDT
Description of problem:

After upgrading from F8 to Rawhide (via preupgrade), the system (which is set to
Romanian language & keyboard) displays garbage characters in place of some
Romanian-specific characters (s,t) during boot (in text-mode).

This is a regression, since at least it displayed (incorrect) Unicode
cedilla-below characters in Fedora 8 (please see bug #329071 and bug #440992 for
details).

Version-Release number of selected component (if applicable):
initscripts-8.74-1.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 8 or Fedora 9 beta
2. Perform latest online upgrades to latest rawhide.
3. Set system to Romanian settings via System -> Administration -> Language
4. Put system in default runlevel 3.
5. Reboot system and watch Romanian specific characters during initialization
(s/S, t/T with comma below).  

Actual results:
Characters are garbled.

Expected results:
Characters should display normally (Unicode characters with comma below, not
with cedilla below - please see bug #329071 and bug #440992 for details).


Additional info:
Probably this is not specific to initscripts, but I don't know where to file
this bug. Please redirect it appropriately.
Comment 1 Bill Nottingham 2008-05-01 09:57:08 EDT
Not being a native speaker, can you give me a specific example of a string
that's rendered incorrectly? In a test boot here, there's nothing that seems
obviously wrong.
Comment 2 Bill Nottingham 2008-05-01 10:05:41 EDT
OK, reading some more...

I've examined the po file. The characters appear to be encoded correctly. I've
done a boot, and they are rendered as something that appears to be correct. What
specifically are you seeing?
Comment 3 Răzvan Sandu 2008-05-01 10:23:19 EDT
Hello,

For example, all initscripts scripts launch some daemon and write "Starting
daemon X"... In Romanian, this is translated as "Se porneşte daemon X". The
sixth character from the second word appears as a square instead of s with comma
below.

Regards,
Răzvan
Comment 4 Bill Nottingham 2008-05-01 10:34:04 EDT
I can't reproduce that - I see the proper character.

Can you attach your /etc/sysconfig/i18n? Is this on startup, shutdown, or both?
Comment 5 Răzvan Sandu 2008-05-01 10:53:07 EDT
Here it is:

LANG="ro_RO.UTF-8"
SYSFONT="latarcyrheb-sun16"

It is both at init and shutdown, doesn't matter.

Regards,
Răzvan
Comment 6 Bill Nottingham 2008-05-01 11:00:42 EDT
Hm. I only see this for the character in 'starting udev', which is unfortunately
unavoidable. (That's run before the font is set.) The rest are fine.

Are you booting with any unusual console parameters? If you use rhgb, does it
show correctly there?
Comment 7 Răzvan Sandu 2008-05-02 12:39:03 EDT
Hello,

You're right - sorry, it was only on "starting udev". I don't know why, it was
displayed correctly in F8...

However, characters displayed are incorrect: cedilla-below versions of s/S, t/T
characters are rendered instead of the comma-below ones.

Regards,
Răzvan
Comment 8 Bill Nottingham 2008-05-02 12:54:52 EDT
The font was set differently in F8 than it is in F9. It's now run via a console
udev rule instead of hardcoded.

As to the characters, they are the correct unicode codepoint. Any issues with
cedilla vs. comma would be an issue with the font itself. Therefore, moving to kbd.

Comment 9 Răzvan Sandu 2008-05-04 12:35:11 EDT

*** This bug has been marked as a duplicate of 329071 ***

Note You need to log in before you can comment on or make changes to this bug.