This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 440992 - [ro] Correct Romanian glyphs in Liberation Fonts.
[ro] Correct Romanian glyphs in Liberation Fonts.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
http://www.secarica.ro
: i18n
Depends On: 251890 337271 444392
Blocks: 450061
  Show dependency treegraph
 
Reported: 2008-04-04 16:35 EDT by Răzvan Sandu
Modified: 2010-05-10 14:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 03:25:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of triage. (122.85 KB, image/png)
2008-04-10 21:09 EDT, Caius Chance
no flags Details
Test Case created and used. (94.50 KB, application/msword)
2008-04-10 21:09 EDT, Caius Chance
no flags Details
Example of right and wrong Romanian characters in DejaVu Serif (41.90 KB, application/pdf)
2008-04-21 01:22 EDT, Răzvan Sandu
no flags Details

  None (edit)
Description Răzvan Sandu 2008-04-04 16:35:38 EDT
Description of problem:

When used on a system configured for Romanian language, liberation-fonts
generates wrong characters:

- "T with cedilla below" (Unicode 0162) instead of "T with comma below" (Unicode
021A)
- "t with cedilla below" (Unicode 0163) instead of "t with comma below" (Unicode
021B)
- "S with cedilla below" (Unicode 015E) instead of "S with comma below" (Unicode
0218)
- "s with cedilla below" (Unicode 015F) instead of "s with comma below" (Unicode
0219)

For non-Romanian developers: there is no such thing as „cedilla-below”
characters in Romanian language; please see http://www.secarica.ro

Version-Release number of selected component (if applicable):
liberation-fonts.noarch 0:1.0-4.fc9

How reproducible:
Always.

Steps to Reproduce:

1. Install latest Fedora (development)
2. Configure it for Romanian language
3. Open a new text document in OpenOffice.org
4. Press AltGr+s and AltGr+t (and Shift for capitals) to insert the specific
Romanian characters.
  
Actual results:
Characters with cedilla below are inserted in the document.

Expected results:
Characters with comma below should be inserted.

Additional info:
This is a historical bug for Romanian language implementations, still not solved .
Comment 1 Caius Chance 2008-04-07 03:12:19 EDT
bug#251890 need to be resolved by manufacturer before this one to be handled.
Comment 2 Caius Chance 2008-04-10 20:55:59 EDT
Hi Razvan, I don't have AltGr key on my keyboard to perform the following step:

4. Press AltGr+s and AltGr+t (and Shift for capitals) to insert the specific
Romanian characters.

I used gucharmap to manually check the characters, here are the findings:

- "S with cedilla below" (Unicode 015E) and "s with cedilla below" (Unicode
015F) look alright, it looks like cedilla but not comma (I read the
http://www.secarica.ro).

- "T with cedilla below" (Unicode 0162) and "t with cedilla below" (Unicode
0163) look incorrectly. As you mention, they are like 'T' and 't' with a comma
below but not a cedilla.

Please be aware that, the latest Fedora is using 'Sans', 'Serif', 'Monospace'
alias as its default fonts which they are variable depends on availability of
installed fonts.

I am taking screenshots and reporting to author about this. Thank you very much.
Comment 3 Caius Chance 2008-04-10 21:09:03 EDT
Created attachment 302092 [details]
Screenshot of triage.

The 'T' and 't' have comma below them that is not right. They should look like
the 'S' and 's' on the left the them.
Comment 4 Caius Chance 2008-04-10 21:09:34 EDT
Created attachment 302093 [details]
Test Case created and used.
Comment 5 Răzvan Sandu 2008-04-21 00:49:42 EDT
Hello and thanks !

Please use *the Alt key at right of the spacebar on any US keyboard* to
reproduce this.

Regards,
Răzvan
Comment 6 Răzvan Sandu 2008-04-21 00:56:28 EDT
Hello, Caius & all,


IMPORTANT - regarding comment #3 and attached image, please note that the comma
characters are the *good* ones, the cedilla characters the *wrong* ones ! That
is exactly the reverse of comment #3.

Please see the correct assignements of Unicode codes in the text of my initial bug.


Regards,
Răzvan
Comment 7 Răzvan Sandu 2008-04-21 01:22:12 EDT
Created attachment 303102 [details]
Example of right and wrong Romanian characters in DejaVu Serif
Comment 8 Caius Chance 2008-04-30 20:15:15 EDT
Because the initial manufacturer was not servicing these code points, we will
take care of this bug again after we has hosted this font in fedorahosted.org:

https://fedorahosted.org/liberation-fonts/

Currently, please keep an eye on this bug for our progress:

https://bugzilla.redhat.com/show_bug.cgi?id=444392
Comment 9 Răzvan Sandu 2008-05-08 02:16:36 EDT
The issue about Romanian incorrectly-generated characters was recently corrected
in bug #13277 at freedesktop.org.

Please see comments #82 and #83, with the appropriate patch:

http://bugs.freedesktop.org/show_bug.cgi?id=13277

Would you please include this correction in Red Hat/Fedora ASAP, since it
affects *thousands* of documents and webpages generated in Romanian language ?

Thanks a lot,
Răzvan
Comment 10 Bug Zapper 2008-05-14 04:55:09 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Răzvan Sandu 2008-05-30 04:46:33 EDT
Hello,

bug #444392 was CLOSED NEXTRELEASE.

Can we expect this issue being fixed in nextrelease, too ?

Thank you very much,
Răzvan
Comment 12 Caius Chance 2008-06-01 20:01:38 EDT
Hi Răzvan, I am looking into this bug. Thank you very much. Caius.
Comment 13 Caius Chance 2008-06-01 20:52:12 EDT
Hi Răzvan,

I've created the 4 glyphs you requested (and fixed the U+0162/0163 which
supposed to be cedilla under) and created this Sans Regular TTF for you to test:

https://fedorahosted.org/liberation-fonts/browser/archive/ttf_1_04c_bz440992_test/LiberationSans-Regular.ttf?format=raw

If you feel that's working alright, then I'll fix the remaining fonts and let
you kindly check out.

Best Regards, Caius.
Comment 14 Răzvan Sandu 2008-06-02 06:44:51 EDT
Caius,

Thank you VERY MUCH for your help (for the whole Romanian community).

Since I'm not a developer myself (I'm just a network admin), I'll contact the
Romanian localization team and see if the proposed patch is OK. Then I'll let
you know ASAP.

Thank you again,
Răzvan
Comment 15 Alexandru Szasz 2008-06-02 12:07:00 EDT
Hi Caius,

We need at least another character:
http://www.fileformat.info/info/unicode/char/2011/index.htm (NON-BREAKING
HYPHEN, U+2011)
Comment 16 Caius Chance 2008-06-02 19:43:27 EDT
Hi, looking into it, cheers.

(In reply to comment #15)
> Hi Caius,
> 
> We need at least another character:
> http://www.fileformat.info/info/unicode/char/2011/index.htm (NON-BREAKING
> HYPHEN, U+2011)

Comment 17 Caius Chance 2008-06-02 20:17:35 EDT
Created the U+2010 and U+2011 in Sans Regular for testing:

https://fedorahosted.org/liberation-fonts/browser/archive/ttf_1_04c_bz440992_test/LiberationSans-Regular.ttf?format=raw

Thank you very much for your info and feedback.
Comment 18 Alexandru Szasz 2008-06-03 01:16:15 EDT
Looks good, I think this bug can be closed.
Comment 19 Caius Chance 2008-06-03 22:23:11 EDT
Hi Alexandru, sorry about this bug is not ready to be closed yet. The above
testing ttf is just a sample to see if the patch is correct. There are still
Liberation Sans/Serif/Mono x Regular/Bold/Italic/BoldItalic (i.e. 11 of them are
remaining) waiting to be fixed.

I will process it and put it available for your further testing very soon. Thank
you very much for your commitment.
Comment 20 Răzvan Sandu 2008-06-04 02:52:12 EDT
Hello, Caius & all,

When system is set to Romanian (by anaconda, at install time or via
system-config-language, afterwards), in /etc/sysconfig/i18n we get a line:

SYSFONT="latarcyrheb-sun16"

Caius, please, do you know from which .rpm package these default fonts come from ?

We must file & resolve a bug regarding the comma/cedilla issue for these default
fonts and I don't know where to adress it, exactly.

This is extremely important, since the "latarcyrheb-sun16" is the first thing
that system "sees" after boot and we've already got some crashes due to
incorrect encoding. In some situations, some programs (including anaconda)
worked OK when set to English, but tracebacks occured when set to Romanian.


Thanks a lot,
Răzvan
Comment 21 Caius Chance 2008-06-04 03:41:26 EDT
Hi Răzvan,

(In reply to comment #20)

Hmm, it looks quite serious, doesn't it?

It's belonged to 'kbd' package in recent Fedora. Please feel free to file
another bug on that package for requesting supports on the issues you kindly
discovered.

Cheers, Caius.
Comment 22 Alexandru Szasz 2008-06-04 05:36:12 EDT
(In reply to comment #20)
> Hello, Caius & all,
> 
> When system is set to Romanian (by anaconda, at install time or via
> system-config-language, afterwards), in /etc/sysconfig/i18n we get a line:
> 
> SYSFONT="latarcyrheb-sun16"
> 

Are you sure? I've installed Fedora 9 i386 and x86_64 several times and
/etc/sysconfig/i18n looks like this:

LANG="ro_RO.UTF-8"
SYSFONT="Lat2-Terminus16"

I did use the graphical installer all the time. It may be only in text mode,
I'll test this.

Meantime here's a list of related bugs where this was addressed:

- comments 23 and 24 in bug 253892

- bug list:
https://bugzilla.redhat.com/buglist.cgi?version=&component=anaconda&bug_status=NEW&bug_status=ASSIGNED&bug_status=NEEDINFO&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&bug_status=FAILS_QA&bug_status=RELEASE_PENDING&bug_status=POST&bug_status=PASSES_QA&bug_status=CLOSED&short_desc_type=allwordssubstr&short_desc=Romanian&long_desc_type=allwordssubstr&long_desc=
before opening a new bug.



Comment 23 Răzvan Sandu 2008-06-04 07:48:47 EDT
Sorry, my fault !

All systems I have at hand, running F9, were *upgraded* from F8, not fresh
installs. So Terminus is now, in F9, the default font when setting system to
Romanian ?


However:

- changing the default font is just a temporary solution, IMHO.
"latarcyrheb-sun16" should also include the correct glyphs for the Romanian
language;

- when upgrading a (*Romanian*) system from F8 to F9, why don't we change that
line in /etc/sysconfig/i18n during the upgrade itself ? Is that the correct
behaviour ?

- as for the keyboard configurator (system-config-keyboard, in both X and text
mode), it seems it dissapeared from the System menu, in F9. And I see no
replacement for it...


Regards,
Răzvan





Comment 24 Răzvan Sandu 2008-06-04 07:51:10 EDT
Regarding comment #23, probably the correct behaviour at point no. 2 is to leave
that line alone, but have the correct glyphs in "latarcyrheb-sun16"  ;-)

Regards,
Răzvan
Comment 25 Alexandru Szasz 2008-06-04 08:00:32 EDT
(In reply to comment #23)
> Sorry, my fault !
> 
> All systems I have at hand, running F9, were *upgraded* from F8, not fresh
> installs. So Terminus is now, in F9, the default font when setting system to
> Romanian ?

Yes, it was the quick solution.

> 
> 
> However:
> 
> - changing the default font is just a temporary solution, IMHO.
> "latarcyrheb-sun16" should also include the correct glyphs for the Romanian
> language;

I head that Fedora is planning to convert the X fonts to terminal fonts and drop
all the terminal fonts, so maybe it's worth investigating this first.

> 
> - when upgrading a (*Romanian*) system from F8 to F9, why don't we change that
> line in /etc/sysconfig/i18n during the upgrade itself ? Is that the correct
> behaviour ?

I'm afraid so, rpm upgrade keeps existing configuration.

> 
> - as for the keyboard configurator (system-config-keyboard, in both X and text
> mode), it seems it dissapeared from the System menu, in F9. And I see no
> replacement for it...

Search bugzilla or ask in the mailing list what plans are there for
system-config-keyboard and system-config-language in the future.

Here is a link: http://translate.fedoraproject.org/module/ that you can use to
find out where to report a bug to a component. Click on the module you want and
see a link to report a bug
Comment 26 Nicolas Mailhot 2008-06-04 08:11:49 EDT
(In reply to comment #25)
> (In reply to comment #23)

> > However:
> > 
> > - changing the default font is just a temporary solution, IMHO.
> > "latarcyrheb-sun16" should also include the correct glyphs for the Romanian
> > language;
> 
> I head that Fedora is planning to convert the X fonts to terminal fonts and drop
> all the terminal fonts, so maybe it's worth investigating this first.

As far as I know what's planned is conversion of X keyboard layouts to console
layouts. I doubt converting complex vector TTF/OTF fonts to dumb bitmap console
fonts is possible without major human involvment.
Comment 27 Caius Chance 2008-06-04 20:38:08 EDT
FYI, The font Alexandru mentioned is also within same console font package:

$ rpm -qf /lib/kbd/consolefonts/Lat2-Terminus16.psf.gz
kbd-1.12-31.fc9.i386

I agree Nicolas about converting complex vector TTF/OTF fonts to dumb bitmap
console fonts. Even if the TTF/OTF embedded bitmap glyphs, font style
consistency/readability might also be an issue.
Comment 28 Caius Chance 2008-06-04 20:57:11 EDT
For the best handling by console font maintainer, file a bug against 'kbd' and
resuming this discussion stream on console font might be appropriate:
https://bugzilla.redhat.com/show_bug.cgi?id=450061
Comment 29 Caius Chance 2008-06-12 02:53:07 EDT
Hi, I have modified all of the fonts same as what I have done on Sans-Regular
for testing:

https://fedorahosted.org/liberation-fonts/browser/sandbox/ttf_1_04c_bz440992_test

Please feel free to have a look. If everything is okay, I will close this bug
and release official ver 1.04.

Thank you very much.
Comment 30 Caius Chance 2008-06-12 02:55:17 EDT
"Created (U+0218..021B, U+2010..2012) and Fixed (U+0162/0163)."
Comment 31 Caius Chance 2008-06-12 03:14:44 EDT
Packaged editions:

https://fedorahosted.org/releases/l/i/liberation-fonts/
Comment 32 Caius Chance 2008-06-17 01:26:37 EDT
Hi Alexandru, I have packed the patched fonts (at comment #31) and some simple
tests are done. Please feel free to let me know if you got problems on that.
Otherwise, I will close this bug as resolved in a week.
Comment 33 Alexandru Szasz 2008-06-17 01:39:58 EDT
It looks great, Caius. Thank you for your work, I now have a new favourite font.
You can close this anytime.
Comment 34 Caius Chance 2008-06-17 02:20:48 EDT
FYI, this version has been pushed to rawhide (nightly development version of
fedora) for public testing, too. Please kindly reopen this bug when you see
anything regarding to these glyphs in the future.
Comment 35 Alexandru Szasz 2009-11-13 06:07:00 EST
Somehow this change is not present in Fedora 12.
Comment 36 Nicu Buculei 2009-11-13 06:09:50 EST
confirmed, liberation fonts 1.05 (Fedora 12) and the latest sources from fedorahosted have the glyphs empty (checked with fontforge), it looks like the change was somehow reverted
Comment 38 Caius Chance 2010-05-10 03:25:38 EDT
Fixed:

http://koji.fedoraproject.org/koji/buildinfo?buildID=172693

Note You need to log in before you can comment on or make changes to this bug.