Bug 444973 - nash nfsmount doesn't respect mount options + proposed patch
nash nfsmount doesn't respect mount options + proposed patch
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.3
All Linux
urgent Severity high
: rc
: ---
Assigned To: Peter Jones
Alexander Todorov
: ZStream
: 240745 471115 (view as bug list)
Depends On: 240745
Blocks: 391501 455534
  Show dependency treegraph
 
Reported: 2008-05-02 10:22 EDT by Adam Stokes
Modified: 2010-10-22 20:40 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:11:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch which will hopefully fix the issue. (2.88 KB, patch)
2008-05-27 13:20 EDT, Peter Jones
no flags Details | Diff
patch witch fixes compiler error - undefined variable (510 bytes, text/plain)
2008-06-02 14:17 EDT, IBM Bug Proxy
no flags Details
patch to handle nfs "proto=" mount option correctly (585 bytes, text/plain)
2008-06-02 14:17 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Comment 4 Peter Jones 2008-05-27 13:20:02 EDT
Created attachment 306802 [details]
A patch which will hopefully fix the issue.

I don't think the patch posted is quite correct; can the customer test with
this attached patch instead?
Comment 8 IBM Bug Proxy 2008-06-02 14:17:01 EDT
------- Comment From jroth@de.ibm.com 2008-06-02 14:10 EDT-------
I just applied Peter's patch and I got a undefined variable error.
I'll attach a patch which fixes this small problem.

I applied this patch on top of mkinitrd-5.1.19.6-28.src.rpm

The patch works for comma-separated mount options. But it doesn't work for
proto=tcp nor for proto=udp

proto=tcp,nolock would end up with the following error:

-----
Mounting root filesystem.
unknown nfs mount parameter: proto=0
-----

As a result the nfsroot filesystem cannot be mounted.

The nfs manpage says that both, "proto=tcp" and "tcp" can be used as mount option.
Therefore proto=tcp or proto=udp should also be handled. I'll attach a patch
which fixes this issue.
Comment 9 IBM Bug Proxy 2008-06-02 14:17:09 EDT
Created attachment 307544 [details]
patch witch fixes compiler error - undefined variable
Comment 10 IBM Bug Proxy 2008-06-02 14:17:14 EDT
Created attachment 307545 [details]
patch to handle nfs "proto=" mount option correctly
Comment 11 RHEL Product and Program Management 2008-06-02 16:02:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 16 Peter Jones 2008-07-15 14:43:26 EDT
This should be resolved in mkinitrd-5.1.19.6-29 .
Comment 20 IBM Bug Proxy 2008-10-30 06:20:41 EDT
Problem doesn't exist anymore. Bug is fixed. Thanks!

[root@localhost ~]# cat /proc/mounts
rootfs / rootfs rw 0 0
10.0.0.1:/rhel5u3beta / nfs rw,vers=3,rsize=32768,wsize=32768,hard,nolock,proto=tcp,timeo=70,retrans=3,sec=sys,addr=10.64.0.1 0 0
Comment 22 Flavio Leitner 2008-11-12 07:05:31 EST
*** Bug 471115 has been marked as a duplicate of this bug. ***
Comment 23 Ed Swierk 2008-11-16 02:59:00 EST
Can you please push the latest fix for this issue (http://git.fedoraproject.org/git/?p=mkinitrd;a=commit;h=069a9a57081706f42cce249837a0619c9b8aa535) to F10?  I'd prefer not to have to patch mkinitrd again.
Comment 25 errata-xmlrpc 2009-01-20 17:11:30 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0237.html
Comment 28 Peter Jones 2009-02-17 14:40:41 EST
*** Bug 240745 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.