Bug 44518 - Default font randomly changes
Default font randomly changes
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-06-13 19:10 EDT by Matthew Schumacher
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-20 23:04:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
requested files (38.02 KB, application/octet-stream)
2001-06-19 13:20 EDT, Matthew Schumacher
no flags Details

  None (edit)
Description Matthew Schumacher 2001-06-13 19:10:48 EDT
Description of Problem:

I have RedHat 7.1 with WindowMaker, using the default rpms.  After using my
workstation for about an hour the default font suddenly changes and all of
the xterms or rxvt terms I start use a huge font.  I can get the old font
back by passing `-fn
-Misc-Fixed-Medium-R-SemiCondensed--13-120-75-75-C-60-ISO8859-1` to rxvt
when starting it, but all of my other applications such as Netscape and
VMWare start with the large font.  If I run a `showfont -server unix/:7100
-fn fixed` before and after the font changes I get the same output so I am
unable to track down which component  has the problem.

How Reproducible:

I can't run a script or application to make it happen, but I've been unable
to work for more than an hour without it happening.  Perhaps someone can
suggest a way to reproduce it.

Steps to Reproduce:

Actual Results:

Expected Results:

Additional Information:
I will do anything I can to try to help resolve the bug, however I am not a

Thanks for your time...

Matthew  Schumacher
Comment 1 Mike A. Harris 2001-06-19 00:53:26 EDT
Please look at bug #42251, and tell me if it is similar.  Check out
the screen shots there also.

Can you provide me with:

1) Your X server logs from /var/log from before and after this occurs.
2) Does it occur after a VC switch, or any other wierd time?
3) Your XFree86 config file(s)
4) Your xfs config file (/etc/X11/fs/config)
5) A screenshot of before and after the problem.  You can use "ksnapshot",
   gimp, or in GNOME you can use screenshooter.

Comment 2 Matthew Schumacher 2001-06-19 13:19:33 EDT
 1)  The logs are attached.  One from a X session where the font changed
(before), and one from a new X session that has not had the issue (after).

 2) What is a VC switch?  I have been unable to make it happen with any
paticular application.  More like I am working on something, start a new rxvt
and it starts with a different default font.

 3) The XFree86 config file is attached.

 4) The xfs config file is attached.

 5) The before and after screenshots are attached.



Comment 3 Matthew Schumacher 2001-06-19 13:20:23 EDT
Created attachment 21326 [details]
requested files
Comment 4 Matthew Schumacher 2001-06-19 13:23:35 EDT
The above attachment is a tar.gz file so it needs to be unziped.  Also, I do not
think that the issue is related to bug 42251 because I only need to restart the
X server to get back to square one.

Comment 5 Matthew Schumacher 2001-06-21 17:23:34 EDT
So far I have tried these things to isolate the problem without sucess:

  Removed the following RPMS:
    windowmaker (and related tools)

  Installed newest version of netscape from their site (4.77)
  Compiled and installed newest WindowMaker 0.65.0
  quit using rvxt and started using aterm which I compiled from source

I also avoided using the following applications until the font changed to make
sure it wasn't any paticular application that is causing the problem.

My next step is to upgrade to XFree86 4.0.3 to see if the problem only happens
in XFree86 4.0.1.  If that doesn't work I will likely format and reinstall
RedHat 7.1 to make sure the bug will live outside my system.

Comment 6 Mike A. Harris 2001-06-30 02:20:39 EDT
Are you saying you are using Red Hat Linux 7.1 with XFree86 4.0.1?

By the way, please attach single uncompressed files as file attachments
next time.  It is easier to access and read while going through reports.

Is this a Laptop?
Comment 7 Matthew Schumacher 2001-06-30 04:22:24 EDT
I had the problem on the default XFree86 (4.0.1) so I tried installing the latest XFree86 (4.0.3) and continue to have the problem.

I am about ready to reinstall, what do you think?
Comment 8 Mike A. Harris 2002-02-09 05:34:59 EST
The default XFree86 in Red Hat Linux 7.1 _is_ 4.0.3.  4.0.1 is
from Red Hat Linux 7.0.  All I can suggest is trying the latest XFree86
update we've released XFree86 4.1.0-15, and all other updates we've released,
and if the problem persists, please attach new server logs, config files,
etc. as individual uncompressed file attachments, and we'll try to
troubleshoot this problem further.  Also, is this a laptop?

Comment 9 Mike A. Harris 2002-04-20 23:04:48 EDT
Please indicate if this problem is still present in Red Hat Linux 7.2
for you.
Comment 10 Mike A. Harris 2002-05-17 19:59:14 EDT
I'm unable to reproduce this in any 7.[123] release of the distribution,
so I'm not sure what might cause it for you.  I'm closing this as
CURRENTRELEASE.  If the problem persists however, I suggest reporting
it to XFree86.org directly at xfree86@xfree86.org, fonts@xfree86.org,

Note You need to log in before you can comment on or make changes to this bug.