Bug 445186 - strange percentage in progress bar
strange percentage in progress bar
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-urlgrabber (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 445308 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 06:59 EDT by Marcela Mašláňová
Modified: 2014-01-21 18:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 09:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2008-05-05 06:59:34 EDT
Description of problem:
There are strange percentage, when you install something.
Example:
(3/5): kdevelop-3.5.1-  53% |  59% |=====     | 456 kB/s | 8.7 MB     00:13 ETA

Version-Release number of selected component (if applicable):
yum-3.2.14-10.fc9.noarch
PackageKit-0.1.12-9.20080502.fc9.i386

How reproducible:
install bigger rpm

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Downloading Packages:
(1/5): qt3-designer-3.3.8b-12.fc9.i386.rpm               | 1.9 MB     00:04
(2/5): ctags-5.7-1.fc9.i386.rpm                          | 136 kB     00:00
(3/5): kdevelop-3.5.1-  53% |  59% |=====     | 456 kB/s | 8.7 MB     00:13 ETA

Expected results:
Downloading Packages:
(1/5): qt3-designer-3.3.8b-12.fc9.i386.rpm               | 1.9 MB     00:04
(2/5): ctags-5.7-1.fc9.i386.rpm                          | 136 kB     00:00
(3/5): kdevelop-3.5.1-  59% |=====     | 456 kB/s | 8.7 MB     00:13 ETA

Additional info:
Comment 1 Mary Ellen Foster 2008-05-05 08:15:59 EDT
I believe that's the output of the new "urlgrabber" that shows the cumulative
percentage for all downloads as well as the percentage for each individual download.
Comment 2 James Antill 2008-05-05 09:07:16 EDT
 Right, if you have more than one download you'll get two percentages ... the
first being the total percentage.
 If you have an idea of how to make this less confusing, or more obvious what it
is, we'll be more than happy to look at any suggestions. We'll also probably be
tweaking the output for Fed-10 anyway, as we overhaul the downloading code.
Comment 3 Mary Ellen Foster 2008-05-05 09:12:46 EDT
Well, no suggestions about the output format exactly, but I do have a suggested
patch to make it adjust to the terminal width in bug 437197 ... :)
Comment 4 Marcela Mašláňová 2008-05-05 09:21:11 EDT
Hm move the total percentage on the end of line? Hard to say, what is less
confusing.
Comment 5 James Antill 2008-05-06 09:18:04 EDT
*** Bug 445308 has been marked as a duplicate of this bug. ***
Comment 6 Stewart Adam 2008-05-06 17:15:15 EDT
In my opinion, there's too much going on - a total percentage is redundant since
yum displays (package/totalPackage) and the current download's progress. As
well, a progress bar and percentage for current package is also redundant.

I'm thinking of something like this:
(AAA/BBB): packagename-ver |==============| CCCXB / DDDXB (EEEXB/S HH:MM:SS ETA)

AAA = Current package #
BBB = Total package count
CCC = Amount downloaded
DDD = Package size
XB = B, KB, MB, GB
EEE = Current download speed

or alternatively this one includes the package download % but not a progress bar:

(AAA/BBB): packagename-ver  |  CCCXB / DDDXB  |  EEEXB/S   |  (FF% HH:MM:SS ETA)

This case is the same as the last but FF is the % downloaded.

To keep the total percentage, I think it would make most sense to stick it in
the brackets (ie AAA/BBB - XX%)... It's right next to the total package count,
so it makes sense that the total % is placed there.

Note You need to log in before you can comment on or make changes to this bug.