Bug 445253 - dm_task_run failed during --resync attempt or a mirror
dm_task_run failed during --resync attempt or a mirror
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Jonathan Earl Brassow
Corey Marthaler
: Reopened
Depends On: 813954 1077405
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 15:32 EDT by Corey Marthaler
Modified: 2014-12-11 18:09 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:49:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-05-05 15:32:47 EDT
Description of problem:
I was running a resyncing test case and saw it fail after it had passed the
previous 22 times.

============================================================
Iteration 23 of 10000 started at Mon May  5 12:52:42 CDT 2008
============================================================
SCENARIO - [mirror_resynchronization]
Create mirrors and resync them
Creating nosync mirror...
  WARNING: New mirror won't be synchronised. Don't read what you didn't write!
Verifing percent is finished at 100%

Creating regular mirror...
Verifing copy percent 14% is 0% < x < 100%

Deactivating resync_regular mirror
Deactivating resync_nosync mirror

Resyncing resync_regular mirror
  /dev/mirror_sanity/resync_regular_mlog: not found: device not cleared
  Unable to reset sync status for resync_regular
  Error locking on node hayes-01: LV mirror_sanity/resync_regular_mlog in use:
not deactivating
  Failed to deactivate log LV after wiping failed
couldn't resync resync_regular

Here's what was in the log:
May  5 12:52:57 hayes-01 qarshd[31165]: Running cmdline: lvchange --resync -y
mirror_sanity/resync_regular
May  5 12:52:57 hayes-01 [5718]: Monitoring mirror device
mirror_sanity-resync_regular for events
May  5 12:52:58 hayes-01 lvm[5718]: dm_task_run failed, errno = 22, Invalid argument
May  5 12:52:58 hayes-01 lvm[5718]: No longer monitoring mirror device
mirror_sanity-resync_regular for events
May  5 12:52:59 hayes-01 xinetd[2627]: EXIT: qarsh status=0 pid=31165
duration=2(sec)
May  5 12:52:59 hayes-01 kernel: device-mapper: dm-log-clustered: Request timed
out on DM_CLOG_GET_SYNC_COUNT:8843
5 - retrying


Version-Release number of selected component (if applicable):
2.6.18-92.el5

[root@hayes-01 tmp]# rpm -qi cmirror
Name        : cmirror                      Relocations: (not relocatable)
Version     : 1.1.15                            Vendor: Red Hat, Inc.
Release     : 1.el5                         Build Date: Thu 28 Feb 2008 01:04:29
PM CST
Install Date: Mon 05 May 2008 12:01:17 PM CDT      Build Host:
hs20-bc1-7.build.redhat.com

[root@hayes-01 tmp]# rpm -qi kmod-cmirror
Name        : kmod-cmirror                 Relocations: (not relocatable)
Version     : 0.1.8                             Vendor: Red Hat, Inc.
Release     : 1.el5                         Build Date: Thu 28 Feb 2008 01:01:13
PM CST
Install Date: Mon 05 May 2008 12:01:17 PM CDT      Build Host:
ls20-bc1-14.build.redhat.com

[root@hayes-01 tmp]# rpm -qi lvm2
Name        : lvm2                         Relocations: (not relocatable)
Version     : 2.02.32                           Vendor: Red Hat, Inc.
Release     : 4.el5                         Build Date: Fri 04 Apr 2008 06:15:19
AM CDT
Install Date: Mon 05 May 2008 11:26:24 AM CDT      Build Host:
hs20-bc2-3.build.redhat.com
Comment 1 Jonathan Earl Brassow 2008-05-07 16:02:00 EDT
"lvm[5718]: dm_task_run failed, errno = 22, Invalid argument"
indicates a problem with device-mapper... should test single machine mirror to
ensure this is not isolated to cmirror.
Comment 2 Jonathan Earl Brassow 2008-05-15 14:43:18 EDT
Is this reproducible on single machine mirroring?

This is not likely to be a cmirror problem, but an LVM problem.... Also, why is
the mirror being monitored only to clear the log device.  The mirror should not
be active when the command is run.
Comment 3 Jonathan Earl Brassow 2008-05-15 15:58:01 EDT
<off topic>
May  5 12:52:57 hayes-01 qarshd[31165]: Running cmdline: lvchange --resync -y
mirror_sanity/resync_regular
May  5 12:52:57 hayes-01 [5718]: Monitoring mirror device
mirror_sanity-resync_regular for events
May  5 12:52:58 hayes-01 lvm[5718]: dm_task_run failed, errno = 22, Invalid argument
May  5 12:52:58 hayes-01 lvm[5718]: No longer monitoring mirror device
mirror_sanity-resync_regular for events

I've submitted a patch to lvm-devel to reduce this monitor/unmonitor cycling...
</off topic>
Comment 4 Corey Marthaler 2008-05-16 11:21:51 EDT
I haven't been able to reproduce this using the same test case on single machine
mirrors.
Comment 5 RHEL Product and Program Management 2008-07-14 11:01:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 RHEL Product and Program Management 2008-07-14 16:58:14 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 7 Corey Marthaler 2008-07-15 09:45:37 EDT
How about in RHEL5.4, can we fix this there?
Comment 8 Jonathan Earl Brassow 2008-09-29 17:36:53 EDT
Yes, we should be able to fix in 5.4...  Changing component to device-mapper.
Comment 13 Jonathan Earl Brassow 2012-06-07 18:16:36 EDT
A new bug has been created to address all 'dm_task_run' failures (bug 813954).  This bug will no longer be prioritized.
Comment 14 RHEL Product and Program Management 2014-03-07 08:57:53 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 15 RHEL Product and Program Management 2014-06-03 08:49:53 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.