Bug 1077405 - Various dm_task_run failures cause many continuing problems in LVM
Summary: Various dm_task_run failures cause many continuing problems in LVM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.0
Hardware: x86_64
OS: Linux
high
low
Target Milestone: rc
: ---
Assignee: Peter Rajnoha
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On: 813954
Blocks: 1049888 1113520 1203710 1205796 1313485 445253 644071 654116 1295577
TreeView+ depends on / blocked
 
Reported: 2014-03-17 22:36 UTC by Corey Marthaler
Modified: 2018-12-03 21:04 UTC (History)
14 users (show)

Fixed In Version: lvm2-2.02.152-1.el7
Doc Type: Bug Fix
Doc Text:
dmeventd code has been updated to recent version which includes numerous fixes, including fixes for various possible errors issued about dm_task_run calls.
Clone Of: 813954
Environment:
Last Closed: 2016-11-04 04:07:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Comment 2 RHEL Program Management 2014-03-25 05:47:20 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Zdenek Kabelac 2014-11-25 14:58:55 UTC
I'm convinced it could be matched with Bug #1108540 since dmeventd is directly involved. It's fixed with release of 2.02.112

Comment 5 Peter Rajnoha 2014-12-17 09:00:16 UTC
We need to inspect more here - I don't think this is exactly the same as bug #1108540 - the errors differ. While in bug #1108540 we always had "dm_task_run failed, errno = 6, No such device or address", here we have "dm_task_run failed, errno = 22, Invalid argument" which seems to be a different issue (wrong table supplied while dmeventd is trying to fixup LVs).

Comment 11 Zdenek Kabelac 2015-11-05 13:13:40 UTC
New dmeventd code in version 2.02.133 should resolve most of spurious  dm_task_run errors flowing out of dmeventd process.

My view here is - once we release this version - and we get another fail case with dm_task_run - take it as a new bug.

Comment 15 Mike McCune 2016-03-28 23:21:47 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 17 Corey Marthaler 2016-08-03 18:49:40 UTC
I have not seen any of these messages in quite some time on any of the nodes doing raid regression testing. Marking verified.


3.10.0-480.el7.x86_64

lvm2-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
lvm2-libs-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
lvm2-cluster-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-libs-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-event-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-event-libs-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-persistent-data-0.6.3-1.el7    BUILT: Fri Jul 22 05:29:13 CDT 2016
cmirror-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
sanlock-3.4.0-1.el7    BUILT: Fri Jun 10 11:41:03 CDT 2016
sanlock-lib-3.4.0-1.el7    BUILT: Fri Jun 10 11:41:03 CDT 2016
lvm2-lockd-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016

Comment 19 errata-xmlrpc 2016-11-04 04:07:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.