Bug 445383 - Network broken on boot
Network broken on boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 12:27 EDT by Daniel Benamy
Modified: 2008-05-20 05:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 18:37:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Benamy 2008-05-06 12:27:27 EDT
Description of problem:
During boot, it says determining ip info, pauses for 5 - 10 seconds then says
done, but when the system comes up networking doesn't work. I'm using ipv4 dhcp.
After boot:
# /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:16:17:EF:40:47
          inet6 addr: fe80::216:17ff:feef:4047/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4815 (4.7 KiB)  TX bytes:9898 (9.6 KiB)
          Interrupt:17 Base address:0x4000
There's no ipv4 address.
Also I think the network manager list doesn't show eth0. I forgot to double
check. Dunno if that's the right component for this bug though. If I restart
networking, network manager wakes up and I get connected:
# /etc/init.d/network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:
Determining IP information for eth0...dhclient(4455) is already running - exiting.

This version of ISC DHCP is based on the release available
on ftp.isc.org.  Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.

Please report for this software via the Red Hat Bugzilla site:
    http://bugzilla.redhat.com

exiting.
 failed.
                                                           [FAILED]
# /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:16:17:EF:40:47
          inet addr:192.168.0.101  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::216:17ff:feef:4047/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:553 errors:0 dropped:0 overruns:0 frame:0
          TX packets:629 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:418825 (409.0 KiB)  TX bytes:93400 (91.2 KiB)
          Interrupt:17 Base address:0x4000

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.3.svn3623.fc9.x86_64
NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386
I don't know if I'm supposed to have i386 and x86_64 installed.
initscripts-8.76-1.x86_64
upstart-0.3.9-19.fc9.x86_64

How reproducible:
Every time.
Comment 1 Daniel Benamy 2008-05-07 00:57:58 EDT
(In reply to comment #0)
> Description of problem:
...
> Also I think the network manager list doesn't show eth0. I forgot to double
...

I checked again and network manager shows eth0 in the list but it's greyed out.
Comment 2 John Poelstra 2008-05-07 14:58:32 EDT
I found that disabling the 'network' service fixed this... 
https://bugzilla.redhat.com/show_bug.cgi?id=439103#c24
Comment 3 Dan Williams 2008-05-08 14:31:20 EDT
Daniel: does it say "device not managed" underneath the device in the menu?  Can
you paste in the output of '/usr/bin/nm-tool' when this happens?
Comment 4 Daniel Benamy 2008-05-09 18:43:14 EDT
Dan: It does not.

# nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 ----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  HW Address:        00:16:17:EF:40:47

  Capabilities:
    Supported:       yes
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Settings

Thanks for your help!
Comment 5 Daniel Benamy 2008-05-11 19:35:40 EDT
FWIW, adding "/etc/init.d/network restart" to /etc/rc.local didn't help.
Comment 6 Bug Zapper 2008-05-14 06:43:51 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Răzvan Sandu 2008-05-16 16:18:04 EDT
Hello,

It happened to me, too, on a very "classic" and well-supported Ethernet hardware
(Realtek, 2 years old, Gigabit).

- the network service is started very late *or at all* after boot;
- when trying to restart the service I always see that message stating:

Determining IP information for eth0...dhclient(4455) is already running - exiting.

(I am using DHCP over IPv4 too);

- sometimes the network service suddenly cease to work, especially when I'm
away, making the workstation inaccesible from remote;

- despite these instructions (which I've reached from F9 release notes), 

http://fedoraproject.org/wiki/Tools/NetworkManager?action=show&redirect=NetworkManager

there is no NetworkManagerDispatcher service present in ntsysv's list (it once
was, in F8)

- on another machine (laptop), I was unable to fix the "keyring password" issue
for the wireless connection, despite the fact I've followed exactly the
instructions given at
http://fedoraproject.org/wiki/Tools/NetworkManager?action=show&redirect=NetworkManager


Unfortunately, for the moment, I was forced to disable NetworkManager completely
and to resume using the old way (system-config-network), since it proved totally
unsuitable for servers or critical machines that must run continuously.


Regards,
Răzvan
Comment 8 Todd J Martin 2008-05-18 19:06:08 EDT
I'm also seeing where the wired network interface fails to come up after a
reboot on my laptop.  The scenario looks like this.  The wired network is
working and I have disabled the wireless network.  I do a shutdown -r now to
reboot.  After the reboot, I login and see that I have no network access.  Then
I unplug the network cable and then plug it back in.  This triggers
NetworkManager to enable the wired network.
Comment 9 Dan Williams 2008-05-19 07:56:03 EDT
Todd: can you try installing the updated NM from:

http://koji.fedoraproject.org/koji/taskinfo?taskID=608593

That should fix your problem.
Comment 10 Todd J Martin 2008-05-19 11:28:21 EDT
Those updates worked for me.  I ran the exact same test as before twice and saw
no problems.  Thanks, Dan.
Comment 11 Daniel Benamy 2008-05-19 15:02:50 EDT
I just discovered that restarting the NetworkManager service makes it start
working. I don't need to restart networking. And I thought I'd give those new
packages a shot, but they didn't help me.
Comment 12 Răzvan Sandu 2008-05-19 17:35:48 EDT
Hello,

Thanks all developers for the fix !

I've applied the update in comment #9, then restarted the machine.

Now it seems the network comes up smoothly (at least on my Ethernet interface),
but I experience another problem:

My workstation uses zebra with ripd, to learn RIP routes from a nearby router.
Despite of network working and quagga daemons starting at boot, the routes are
not learnt. That leads to the workstation not being accessible from other
networks that do not share the default gateway with it.

"The fix" was to do an indirect ssh in workstation's default gateway, then in
it, and restart zebra and ripd. RIP routes are learnt again and I'm able to
access my workstation remotely, in a direct way.

That's pretty strange and *never* happens if I disable NetworkManager and use
system-config-network on the workstation.

Any idea, please ?

Regards,
Răzvan
Comment 13 Dan Williams 2008-05-19 18:37:57 EDT
Do zebra and ripd handle network interface changes by listening to netlink
events or similar?  You can also write a dispatcher script to restart zebra and
ripd manually when networking changes by using the examples here:

http://kanarip.blogspot.com/2007/08/networkmanager-and-networkmanagerdispat.html
http://ubuntuforums.org/showthread.php?t=253174

Comment 14 Daniel Benamy 2008-05-20 03:26:33 EDT
Err, something is still broken for me. I don't think the bug should be closed.
Comment 15 Răzvan Sandu 2008-05-20 05:17:28 EDT
Hello,

On comment #13:

Sorry, but this is an important issue for all networks that have more than one
gateway... Could we please find a solution on this for the end user, not for
programmers ?

Many thanks,
Răzvan

Note You need to log in before you can comment on or make changes to this bug.