Bug 445449 - GDM is ignoring options in the custom.conf
GDM is ignoring options in the custom.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 16:54 EDT by Josh Lange
Modified: 2015-01-14 18:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-08 17:50:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (2.94 KB, patch)
2008-05-07 20:34 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Josh Lange 2008-05-06 16:54:03 EDT
I can't seem to be able to turn off the user browser using:
Browse=false

SystemMenu=false properly prevents a user from shutting off the system from gdm
*BUT* it still advertises/allows a user to shut off the system once logged in.

I have a few other options that I need for my setup too, including relaxing
permissions. It would be great to get some insight.

Comments:
GDM appears to have been reworked quite a bit. if there is some new location
where these options should go, it would be good to have comments stating that in
the new custom.conf skeleton.
Comment 1 Josh Lange 2008-05-06 18:48:21 EDT
I tried adding both of these options to the xml "schema" file in the same
directory (using the syntax of the other entries), and the options were still
ignored.

I know the SystemMenu attribute is correct, because its from a gdm configuration
that I migrated from my fedora 7 image.

I might have the wrong impression about the "Browse" entry though. I'm trying to
disable the user selection menu (always prompt the user to enter their
username), user selection is a nuisance when you have dozens of users.
Comment 2 Matthias Clasen 2008-05-06 20:13:37 EDT
There is no configuration option to turn off the user list at this time.
Comment 3 Ray Strode [halfline] 2008-05-06 20:33:26 EDT
Two things though.

1) We're discussing adding the option back
2) The new setup should work fine with dozens of users, because if you type the
username and press enter it will do the right thing (in fact better, because you
only have to type the first few letters of the username)
Comment 4 Josh Lange 2008-05-06 21:18:48 EDT
>Two things though.
>1) We're discussing adding the option back
>2) The new setup should work fine with dozens of users, because if you type the
>username and press enter it will do the right thing (in fact better, because you
>only have to type the first few letters of the username)

It would be nice, we actually have closer to 3,000 users, managed through ldap.
By default (various record/time limits contribute), nss_ldap only returns a
small fraction of these results trough a broad "getent passwd" (its too taxing
on the servers to have 300+ machines running these queries all the time), so
auto-completion would only work for a small subset of our users (and incorrectly
for others?). Having to click "Other", or possibly scrolling to the choice of
"other" will boggle many users in this situation as well.


As for the SystemMenu tag though, that doesn't seem to prevent gnome from
shutting down the host system either.
Comment 5 Josh Lange 2008-05-06 22:12:49 EDT
Some places may even have security policies against allowing a full search of
their ldap databases (making "getent passwd", fail to return ldap entries every
time). (In this case, auto completion might try to complete a local name??)
Comment 6 Ray Strode [halfline] 2008-05-07 09:47:37 EDT
Hi, yea autocompletion only works for local users and ldap users who have logged
in recently/frequently, for precisely that reason (previous versions of gdm
would do the whole getent passwd equivalent and tax the ldap server and come to
a halt).

Maybe Other... should be at the top instead of the bottom.
Comment 7 Josh Lange 2008-05-07 12:01:24 EDT
An option to disable the userlist would still be nice (seems somewhat indirect
to instruct people click "other" under environments where most machines are in
open labs). 

I can imagine some people may miss the "other" entry, when they walk up to a
machine, and are greeted by a somewhat random userlist, that doesn't have their
name on it.

That being said, I agree that it would might be better to have the entry at the
top of the list too, and possibly named "Enter Username...", or something
equivalent.
Comment 8 Josh Lange 2008-05-07 19:33:43 EDT
Should I open a new bug for the SystemMenu=false issue? (it turns out that the
setting is always ignored) or do you guys know about this one?
Comment 9 Matthias Clasen 2008-05-07 20:00:12 EDT
No, greeter options in custom.conf are not coming back. 
The greeter is using gconf for its configuration, and there is already 

 /apps/gdm/simple-greeter/disable_restart_buttons  

Set to TRUE to disable showing the restart buttons in the login window 
Comment 10 Matthias Clasen 2008-05-07 20:34:06 EDT
Created attachment 304821 [details]
patch

Here is a patch that adds a show_users gconf key.
Comment 11 Josh Lange 2008-05-07 21:21:36 EDT
Cool, thanks.

Do you know if this will make it in to fedora 9? or will I have to create a fork
for my setup?
Comment 12 Matthias Clasen 2008-05-08 09:24:43 EDT
We may pull some of these things into an F9 update at some point, but it won't
be there initially.
Comment 13 Fedora Update System 2008-05-10 04:50:26 EDT
banshee-0.99.1-1.1.fc9 has been submitted as an update for Fedora 9
Comment 14 Nigel Jones 2008-05-10 04:53:11 EDT
(In reply to comment #13)
> banshee-0.99.1-1.1.fc9 has been submitted as an update for Fedora 9
Err sorry everyone, This was meant to Bug 445499 but I seemed to enter a 4
instead of a 9.

Sorry.

Note You need to log in before you can comment on or make changes to this bug.