Bug 445515 - can not register to failover RHN server
can not register to failover RHN server
Status: CLOSED DUPLICATE of bug 429334
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: John Matthews
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 07:34 EDT by Jan Hutař
Modified: 2008-05-09 04:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 04:07:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-05-07 07:34:10 EDT
Description of problem:
When there is server set like this in the /etc/sysconfig/rhn/up2date:

serverURL=http://www.yahoo.com;https://xmlrpc.rhn.webqa.redhat.com/XMLRPC;

I can not register. When I register with correct server in the config and then 
set it like this ^, `yum install ...` and so works.


Version-Release number of selected component (if applicable):
rhn-setup-0.4.17-8.el5.noarch
yum-3.2.8-9.el5.noarch
yum-rhn-plugin-0.5.3-6.el5.noarch


How reproducible:
always


Steps to Reproduce:
1. change /etc/sysconfig/rhn/up2date to contain serverURL like that ^
2. # rhn_register


Actual results:
┌─────────────────┤ Fatal Error ├─────────────────┐
│                                                 │
│ We can't contact the Red Hat Network Server.    │
│                                                 │
│ Double check the location provided - is         │
│ 'http://www.yahoo.com/XMLRPC' correct?          │
│ If not, you can correct it and try again.       │
│                                                 │
│ Make sure that the network connection on this   │
│ system is operational.                          │
│                                                 │
│ This system will not be able to successfully    │
│ receive software updates from Red Hat without   │
│ connecting to a Red Hat Network server          │


Expected results:
registration passes


Additional info:
I'm using RHN Proxy 5.0.1 (rhns-proxy-tools-5.0.1-5.rhel4) with RHN Satellite 
5.0.1
This was provided as a yum test-case: https://testopia.devel.redhat.com/
bugzilla/tr_show_case.cgi?case_id=1304 (see "Action" heading there)
Comment 1 daryl herzmann 2008-05-08 09:29:55 EDT
Hi,

I believe I reported this bug back in January:

https://bugzilla.redhat.com/show_bug.cgi?id=429334

daryl
Comment 2 Jan Hutař 2008-05-09 04:07:10 EDT
Hello,
right, thanks! Closing.

*** This bug has been marked as a duplicate of 429334 ***

Note You need to log in before you can comment on or make changes to this bug.