Bug 429334 - rhn_register fails when configured for failover with proxy
rhn_register fails when configured for failover with proxy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Sayli Karmarkar
:
: 445515 (view as bug list)
Depends On:
Blocks: 462646
  Show dependency treegraph
 
Reported: 2008-01-18 14:16 EST by daryl herzmann
Modified: 2015-03-22 21:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:18:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/up2date for rhn_register GUI (with serverURL=https://myproxy/XMLRPC;https://xmlrpc.rhn.redhat.com/XMLRPC;) (5.46 KB, application/octet-stream)
2008-11-04 06:39 EST, Jan Hutař
no flags Details

  None (edit)
Description daryl herzmann 2008-01-18 14:16:51 EST
1) Setup RHN failover:

serverURL=https://myproxy/XMLRPC;https://xmlrpc.rhn.redhat.com/XMLRPC;

2) Run rhn_register and get traceback:

[Fri Jan 18 13:01:22 2008] rhn_register 
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 224, in onLoginPagePrepare
    self.loginPagePrepare()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 403, in loginPagePrepare
    protocol, host, path, parameters, query, fragmentIdentifier =
urlparse.urlparse(server)
  File "/usr/lib/python2.4/urlparse.py", line 50, in urlparse
    tuple = urlsplit(url, scheme, allow_fragments)
  File "/usr/lib/python2.4/urlparse.py", line 83, in urlsplit
    cached = _parse_cache.get(key, None)
exceptions.TypeError: list objects are unhashable

thanks!
Comment 1 Jan Hutař 2008-05-09 04:07:11 EDT
*** Bug 445515 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2008-06-11 13:05:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Jan Hutař 2008-11-04 06:39:10 EST
Created attachment 322412 [details]
/var/log/up2date for rhn_register GUI (with serverURL=https://myproxy/XMLRPC;https://xmlrpc.rhn.redhat.com/XMLRPC;)
Comment 20 errata-xmlrpc 2009-01-20 17:18:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0249.html

Note You need to log in before you can comment on or make changes to this bug.