Bug 445521 - Internal Server Error when checking Provisioning > Snapshots > Packages
Internal Server Error when checking Provisioning > Snapshots > Packages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
501
All Linux
low Severity low
: ---
: ---
Assigned To: Jay Dobies
Sayli Karmarkar
:
Depends On:
Blocks: sat530-snapshots
  Show dependency treegraph
 
Reported: 2008-05-07 08:09 EDT by Jan Hutař
Modified: 2015-03-22 21:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:58:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-05-07 08:09:46 EDT
Description of problem:
I'm getting "500 Error - Internal Server Error" when I click on the "Packages" 
sub-tab of the "Scheduled action completion: Package Install" snapshot.


Version-Release number of selected component (if applicable):
Red Hat Network release 5.0.1
rhn-check-0.4.17-8.el5.noarch


How reproducible:
always


Steps to Reproduce:
1. I have system with provisioning entitlement
2. on the RHN Satellite: Software > Packages > Install selected package "aide" 
and scheduled its installation
3. # rhn_check; rpm -q aide
4. on the RHN Satellite: Provisioning > Snapshots > "Scheduled action 
completion: Package Install"
5. go to Packages sub-tab


Actual results:
500 Error - Internal Server Error
You may have reached this page in one of the following ways:
You are using an outdated version of Konqueror 3.0, which may not handle form 
variables properly in all cases. Continuing to use this outdated version of 
Konqueror may have unexpected results. Please up2date to the latest version of 
Konqueror (3.03 or greater), or if this is not possible, please use another 
browser.
You've found an error in the site. Please report this error to your local 
administrator with details of how you received this message.


Expected results:
list of changes packages


Additional info:
Tested in current Opera and Firefox in case this could be the reason
I'm using RHN Proxy 5.0.1 (rhns-proxy-tools-5.0.1-5.rhel4) with RHN Satellite 
5.0.1
Comment 1 Jay Dobies 2009-04-07 10:33:53 EDT
I am unable to reproduce this as of Spacewalk 0.5. I tested scenarios where:
- The snapshot reflected the current state of packages (the UI specified "No package profile differences.")
- There were package differences between the snapshot and current (i.e. multiple package installations and looking at an older one). The package list was displayed correctly.

Pushing to ON_QA to double check.
Comment 3 Jay Dobies 2009-06-17 09:30:09 EDT
Jan - Could you file this as a new bug for tracking purposes please? It sounds as if the Internal Server Error is gone and this is a different issue.
Comment 4 Jan Hutař 2009-06-18 02:12:29 EDT
Hello, reported as bug 506651 but I'm not able to reproduce any more :-(
Comment 5 Jan Hutař 2009-06-22 02:59:34 EDT
This works as expected.
Comment 7 Brandon Perkins 2009-09-10 15:58:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.