Bug 445550 - Will not start when used with Orca
Will not start when used with Orca
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 11:11 EDT by Janina Sajka
Modified: 2008-09-26 07:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 07:06:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Wasn't loading /usr/lib64/gtk-2.0/modules/libatk-bridge.so (998 bytes, patch)
2008-09-25 21:47 EDT, Janina Sajka
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 456541 None None None Never

  None (edit)
Description Janina Sajka 2008-05-07 11:11:18 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:Puts up a message saying only "Unavailable." We've checked
without Orca a11y, and FF works as expected. The 32-bit Firefox with Orca works
as expected. This problem has been there for some time--sorry for not reporting
sooner. I don't know how to assist further in debugging this. I also don't know
whether or not this bug is Fedora specific.
Comment 1 Matěj Cepl 2008-05-07 18:47:56 EDT
Would you be able please to test this with the upstream binary from
http://www.mozilla.com/en-US/firefox/all-beta.html (just unpack the tarball
somewhere, cd into the unpacked directory and run ./firefox)? Does it work better?
Comment 2 Janina Sajka 2008-05-07 22:29:12 EDT
Yes, it runs as expected--but I did not see anything explicitly 64-bit on that
page, and the firefox-bin is reported as a 32-bit file by the file command. So,
this isn't a surprise because the iFedora firefox.i386 rpms work very well. The
problem is only with the firefox.x86_64 rpms.
Comment 3 Matěj Cepl 2008-05-08 09:44:02 EDT
Sorry, my bad. Assigning to developers.
Comment 4 Bug Zapper 2008-05-14 06:46:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Janina Sajka 2008-09-25 16:19:46 EDT
We've recently tried working this bug from the Orca side. This resulted in bug 456541 on Mozilla and a proposed patch from Sun posted there. The patch builds, but creates an unpack error for us. We're unclear on how to take this further, but the opinion on Mozilla is now that the problem is Fedora specific. Apparently, the 64-bit Fedora build is NOT looking in /usr/lib64, but rather in /usr/lib for libatk-bridge.so, if we understand Sun correctly.
Comment 6 Janina Sajka 2008-09-25 21:47:03 EDT
Created attachment 317752 [details]
Wasn't loading /usr/lib64/gtk-2.0/modules/libatk-bridge.so

patch to xulrunner
Comment 7 Matěj Cepl 2008-09-26 07:06:35 EDT
We believe that it is more appropriate to let this issue be resolved upstream (of course, bug http://bugzilla.mozilla.org/show_bug.cgi?id=456541).

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.