Bug 445554 - Logrotate ignores pre/postrotating scripts arguments
Summary: Logrotate ignores pre/postrotating scripts arguments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: logrotate
Version: 5.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Tomas Smetana
QA Contact:
URL:
Whiteboard:
Depends On: 241766
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-07 15:28 UTC by Martin Poole
Modified: 2018-10-20 01:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-17 17:27:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0881 normal SHIPPED_LIVE logrotate bug fix update 2008-09-17 17:27:22 UTC

Comment 1 RHEL Program Management 2008-05-07 15:55:41 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 2 Tomas Smetana 2008-05-21 11:31:49 UTC
No problem to fix this one.

Comment 3 Enzo 2008-07-21 08:59:41 UTC
Any status on a fix for this bug?


Comment 4 Tomas Smetana 2008-07-21 09:03:37 UTC
(In reply to comment #3)
> Any status on a fix for this bug?

Patch was ready a long time ago but logrotate isn't on the list of approved
components for 5.3.  Maybe in the next release.

Comment 10 errata-xmlrpc 2008-09-17 17:27:27 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0881.html

Comment 12 Roland Friedwagner 2009-01-29 10:17:14 UTC
Dear Sirs,

I've tested the Errata Package logrotate-3.7.4-9.i386.rpm as provided
with RHEL 5.3

Now the problem with the missing postrotate and prerotate argument 
is getting worse.

Because now the argument is a list of _all_ logfiles which are rotated.

BUT IT SHOULD BE the first argument the _one_ logfile that is rotated
at this invocation.

Example for an postrotate script as running fine in nearly all
RHEL and RHL releases before but now it is useless:
/var/log/xxx/*.log
/var/log/xxx/debug
{
    daily
    rotate 7
    missingok
    ifempty
    compress
    delaycompress
    create
    lastaction
        service yyy condrestart &>/dev/null
        service yyy condrestart &>/dev/null
    endscript
    postrotate
      [ -f $1.7.gz ] && gzip -dc $1.7.gz | bzip2 >> $1.archive.bz2 && rm $1.7.gz
      exit 0
    endscript
}

arg1 holds "/var/log/lpis/*.log" on every invocation :-(

Kind Regards,
Roland


Note You need to log in before you can comment on or make changes to this bug.