Bug 445573 - firefox disk write IO storms
firefox disk write IO storms
Status: CLOSED DUPLICATE of bug 439908
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 445568 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 13:49 EDT by Warren Togami
Modified: 2008-07-23 13:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-16 11:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 421482 None None None Never

  None (edit)
Description Warren Togami 2008-05-07 13:49:09 EDT
firefox-3.0-0.60.beta5.fc9.i386   (J5's machine)
firefox-3.0-0.60.beta5.fc9.x86_64 (warren's machine)

Two days ago I began noticing firefox using tons of disk IO sporadically while
the browser is supposed to be idle.  iotop shows constant write activity but no
read.  J5 began noticing this problem yesterday on his i386 machine.  Write
activity happens while sitting on an idle web page (even as simple as Fedora
Wiki) and it goes constantly for a few minutes, then stops.  During the disk I/O
firefox is still usable but extremely unresponsive.  Even closing Firefox takes
as much as a minute or two as it continues writing. 

http://forums.fedoraforum.org/showthread.php?t=187332
mcepl pointed out this thread that hints at urlclassifier*.sqlite files being
the cause.

https://bugzilla.mozilla.org/show_bug.cgi?id=402469
mcepl pointed out complaints about urlclassifier3.sqlite here, but I don't see
any complaints about disk IO.
Comment 1 Matěj Cepl 2008-05-07 13:54:30 EDT
Cannot reproduce here, but I have heavily working Firefox with insane amount of
tabs, so maybe it is just hidden in other activity.
Comment 2 Rex Dieter 2008-05-07 14:03:42 EDT
*** Bug 445568 has been marked as a duplicate of this bug. ***
Comment 3 Mat Booth 2008-05-07 14:46:44 EDT
I'm also seeing this problem with:

xulrunner-1.9-0.60.beta5.fc9.x86_64
firefox-3.0-0.60.beta5.fc9.x86_64

Firefox starts thrashing the disk almost every time a few minutes into the
session no matter what website. Vmstat tells me the CPU is 50%-90% waiting on IO
fairly consistently for more than 5 minutes at a time.
Comment 4 Frank Aisenbrey 2008-05-13 06:58:03 EDT
I have the same problem here.

iotop's (yum install iotop) most actives (examples while Firefox is running):
  PID USER      DISK READ  DISK WRITE   SWAPIN    IO>    COMMAND
  477 root           0 B/s   22.64 K/s  0.00 % 99.99 % [kjournald]
 3293 ferrogoo  116.37 K/s   72.73 K/s  0.00 % 99.99 % firefox -UILocale de

...

  PID USER      DISK READ  DISK WRITE   SWAPIN    IO>    COMMAND
  214 root           0 B/s       0 B/s  0.00 % 99.99 % [pdflush]
  477 root           0 B/s       0 B/s  0.00 % 99.99 % [kjournald]

...

   PID USER     DISK READ  DISK WRITE   SWAPIN    IO>    COMMAND
 3222 ferrogoo  290.78 K/s  207.18 K/s  0.00 % 79.13 % firefox -UILocale de
  477 root           0 B/s       0 B/s  0.00 % 61.14 % [kjournald]
  214 root           0 B/s       0 B/s  0.00 % 19.37 % [pdflush]

It takes about three minutes to complete. Part of the time Firefox does not
respond to any user interaction.
Comment 5 Bug Zapper 2008-05-14 06:47:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Rex Dieter 2008-05-15 08:47:06 EDT
Per http://jasondclinton.livejournal.com/66300.html , looks like this may have
something to do with upstream bug
https://bugzilla.mozilla.org/show_bug.cgi?id=421482
(and peripherally http://bugzilla.kernel.org/show_bug.cgi?id=9546 )
Comment 7 Ralf Ertzinger 2008-05-15 16:03:43 EDT
I see this, too.

The IO bursts seem to be periodic, and strace'ing firefox during one of those
peroids shows it happily working it's way through urlclassifier*.sqlite.

Streaming reads from the same filesystem (movie playback) completely stalls
during those reads.
Comment 8 Christopher Aillon 2008-05-16 11:16:38 EDT

*** This bug has been marked as a duplicate of 439908 ***
Comment 9 Prarit Bhargava 2008-06-25 08:29:16 EDT
*** Bug 452718 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.