Bug 445585 - multipath does not configure correctly when the ratio of paths / maps to system resources increases
multipath does not configure correctly when the ratio of paths / maps to syst...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dave Wysochanski
Corey Marthaler
: Tracking
Depends On: 202792 217130 243751 443380 445268 459969
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 15:09 EDT by Dave Wysochanski
Modified: 2010-10-21 15:47 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-21 15:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2008-05-07 15:09:39 EDT
Description of problem:

This is a generic bz meant to track proper configuration of multipath device
maps.  There are multiple problems with getting all maps to configure correctly.
 Sometimes the maps will be created without all paths, sometimes the maps will
be created with a WWID name instead of the friendly name, etc.  I believe at
least some of these problems are still present in upstream code.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.5-31.el4

How reproducible:
Some problems are hard to reproduce.  Many are related to bursty, concurrent
executions of the multipath tool caused by many udev events happening in a short
period of time.  I've been able to reproduce some of the problems with xen +
iscsi so specific hardware might not be required.

Steps to Reproduce:
1. Configure multipath for a large number of LUNs + paths
2. Start multipath 
  
Actual results:
Not all paths / maps are created

Expected results:
All paths and maps created properly

Additional info:
Comment 1 Martin George 2008-09-16 08:14:38 EDT
Since this is a generic bugzilla for tracking issues hit when large no. of luns/paths (256 luns x 4 = 1024 paths) are mapped to the RHEL host, I am adding a few myself that we have observed for such scenarios:

1) OOM/Hang issue - https://bugzilla.redhat.com/show_bug.cgi?id=459969

2) Multipath creates wwid based names instead of mpath names despite enabling user_friendly_names - https://bugzilla.redhat.com/show_bug.cgi?id=445268

3) Multipath does not automatically remove maps corresponding to the deleted luns - https://bugzilla.redhat.com/show_bug.cgi?id=443380

4) Delay in scanning large no. of luns/paths - https://bugzilla.redhat.com/show_bug.cgi?id=460301

5) Multipathd daemon ends up dead with the message "multipathd dead but pid file exists". This is highly intermittent. - No bugzilla yet.
Comment 3 Ben Marzinski 2010-10-21 15:47:55 EDT
I'm closing this bug since all the specific bugs it referenced are now closed.

Note You need to log in before you can comment on or make changes to this bug.