This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 445782 - smbclient "put" always creates zero byte sized files at destination
smbclient "put" always creates zero byte sized files at destination
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
: 446852 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 22:57 EDT by Kai Engert (:kaie)
Modified: 2013-01-09 23:41 EST (History)
5 users (show)

See Also:
Fixed In Version: 3.2.0-2.17.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 05:34:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 5452 None None None Never

  None (edit)
Description Kai Engert (:kaie) 2008-05-08 22:57:38 EDT
Please refer to the upstream bug at:
https://bugzilla.samba.org/show_bug.cgi?id=5452

Below is a copy of what I wrote in the upstream bug:


Client:
Fedora 9 (preview)
package version samba-client-3.2.0-1.pre3.9.fc9.i386

Server:
Windows XP SP3, Intel Laptop, 32 bit

I use
  smbclient '//192.168.2.51/moz' -U kaie
then
  put hello

"hello" is a file of size "6 bytes", containing "hello".

Actual behavior:
smbclient prints:
  smb: \> put hello
  putting file hello as \hello (0,0 kb/s) (average 0,0 kb/s)
and the destination gets a zero bytes file

Expected behavior:
get the correct file at the destination


I tested with different files, always zero bytes.


Additional info:
Same server, same client commands, same input file, but using a Fedora 8 client
(version 3.0.28a) it works fine!


It's independent of the input file, I always get zero bytes.

I did a network trace with wireshark (thanks to Andrew Bartlet for helping), he
looked at it, and he concluded, it's a good trace for sending a zero byte file.

I did an strace, I see smbclient does a state64, it gets the expected file size
(6 bytes), it successfully opens that file, but never reads from it! It does
something other actions, but then closes the file.

Thanks to Simo Sorce who reproduced this bug with latest samba code.
Comment 1 Bug Zapper 2008-05-14 06:52:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Anton Guda 2008-05-16 06:23:48 EDT
After application of patch from samba bug 5452
this bug seems to disapear.
Comment 3 Kai Engert (:kaie) 2008-05-16 06:34:07 EDT
I tried to apply the patch to the sources used in Fedora 9, but when I compiled,
I ran into a compiler error. I gave up, assuming that Gunther or Simo would soon
work on an updated rpm anyway, so I didn't want to duplicate the work.

I see on koji that Gunther has already built new packages where the changelog
mentions the inclusion of the fix, but I guess those have not yet been pushed
out as an update.
Comment 4 Simo Sorce 2008-05-16 10:20:13 EDT
*** Bug 446852 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2008-05-17 18:28:31 EDT
samba-3.2.0-1.pre3.11.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update samba'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4120

Note You need to log in before you can comment on or make changes to this bug.