Bug 445971 - Some texinfo links do not work
Some texinfo links do not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: a2ps (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 14:55 EDT by Steve Chapel
Modified: 2008-05-18 14:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: a2ps-4.14-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-18 14:20:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to a2ps devel branch (4.40 KB, patch)
2008-05-16 05:48 EDT, Vitezslav Crhonek
no flags Details | Diff

  None (edit)
Description Steve Chapel 2008-05-10 14:55:35 EDT
Description of problem:
Some texinfo links do not work

Version-Release number of selected component (if applicable):
texinfo-4.11-5.fc9

How reproducible:
Always

Steps to Reproduce:
1. Type 'info regex' at command prompt
2. Type 'mcoll<tab><return>'
  
Actual results:
Collating Elements vs. Characters: No such file or directory

Expected results:
Info goes to Collating Elements vs. Characters section

Additional info:
After finding this problem, I quickly found another:
1. Type 'info psset' at command prompt
2. Type 'minvok<return>'
3. Type ']'
4. Type 'mpleas<return'
5. Type ']'
6. Type 'u'
At this point, info reports:
Cannot find node `(/usr/share/info/a2ps.info.gz)Please tell me..'.

It seems likely that there are many such broken links in texinfo. I found the
first problem in Fedora 8 before confirming that it's also in Fedora 9, so it
looks like these have been broken for a while.
Comment 1 Vitezslav Crhonek 2008-05-12 09:08:12 EDT
It looks like wrong structure of the info file in a2ps package...
Comment 2 Bug Zapper 2008-05-14 06:58:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Vitezslav Crhonek 2008-05-15 09:34:04 EDT
Actually, a2ps.texi in a2ps tarball is wrong. It's not allowed to use period
character in Texinfo node name. Here's link to the Texinfo documentation, where
it's mentioned:

http://www.gnu.org/software/texinfo/manual/texinfo/html_node/Node-Line-Requirements.html#Node-Line-Requirements

Moving bug to a2ps component.
Comment 4 Patrice Dumas 2008-05-15 10:38:37 EDT
The report about regex is not in a2ps. In fact I couldn't reproduce
it, but my dir file is full of 'This entry...' reported, and if I 
remember well fixed in other bug.

Anyway I'll look at the a2ps issue this week-end.
Comment 5 Vitezslav Crhonek 2008-05-16 05:47:10 EDT
Regex is in a2ps too:

[vcrhonek@norcus ~]$ rpm -qf /usr/share/info/regex.info.gz 
a2ps-4.13b-69.fc8

Yes, 'This entry...' is bug #394191 hangover. Latest Rawhide and F-9 Texinfo
removes it in post install. See bug #433535.

Comment 6 Vitezslav Crhonek 2008-05-16 05:48:59 EDT
Created attachment 305667 [details]
Proposed patch to a2ps devel branch
Comment 7 Patrice Dumas 2008-05-18 14:20:36 EDT
Thanks for the patch. Applied and built.

Note You need to log in before you can comment on or make changes to this bug.