Bug 446003 - System startup fails with rhgb
System startup fails with rhgb
Status: CLOSED DUPLICATE of bug 464896
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-11 12:55 EDT by Leon Stringer
Modified: 2008-10-03 11:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 04:40:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Stringer 2008-05-11 12:55:32 EDT
Description of problem:
My F9 system fails to start up unless I remove rhgb in /etc/grub.conf.

Version-Release number of selected component (if applicable):
rhgb-9.0.0-6.fc9.i386

How reproducible:
Every time

Steps to Reproduce:
1. Start system.
  
Actual results:
After the message "Starting udev [OK]" the screen goes blank. Sometimes it
enters powersave, sometimes not. Sometimes I briefly see the default X mouse
cursor. There is no further disk activity after this.

Expected results:
System to start normally.

Additional info:
system-config-display reports my adapter as an "Intel Corporation
82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device".
This may be a dupe of "442492: i686 LiveCD only succeeds if rhgb is omitted".
Comment 1 Leon Stringer 2008-05-11 12:58:48 EDT
Further info: I have an FC5 partition on the same machine for which rhgb works
fine. Also, rhgb was working fine when I first installed F9, unfortunately I
can't put my finger on how long ago it broke.
Comment 2 David Timms 2008-05-13 07:23:50 EDT
Leon: Which pre F9 version did you install ?
Where any updates applied to it at all before you saw the error ?
Comment 3 Leon Stringer 2008-05-13 09:03:24 EDT
I installed Fedora 9 Beta from the DVD ISO. I then applied updates in the normal
way, i.e. when I got the icon in the top right of the GNOME desktop prompting me
that updates were available. So yes, I've applied many updates.
Comment 4 Bug Zapper 2008-05-14 07:00:08 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Peter Bloomfield 2008-09-14 16:43:02 EDT
I'm seeing the same issue since upgrading (with yum) from updated F9 to current rawhide.  I can't boot kernel 2.6.27 at all, because after removing 'rhgb' from the boot command, the X server still seems to be started early in the boot process, and from there on the screen stays black.  If I go back to 2.6.25.14-108.fc9.i686 and boot without rhgb, gdm comes up normally.

ThinkPad T43, kernel-2.6.27-0.323.rc6.fc10.i686, xorg-x11-server-common-1.5.0-6.fc10.i386, plymouth-0.6.0-0.2008.09.10.1.fc10.i386
Comment 6 Ray Strode [halfline] 2008-09-15 10:41:18 EDT
what if you add nomodeset to the grub kernel commandline ?
Comment 7 Peter Bloomfield 2008-09-15 17:13:06 EDT
(In reply to comment #6)
> what if you add nomodeset to the grub kernel commandline ?

I get a text-mode screen with a white progress-type bar at the bottom, with light and dark blue blocks to its right, and then a normal gdm screen. Thanks for the suggestion!  BTW: that's with kernel-2.6.27-0.323.rc6.fc10.i686.
Comment 8 Peter Bloomfield 2008-09-15 17:38:25 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > what if you add nomodeset to the grub kernel commandline ?
> 
> I get a text-mode screen with a white progress-type bar at the bottom, with
> light and dark blue blocks to its right, and then a normal gdm screen. Thanks
> for the suggestion!  BTW: that's with kernel-2.6.27-0.323.rc6.fc10.i686.

...and if I also remove 'rhgb', I get a normal text-mode boot--well, almost: the cursor jumps to the top of the screen after the first few lines, and overwrites those lines, but otherwise a normal boot.
Comment 9 Ray Strode [halfline] 2008-09-15 17:41:18 EDT
reassigning to kernel
Comment 10 Peter Bloomfield 2008-09-25 18:56:59 EDT
Kernel kernel-2.6.27-0.352.rc7.git1.fc10.i686 boots fine without nomodeset, both with and without rhgb--thanks!
Comment 11 Matěj Cepl 2008-10-02 04:40:38 EDT
Actually, this bug changed into something else. Now it is apparently duplicate of bug 462980. Closing.

*** This bug has been marked as a duplicate of bug 462980 ***
Comment 12 Matěj Cepl 2008-10-03 11:51:21 EDT

*** This bug has been marked as a duplicate of bug 464896 ***

Note You need to log in before you can comment on or make changes to this bug.