Bug 462980 - (norhgbx15) No graphical boot with rhgb after updating Xorg server
No graphical boot with rhgb after updating Xorg server
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 463076 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 18:57 EDT by Dirk
Modified: 2018-04-11 06:43 EDT (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 10:16:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (887 bytes, text/plain)
2008-09-19 18:57 EDT, Dirk
no flags Details
/etc/sysconfig/init (1.04 KB, text/plain)
2008-09-19 19:04 EDT, Dirk
no flags Details
/etc/init.d/functions (14.48 KB, text/plain)
2008-09-19 19:05 EDT, Dirk
no flags Details
/var/log/Xorg.0.log (42.71 KB, text/plain)
2008-09-22 13:06 EDT, Dirk
no flags Details
xorg.conf (1.82 KB, text/plain)
2008-10-02 14:10 EDT, Mike C
no flags Details
/var/log/Xorg.0.log (12.58 KB, text/plain)
2008-10-02 14:13 EDT, Mike C
no flags Details
xorg.conf for Dell D610 (1.54 KB, text/plain)
2008-10-02 14:53 EDT, Mike C
no flags Details
Xorg.0.log for Dell D610 with non-graphical boot (34.05 KB, text/plain)
2008-10-02 14:54 EDT, Mike C
no flags Details
Xorg.0.log (1.06 KB, text/plain)
2008-10-03 09:36 EDT, Peter Bloomfield
no flags Details
As requested my xorg.conf (862 bytes, text/plain)
2008-10-18 12:08 EDT, telespalla.filone
no flags Details
And Xorg.0.log (10.46 KB, text/plain)
2008-10-18 12:09 EDT, telespalla.filone
no flags Details
Xorg.1.log (8.33 KB, text/plain)
2008-10-18 12:09 EDT, telespalla.filone
no flags Details
Xorg.2.log (8.33 KB, text/plain)
2008-10-18 12:10 EDT, telespalla.filone
no flags Details
Xorg.3.log (8.33 KB, text/plain)
2008-10-18 12:10 EDT, telespalla.filone
no flags Details
Xorg.4.log (8.33 KB, text/plain)
2008-10-18 12:11 EDT, telespalla.filone
no flags Details
Xorg.5.log (8.33 KB, text/plain)
2008-10-18 12:11 EDT, telespalla.filone
no flags Details

  None (edit)
Description Dirk 2008-09-19 18:57:35 EDT
Created attachment 317267 [details]
xorg.conf

Description of problem:
After upgrading the Xorg server from 1.4.99 (beta) to 1.5.0 (final) no graphical boot with rhgb available.

rhgb is not functional by booting the kernel. The package "rhgb" is installed and /usr/bin/rhgb ist executable and runs from terminal after booting. Runlevel is 5.

Version-Release number of selected component (if applicable):
rhgb 9.0.0.-6
Xorg-server 1.5.0-1
Kernel 2.6.26.3-29

How reproducible:
On every boot-process

Additional info:

grub.conf

- - - - - - - - - -
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.26.3-29.fc9.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.26.3-29.fc9.x86_64 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.26.3-29.fc9.x86_64.img
- - - - - - - - - -
Comment 1 Dirk 2008-09-19 19:04:55 EDT
Created attachment 317268 [details]
/etc/sysconfig/init
Comment 2 Dirk 2008-09-19 19:05:25 EDT
Created attachment 317269 [details]
/etc/init.d/functions
Comment 3 Stefan Zakarias 2008-09-20 00:45:40 EDT
Just confirming that this happens in the i386 version too.  Same cause and symptoms as above.
Comment 4 Kevin Fenzi 2008-09-20 13:56:22 EDT
I'm also seeing it here on x86_64.
Comment 5 Björn Persson 2008-09-21 19:19:42 EDT
I see the same thing on an Intel G35, so it doesn't seem specific to the graphics card.

Linux 2.6.26.3-29.fc9.x86_64
xorg-x11-server 1.5.0-1.fc9
intel_drv.so compiled for 1.4.99.902, module version = 2.2.1
intel_master_drv.so compiled for 1.4.99.902, module version = 2.3.2
rhgb-9.0.0-6.fc9.x86_64
Comment 6 J.Jansen 2008-09-22 02:21:30 EDT
I see this on all of my F9 installations (both 32 and 64 bit) and a variety of processors and graphical cards.
Comment 7 Matěj Cepl 2008-09-22 10:24:28 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 8 lplp2 2008-09-22 11:25:24 EDT
Same problem here with same new packages and ATI card.

In addition, my wireless mouse doesn't work since this update.
Comment 9 Dirk 2008-09-22 13:06:12 EDT
Created attachment 317383 [details]
/var/log/Xorg.0.log
Comment 10 Simon Andrews 2008-09-23 10:06:41 EDT
I see this has been assigned to xorg-x11-drv-ati, but this doesn't seem to be an ATI issue.  I see the same thing on nvidia hardware (nv driver), and comments #6 and #6 say it's on intel as well.
Comment 11 Stefan Zakarias 2008-09-23 14:24:14 EDT
Adding to Simon Andrews post (#10), I'm using an nVidia 6600GT (AGP).  So unless there is something weird about the ATI files, I don't see how it could be an ATI-only problem.
Comment 12 Pramod Dematagoda 2008-09-25 12:09:05 EDT
This can't be something to do with ATI since there are other bug reports with different hardware and drivers. I have the same issue on an Intel VGA card.

Also there seem to be multiple bug reports on the same issue, perhaps it would be better if they were merged or something?
Comment 13 martin coker 2008-09-26 04:35:29 EDT
Just joining this bug. I have been away for 3 weeks so had to resolve the key problem on fedora 9 updates and catch up on 178 of them. I too have now lost the graphical boot screen on two of my F9's. This seems to be reported by ever increasing numbers(fedora forum) and does not seem to be graphics card related.

I am running intel duo and amd x86_64 F9,s both with nvidia cards. So can confirm that this is not just an ati problem.

Strange thing on updates is that using package kit on both machines now show no updates are required, yet checking again using yumex I see xorg synaptics package available. Both machines are desktop so I do not see that this is required. I do not have any issue with mouse or keyboard, but I note the mention of mouse problems above and on the many posts on fedora forum site.
Comment 14 Nicola Soranzo 2008-09-29 13:51:32 EDT
*** Bug 463076 has been marked as a duplicate of this bug. ***
Comment 15 hadmanysons 2008-09-30 11:25:16 EDT
I have an HP Pavilion ZE4910us laptop with an Intel Gseries graphics card and I also have had this problem. So, not just an ati or nvidia problem either.
Comment 16 Matěj Cepl 2008-10-02 04:40:38 EDT
*** Bug 446003 has been marked as a duplicate of this bug. ***
Comment 17 Dan Thurman 2008-10-02 11:52:48 EDT
See bug: 465132

Motherboards:
1) ASUS P5GC-MX/1333: LGA779, Intel 945GC + ICH7
2) Intel DQ35J0: GMA 3100, Q35 Express Chipset, ICH9DO

Two problems,

1) The startup gui fails for both MB as reported here.
2) Kernels:
   kernel-2.6.26.3-29.f9.i686
   kernel-2.6.26.5-45.fc9.i686

   Hangs only for ASUS MB but does not hang
   for kernel: 2.6.25.14-108.f9.i686

It is not clear if the kernel / xorg are related
or seperate problems.
Comment 18 Mike C 2008-10-02 14:04:08 EDT
Same for me on a Dell M4300 with hardware
http://www.smolts.org/client/show/pub_8a5cfd23-a9fb-4eda-9a8a-23171d46c3b4
running kernel 2.6.26.5-45.fc9.i686.PAE with kmod-nvidia

I will attach relevant files shortly
Comment 19 Mike C 2008-10-02 14:10:21 EDT
Created attachment 319272 [details]
xorg.conf

/etc/X11/xorg.conf
Comment 20 Mike C 2008-10-02 14:13:38 EDT
Created attachment 319273 [details]
/var/log/Xorg.0.log

Xorg.0.log after non-graphical boot
Comment 21 Mike C 2008-10-02 14:51:59 EDT
Same symptoms with Dell D610 
http://www.smolts.org/client/show/pub_bf0cee64-7d74-494b-a0c0-e62cf4e63b20

running kernel 2.6.26.5-45.fc9.i686 and standard driver from F9

Will post relevant files shortly
Comment 22 Mike C 2008-10-02 14:53:17 EDT
Created attachment 319278 [details]
xorg.conf for Dell D610

xorg.conf for Dell d610
Comment 23 Mike C 2008-10-02 14:54:32 EDT
Created attachment 319281 [details]
Xorg.0.log for Dell D610 with non-graphical boot

Xorg.0.log for non-graphical boot Dell D610
Comment 24 Peter Bloomfield 2008-10-03 09:36:35 EDT
Created attachment 319362 [details]
Xorg.0.log

My problem seems to be different (rhgb runs fine), but the bug I've been following (bug 446003) has been closed as a dup of this one.

With current rawhide, my ThinkPad T43 will boot only with nomodeset.  Without it, and with or without rhgb, the display hangs a few seconds into the auto-login screen.  Server log from a failed boot attached.  The last kernel that would boot without nomodeset was kernel-2.6.27-0.352.rc7.git1.fc10.i686); I don't have a record of the xorg versions.

Current setup:
kernel-2.6.27-0.377.rc8.git1.fc10.i686
xorg-x11-server-Xorg-1.5.1-4.fc10.i386
xorg-x11-drv-ati-6.9.0-21.fc10.i386

01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
Comment 25 Pramod Dematagoda 2008-10-03 09:55:49 EDT
@Peter Bloomfield:-
I think you may have the wrong bug report here. RHGB has long since been taken out from Fedora 10 and has been replaced with Plymouth, so you should file a bug against that or perhaps the X-Server. Also your release is wrong, this bug report is for Fedora 9 whereas your issue is on Fedora 10(Or Rawhide according to the bugzilla).
Comment 26 Nicola Soranzo 2008-10-03 09:59:58 EDT
(In reply to comment #24)
> My problem seems to be different (rhgb runs fine), but the bug I've been
> following (bug 446003) has been closed as a dup of this one.
> 
> With current rawhide, my ThinkPad T43 will boot only with nomodeset.  Without
> it, and with or without rhgb, the display hangs a few seconds into the
> auto-login screen.  Server log from a failed boot attached.  The last kernel
> that would boot without nomodeset was kernel-2.6.27-0.352.rc7.git1.fc10.i686);
> I don't have a record of the xorg versions.

You should follow bug 464896, this one is about rhgb.

Thanks,
Nicola
Comment 27 Peter Bloomfield 2008-10-03 10:28:11 EDT
(In reply to comment #26)
[ snip ]
> You should follow bug 464896, this one is about rhgb.
> 
> Thanks,
> Nicola

That's helpful!  Thanks for the pointer.

Peter
Comment 28 hadmanysons 2008-10-03 12:05:40 EDT
Here's my smolt id: http://www.smolts.org/client/show_all/pub_89fc8ca5-45c7-4a61-8109-cec9af8e7300. I installed F9 on another computer last night. After about 600 MB's of updates, rhgb go boom.
Comment 29 Ranjan 2008-10-11 09:51:56 EDT
same issue on my dell 92000 inspiron laptop. ATI Mobility 9600 video card
Comment 30 Adel Gadllah 2008-10-12 11:44:38 EDT
Seems like reverting the "Use abstract sockets by default" patch fixes the issue for me.
I have done a scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=875515 
with this patch reverted.

Please test and confirm whether if works for you too or not.
Comment 31 Muayyad Alsadi 2008-10-12 20:30:53 EDT
> Please test and confirm whether if works for you too or not.

yes it works again with me (I'm using nvidia)
Comment 32 Muayyad Alsadi 2008-10-12 20:31:11 EDT
> Please test and confirm whether if works for you too or not.

yes it works again with me (I'm using nvidia)
Comment 33 Pramod Dematagoda 2008-10-12 20:52:26 EDT
(In reply to comment #30)
> Seems like reverting the "Use abstract sockets by default" patch fixes the
> issue for me.
> I have done a scratch build:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=875515 
> with this patch reverted.
> 
> Please test and confirm whether if works for you too or not.

I have installed your RPM of RHGB and now RHGB seems to work fine.

I'm on an Intel.
Comment 34 Kamil Pawlowski 2008-10-13 01:05:49 EDT
This rpm solves problem in my box, nvidia, thanks
Comment 35 Stefan Zakarias 2008-10-13 02:11:01 EDT
Confirmed.  Working for me too:

P4, 3.4GHz, i386
nVidia 6600GT (AGP)
Fedora 9
Comment 36 Christoph Wickert 2008-10-13 03:57:52 EDT
Still broken for me (Nvidia Geforge Go 7300).
Comment 37 Mike C 2008-10-13 04:11:40 EDT
This works great and fixes the graphical boot for the machine referred to in comment #21. Hope this will be pushed out soon.
Comment 38 martin coker 2008-10-13 07:30:47 EDT
Nvidia 7300LE on amd64 rock mobo. All ok works fine. Still have to try it on intel duo with same card but looks a fix to me. many thanks
Comment 39 Simon Andrews 2008-10-13 08:34:55 EDT
The rpm from #33 fixes the issue on my system (01:00.0 VGA compatible controller: nVidia Corporation NV43GL [Quadro FX 550] (rev a2)).
Comment 40 Mike C 2008-10-13 10:52:49 EDT
The rpm from #33 also fixes the issue on a second laptop that also had the same problem (Old Amilo D6800)
Comment 41 Fedora Update System 2008-10-13 14:29:27 EDT
libxcb-1.1-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libxcb-1.1-5.fc9
Comment 42 Dan Thurman 2008-10-13 16:07:31 EDT
#41 required too many dependencies to be removed so I declined to install it.
#33 how do I install the src.rpm for confirmation w/o heavy dependencies?
    Perhaps better to wait for upstream push?
Comment 43 Michael Cronenworth 2008-10-13 16:14:39 EDT
(In reply to comment #42)
> #41 required too many dependencies to be removed so I declined to install it.

There are no added or removed dependencies. It sounds like you grabbed an RPM not built for your CPU architecture. If you're on 32-bit you need i386. If you're in 64-bit land you need x86_64.
Comment 44 Dan Thurman 2008-10-13 18:06:44 EDT
Response to #43:

I downloaded:   libxcb-1.1-5.fc9.i386.rpm (info) (download)
and package installer complains:

libxcb = 1.1-4.fc9 is needed by package libxcb-devel-1.1-4.fc9.i386

So, attempts to remove: libxcb-devel-1.1-4.fc9.i386

results:

# yum remove libxcb-devel-1.1-4.fc9.i386
[...]
================================================================================
 Package                    Arch   Version                      Repository Size 
================================================================================
Removing:
 libxcb-devel               i386   1.1-4.fc9                    installed 1.8 M
Removing for dependencies:
 GtkAda-devel               i386   2.10.0-4.fc9                 installed  19 M
 GtkAda-doc                 i386   2.10.0-4.fc9                 installed 9.9 M
 Inventor-devel             i386   2.1.5-33.fc9                 installed 2.7 M
 Inventor-examples          i386   2.1.5-33.fc9                 installed 2.1 M
 InventorXt-devel           i386   2.1.5-33.fc9                 installed 251 k
 PyQt4-devel                i386   4.4.2-2.fc9                  installed  19 M
 SDL-devel                  i386   1.2.13-3.fc9                 installed 1.4 M
 SDL_gfx-devel              i386   2.0.16-5.fc9                 installed  91 k
 SDL_image-devel            i386   1.2.6-6.fc9                  installed 4.5 k
 SDL_mixer-devel            i386   1.2.8-9.fc9                  installed  25 k
 SDL_ttf-devel              i386   2.0.9-4.fc9                  installed 9.6 k
 Thunar-devel               i386   0.9.0-4.fc9                  installed 1.1 M
 Xaw3d-devel                i386   1.5E-11.1                    installed 333 k
 arts-devel                 i386   8:1.5.10-1.fc9               installed 933 k
 at-spi-devel               i386   1.22.1-1.fc9                 installed 1.5 M
 cairo-devel                i386   1.6.4-1.fc9                  installed 1.1 M
 cairomm-devel              i386   1.5.0-1.fc9                  installed 1.9 M
 cernlib-devel              i386   2006-29.fc9                  installed 1.9 M
 cernlib-g77-devel          i386   2006-29.fc9                  installed 1.9 M
 cernlib-g77-static         i386   2006-29.fc9                  installed  44 M
 cernlib-g77-utils          i386   2006-29.fc9                  installed  30 k
 cernlib-static             i386   2006-29.fc9                  installed  44 M
 cernlib-utils              i386   2006-29.fc9                  installed  30 k
 eel2-devel                 i386   2.22.2-1.fc9                 installed 172 k
 elice                      i386   0.258-1.fc9                  installed 407 k
 eric                       noarch 4.1.6-1.fc9                  installed  21 M
 exo-devel                  i386   0.3.4-2.fc9                  installed 1.1 M
 fltk-devel                 i386   1.1.8-1.fc9                  installed 2.9 M
 fltk-fluid                 i386   1.1.8-1.fc9                  installed 404 k
 gail-devel                 i386   1.22.3-1.fc9                 installed  65 k
 gd-devel                   i386   2.0.35-5.fc9                 installed 293 k
 geant321                   i386   2006-29.fc9                  installed 7.7 k
 geant321-g77               i386   2006-29.fc9                  installed 7.7 k
 ghc-gtk2hs                 i386   0.9.12.1-8.fc9               installed  0.0 
 ghc682-gtk2hs              i386   0.9.12.1-8.fc9               installed  37 M
 gkrellm-devel              i386   2.3.1-5.fc9                  installed  58 k
 gnome-build-devel          i386   0.2.4-1.fc9                  installed  30 k
 gnome-chemistry-utils-devel
                            i386   0.8.7-2.fc9                  installed 2.0 M
 gnome-desktop-devel        i386   2.22.3-1.fc9                 installed 196 k
 gnome-device-manager-devel i386   0.2-3.fc9                    installed  11 k
 gnome-libs-devel           i386   1:1.4.2-9.fc9                installed 3.4 M
 gnome-mag-devel            i386   0.15.0-2.fc9                 installed 142 k
 gnome-media-devel          i386   2.22.0-2.fc9                 installed  11 k
 gnome-panel-devel          i386   2.22.2-2.fc9                 installed 177 k
 gnome-scan-devel           i386   0.6-2.fc9                    installed 381 k
 gnome-utils-devel          i386   1:2.20.0.1-5.fc9             installed 416 k
 goffice04-devel            i386   0.4.3-3.fc9                  installed 365 k
 gtk+-devel                 i386   1:1.2.10-61.fc9              installed 1.4 M
 gtk2-devel                 i386   2.12.12-1.fc9                installed  20 M
 gtkglext-devel             i386   1.2.0-6.fc9                  installed 1.1 M
 gtkmm24-devel              i386   2.12.7-1.fc9                 installed 3.4 M
 gtkmm24-docs               i386   2.12.7-1.fc9                 installed  50 M
 gtksourceview-devel        i386   1:1.8.5-4.fc9                installed 434 k
 imlib-devel                i386   1:1.9.15-7.fc9               installed 183 k
 kdebase-workspace-devel    i386   4.1.1-1.fc9                  installed 3.2 M
 kdelibs-devel              i386   6:4.1.1-12.fc9               installed 6.1 M
 kdelibs3-devel             i386   3.5.10-1.fc9                 installed  12 M
 kdemultimedia-devel        i386   6:4.1.1-2.fc9                installed 453 k
 kdepimlibs-devel           i386   4.1.1-2.fc9                  installed 1.6 M
 kdevelop                   i386   9:3.5.3-1.fc9                installed  33 M
 kdevelop-libs              i386   9:3.5.3-1.fc9                installed 5.6 M
 kdnssd-avahi-devel         i386   0.1.3-0.6.20080116svn.fc9    installed  27 k
 kuipc                      i386   2006-29.fc9                  installed  63 k
 kuipc-g77                  i386   2006-29.fc9                  installed  63 k
 lazarus                    i386   0.9.24-4.fc9                 installed 168 M
 lesstif-devel              i386   0.95.0-26.fc9                installed 1.6 M
 libICE-devel               i386   1.0.4-3.fc9                  installed  36 k
 libSM-devel                i386   1.1.0-1.fc9                  installed  19 k
 libX11-devel               i386   1.1.4-1.fc9                  installed 1.1 M
 libXScrnSaver-devel        i386   1.1.2-4.fc9                  installed 5.8 k
 libXTrap-devel             i386   1.0.0-5.fc9                  installed  225 
 libXau-devel               i386   1.0.3-5.fc9                  installed 6.5 k
 libXaw-devel               i386   1.0.4-2.fc9                  installed 313 k
 libXcomposite-devel        i386   0.4.0-4.fc9                  installed 7.6 k
 libXcursor-devel           i386   1.1.9-2.fc9                  installed  18 k
 libXdamage-devel           i386   1.1.1-4.fc9                  installed 2.4 k
 libXdmcp-devel             i386   1.0.2-5.fc9                  installed 6.8 k
 libXevie-devel             i386   1.0.2-3.fc9                  installed 3.7 k
 libXext-devel              i386   1.0.4-1.fc9                  installed  48 k
 libXfixes-devel            i386   4.0.3-3.fc9                  installed 8.8 k
 libXfont-devel             i386   1.3.2-1.fc9                  installed  51 k
 libXfontcache-devel        i386   1.0.4-5.fc9                  installed 2.2 k
 libXft-devel               i386   2.1.12-5.fc9                 installed  23 k
 libXi-devel                i386   1.1.3-4.fc9                  installed  41 k
 libXinerama-devel          i386   1.0.3-1.fc9                  installed 2.4 k
 libXmu-devel               i386   1.0.4-1.fc9                  installed  67 k
 libXp-devel                i386   1.0.0-11.fc9                 installed  39 k
 libXpm-devel               i386   3.5.7-4.fc9                  installed  55 k
 libXrandr-devel            i386   1.2.2-3.fc9                  installed  17 k
 libXrender-devel           i386   0.9.4-3.fc9                  installed  13 k
 libXres-devel              i386   1.0.3-4.fc9                  installed 3.2 k
 libXt-devel                i386   1.0.4-5.fc9                  installed 512 k
 libXtst-devel              i386   1.0.3-3.fc9                  installed 3.3 k
 libXv-devel                i386   1.0.3-5.fc9                  installed  27 k
 libXvMC-devel              i386   1.0.4-4.fc9                  installed 4.7 k
 libXxf86dga-devel          i386   1.0.2-2.fc9                  installed 5.4 k
 libXxf86misc-devel         i386   1.0.1-5.fc9                  installed 2.9 k
 libXxf86vm-devel           i386   1.0.1-5.fc9                  installed 4.7 k
 libbonoboui-devel          i386   2.22.0-2.fc9                 installed 1.0 M
 libdmx-devel               i386   1.0.2-5.fc9                  installed  24 k
 libglade2-devel            i386   2.6.2-5.fc9                  installed 217 k
 libgnomecanvas-devel       i386   2.20.1.1-2.fc9               installed 504 k
 libgnomeprint22-devel      i386   2.18.4-1.fc9                 installed 637 k
 libgnomeprintui22-devel    i386   2.18.2-1.fc9                 installed 238 k
 libgnomeui-devel           i386   2.22.1-2.fc9                 installed 2.5 M
 libgtksourceviewmm-devel   i386   0.3.1-1.fc8                  installed 978 k
 libgtksourceviewmm-doc     i386   0.3.1-1.fc8                  installed 1.0 M
 librsvg2-devel             i386   2.22.2-1.fc9                 installed  92 k
 libxfce4mcs-devel          i386   4.4.2-2.fc9                  installed  13 k
 libxfce4util-devel         i386   4.4.2-2.fc9                  installed 297 k
 libxfcegui4-devel          i386   4.4.2-2.fc9                  installed 503 k
 mesa-libGL-devel           i386   7.1-0.37.fc9                 installed 918 k
 mesa-libGLU-devel          i386   7.1-0.37.fc9                 installed  81 k
 ncl-devel                  i386   5.0.0-11.fc9                 installed  24 M
 ncl-examples               i386   5.0.0-11.fc9                 installed  34 M
 ocaml-x11                  i386   3.10.1-3.fc9                 installed  32 k
 pango-devel                i386   1.20.4-1.fc9                 installed 2.1 M
 phonon-devel               i386   4.2.0-5.fc9                  installed 211 k
 pycairo-devel              i386   1.4.12-3.fc9                 installed 7.0 k
 pygtk2-devel               i386   2.12.1-6.fc9                 installed 1.1 M
 qscintilla-designer        i386   2.2-3.fc9                    installed  15 k
 qt-devel                   i386   1:4.4.1-2.fc9                installed  23 M
 qt3-designer               i386   3.3.8b-14.fc9                installed 4.7 M
 qt3-devel                  i386   3.3.8b-14.fc9                installed  36 M
 startup-notification-devel i386   0.9-4.fc9                    installed  37 k
 vala                       i386   0.3.5-1.fc9                  installed 4.2 M
 vala-doc                   i386   0.3.5-1.fc9                  installed  37 k
 vala-tools                 i386   0.3.5-1.fc9                  installed 402 k
 xbae-devel                 i386   4.60.4-9.fc9                 installed 1.5 M
 xfce-mcs-manager-devel     i386   4.4.2-2.fc9                  installed 2.6 k
 xfce4-panel-devel          i386   4.4.2-4.fc9                  installed 296 k
 xfce4-session-devel        i386   4.4.2-3.fc9                  installed  17 k
 xmms-devel                 i386   1:1.2.11-1.20071117cvs.1.fc9 installed  30 k
 xorg-x11-proto-devel       noarch 7.3-12.1.fc9                 installed 1.4 M

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove     135 Package(s)         

Is this ok [y/N]: N
Exiting on user Command
Complete!

So, I declined.
Comment 45 Muayyad Alsadi 2008-10-13 18:22:39 EDT
> libxcb = 1.1-4.fc9 is needed by package libxcb-devel-1.1-4.fc9.i386
the new libxcb will replace the old one, but the old one is needed by the -devel
so just install the new libxcb with its -devel
Comment 46 Christoph Wickert 2008-10-13 18:24:26 EDT
(In reply to comment #44)
> Response to #43:
> 
> I downloaded:   libxcb-1.1-5.fc9.i386.rpm (info) (download)
> and package installer complains:
> 
> libxcb = 1.1-4.fc9 is needed by package libxcb-devel-1.1-4.fc9.i386
> 
> So, attempts to remove: libxcb-devel-1.1-4.fc9.i386

Please download also the new libxcb-devel from the link above and then do a 
rpm -Uvh libxcb-1.1-5.fc9.i386.rpm libxcb-devel-1.1-5.fc9.i386.rpm
Comment 47 Matěj Cepl 2008-10-13 19:05:23 EDT
Did the new package help?
Comment 48 Christoph Wickert 2008-10-13 19:50:16 EDT
For me it's still not working with the hardware from comment # 36, rhgb-9.0.0-9.fc9.i386 and libxcb-1.1-5.fc9.i386

Nevertheless it has become a little bit better: At least rhgb is startet but it crashes immediately. For one or two seconds I can see the mouse cursor with the spinner and the blue background, but it looks like rhgb can't open the console, so I only have like a small dialog in the center of rhgb but the "show details" link is missing. I thought it was related to SELinux so I relabled my entire filesystem and even set SELinux to permissive. No luck.
Comment 49 Pramod Dematagoda 2008-10-13 22:45:42 EDT
I installed libxcb-1.1-5 and reverted rhgb to package version rhgb-9.0.0-6 and now RHGB seems to be working properly, in that it didn't crash and successfully progressed until the end of the boot.
Comment 50 Adam Jackson 2008-10-14 14:25:21 EDT
(In reply to comment #48)
> For me it's still not working with the hardware from comment # 36,
> rhgb-9.0.0-9.fc9.i386 and libxcb-1.1-5.fc9.i386
> 
> Nevertheless it has become a little bit better: At least rhgb is startet but it
> crashes immediately. For one or two seconds I can see the mouse cursor with the
> spinner and the blue background, but it looks like rhgb can't open the console,
> so I only have like a small dialog in the center of rhgb but the "show details"
> link is missing. I thought it was related to SELinux so I relabled my entire
> filesystem and even set SELinux to permissive. No luck.

Well, seeing the mouse cursor with the spinner means you've at least gotten as far as connecting to the X server and making a cursor appear, so I'm prepared to call this rhgb's bug again.  Yay for shifting blame!

Re comment #49, thanks for the testing, I'll push the libxcb update to stable.
Comment 51 Dan Thurman 2008-10-14 15:19:47 EDT
Response to: #45

What is not clear to me is:

1) Where can I download the RPM for rhgb that
   is not "src.rpm" so that I can install it?

2) Do I need to install (1) rhgb first,
   before installing libxcb + devel?

Once I understand fully with info requested in (1) and (2)
above, then I will proceed and then confirm.

Thanks!
Comment 52 Adel Gadllah 2008-10-14 15:34:08 EDT
(In reply to comment #51)
> Response to: #45
> 
> What is not clear to me is:
> 
> 1) Where can I download the RPM for rhgb that
>    is not "src.rpm" so that I can install it?
> 
> 2) Do I need to install (1) rhgb first,
>    before installing libxcb + devel?
> 
> Once I understand fully with info requested in (1) and (2)
> above, then I will proceed and then confirm.
> 

You don't need the new rhgb package anymore, the real fix is the updated libxcb.
(and libxcb-devel is only needed if it is installed to avoid broken deps)
Comment 53 Dan Thurman 2008-10-14 16:41:26 EDT
I have confirmed that update libxcb works!

(From Comment #17):
1) ASUS P5GC-MX/1333: LGA779, Intel 945GC + ICH7
2) Intel DQ35J0: GMA 3100, Q35 Express Chipset, ICH9DO

and for all of the kernels listed in comment #17

THANKS!
Comment 54 Dan Thurman 2008-10-15 15:56:09 EDT
Whoa...

I noticed something is not right - is it related?

Try logging in as a user,  Then logout so that
you can log in as another user in the GUI login?

I get a blank-screen with the X cursor and
not GUI login appears.

I tried Cntl-Alt-Backspace and same thing
appears - blank-screen with the X cursor
and no GUI login appears.

I forget the command to restart the GUI in
an Cntrl-Alt-F1 login window - can someone
tell me what it is so that I can test this
as well?
Comment 55 Fedora Update System 2008-10-15 22:05:52 EDT
libxcb-1.1-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libxcb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8814
Comment 56 Mike C 2008-10-16 05:05:53 EDT
Regarding #54 - I logged out as a user and the system returned me correctly to
the login gui and I could log in again as normal. So for me the fixed rpm works fine.

By the way I reverted rhgb to the original before updating libxcb to 
libxcb-1.1-5.fc9

Ctrl-alt-backspace also works correctly for me.
Comment 57 Mike C 2008-10-16 05:24:17 EDT
Tested on a different machine - Dell M4300 with kmod-nvidia - works fine.

This test is for gdm/gnome - which is the same setup as for #56.

I have not tested kdm/KDE4
Comment 58 telespalla.filone 2008-10-18 12:08:55 EDT
Created attachment 320751 [details]
As requested my xorg.conf
Comment 59 telespalla.filone 2008-10-18 12:09:37 EDT
Created attachment 320752 [details]
And Xorg.0.log
Comment 60 telespalla.filone 2008-10-18 12:09:59 EDT
Created attachment 320753 [details]
Xorg.1.log
Comment 61 telespalla.filone 2008-10-18 12:10:20 EDT
Created attachment 320754 [details]
Xorg.2.log
Comment 62 telespalla.filone 2008-10-18 12:10:42 EDT
Created attachment 320755 [details]
Xorg.3.log
Comment 63 telespalla.filone 2008-10-18 12:11:04 EDT
Created attachment 320756 [details]
Xorg.4.log
Comment 64 telespalla.filone 2008-10-18 12:11:25 EDT
Created attachment 320757 [details]
Xorg.5.log
Comment 65 Fedora Update System 2008-11-05 23:08:39 EST
libxcb-1.1-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 66 Michael Cronenworth 2009-05-11 10:16:52 EDT
Fixed long ago...

Note You need to log in before you can comment on or make changes to this bug.