Bug 446045 - GUI/VNC installs not working. exits when gtk.main() is called
GUI/VNC installs not working. exits when gtk.main() is called
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gtk2 (Show other bugs)
4.7
All Linux
high Severity high
: beta
: ---
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
:
: 446129 446474 (view as bug list)
Depends On: 446129
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 06:22 EDT by Alexander Todorov
Modified: 2010-10-22 20:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0773
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:06:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of virtual machine (10.39 KB, image/png)
2008-05-12 06:34 EDT, Alexander Todorov
no flags Details
/tmp/ramfs/X.log (58.07 KB, text/plain)
2008-05-12 09:50 EDT, Milan Zazrivec
no flags Details

  None (edit)
Description Alexander Todorov 2008-05-12 06:22:47 EDT
Description of problem:
GUI/VNC installs are not working. 

Version-Release number of selected component (if applicable):
anaconda-10.1.1.89-1
tree: RHEL4-U7-re20080507.0

How reproducible:
100% with GUI/VNC

Steps to Reproduce:
1. start the installation (GUI/VNC)
2. proceed to stage 2
3.
  
Actual results:
X server starts. You can see the mouse cursor. Right after that the installation
shuts down. GUI/VNC installations fail.

Expected results:
X server starts and the installation proceeds with GUI or VNC.

Additional info:
Does not affect text mode installs. Same behavior on different arches, bare
metal and xen guest.
Comment 2 Alexander Todorov 2008-05-12 06:34:32 EDT
Created attachment 305113 [details]
screenshot of virtual machine
Comment 3 Joel Andres Granados 2008-05-12 06:41:54 EDT
It is possible that this is not directly related to the Xserver as anaconda
tells us that is started successfully.  The report also states that the mouse
cursor showed up, which is a good sign that the Xserver was started successfully.
Comment 5 Alexander Todorov 2008-05-12 06:48:50 EDT
update:
1) I saw the text messages indicating anaconda is starting
2) Then black screen for some time until X starts
3) Then I saw the welcome screen
4) Then (I think) follows the partitioning screen but before it the installation
began to shut down
Comment 6 Alexander Todorov 2008-05-12 07:45:19 EDT
mzazrivec indicates that this could be related to:
https://bugzilla.redhat.com/show_bug.cgi?id=222301

Anaconda team what's your opinion? 
Comment 7 Chris Lumens 2008-05-12 09:26:38 EDT
Doesn't seem too likely that the bugs are related, though I won't rule it out
completely.  Can you grab the /tmp/ramfs/X.log file and attach it to this bug? 
You may need to add the nokill command line option so you still have a shell on
tty2 when we abort the install.  If something in X is segfaulting, that file
should contain the reason why.
Comment 8 Joel Andres Granados 2008-05-12 09:36:47 EDT
ok, I debugged this and it is unquestionably gtk.  the installer goes bum when
gtk.main() is called.  Going bum means something happens internally in gtk that
makes the anaconda thread exit, in turn making the whole installation exit.
I wonder if this has anything to do with 222301.
Comment 9 Joel Andres Granados 2008-05-12 09:42:07 EDT
I'm not going to clone with 222301 as I am not sure that they are the same
issue.  I will however, change the component to gtk2.
Comment 10 Milan Zazrivec 2008-05-12 09:50:58 EDT
Created attachment 305127 [details]
/tmp/ramfs/X.log

I don't think it'll help though.

The X server starts fine with nice background and initialized mouse pointer and

stays that way for a few seconds, you don't get any widgets though (everything
goes south after that).
Comment 13 Matthias Clasen 2008-05-13 09:30:43 EDT
The stacktrace makes it pretty clear that it must be related to the patch that
was committed in bug 222301. I'm at a loss why, though, and would like to talk
to Behdad about it. The patch changes to the code to be identical to what we
ship in current Fedora, and it works fine there...

Have you verified that the crashes go away if you back down gtk2 ? If so, I
would recommend that we back out the patch for 222301 until we have a clear
understanding of what is going on here. That patch was a bit of a last-minute
addition, anyway.
Comment 14 Brock Organ 2008-05-14 16:20:39 EDT
*** Bug 446474 has been marked as a duplicate of this bug. ***
Comment 15 Alexander Todorov 2008-05-15 05:46:59 EDT
I can confirm that with gtk2-2.4.13-24.el4 and anaconda-10.1.1.89-1

the GUI and VNC installs are working. 
Comment 17 Jonathan Blandford 2008-05-15 09:51:08 EDT
devel_ack for the rollback.
Comment 18 James Laska 2008-05-15 10:04:59 EDT
for clarification ... it looks like we fixed the root issue instead of rolling
back the fix that introduced this bug

* Sun May 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.13-24.el4
- Another try, fix serial overflow in x11-geometry.
- Resolves: #222301

Comment 19 Milan Zazrivec 2008-05-15 10:29:49 EDT
RHEL4-U7-re20080507.0 had gtk2-2.4.13-23.el4 which contained fix for bug #222301.
The problem was that fix for bug #222301 also introduced regression (gtk2
applications randomly segfaulting). Anaconda sure did pick up this version
of gtk2, which resulted into graphical installation being broken. The
implications of this regression were much more serious though -- whole
gnome-session and all gtk2 applications were unusable.

Anyway the problem was being taken care of in bug #222301 already
and we have a new version (2.4.13-24.el4), which works just fine
(see https://bugzilla.redhat.com/show_bug.cgi?id=222301#c55).

So to sum up, no rollback is needed. This bugzilla is just confusing.
Comment 23 John Jarvis 2008-07-16 16:32:22 EDT
*** Bug 446129 has been marked as a duplicate of this bug. ***
Comment 24 errata-xmlrpc 2008-07-24 16:06:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0773.html

Note You need to log in before you can comment on or make changes to this bug.