Bug 446129 - can't do graphical install on box with Matrox G200e
can't do graphical install on box with Matrox G200e
Status: CLOSED DUPLICATE of bug 446045
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gtk+ (Show other bugs)
4.7
All Linux
high Severity high
: rc
: ---
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
: OtherQA
Depends On:
Blocks: 446045
  Show dependency treegraph
 
Reported: 2008-05-12 17:28 EDT by Geoff Gustafson
Modified: 2009-06-19 23:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 16:32:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Gustafson 2008-05-12 17:28:16 EDT
Description of problem:
With the re20080507.0 rel-eng build, can't do a graphical install. After trying
to start anaconda, it brings up the blue screen w/ RH logo but then crashes and
says "install exited abnormally" after "Starting graphical installation...".
I see anaconda with a segfault in another virtual console:
<6>anaconda[678]: segfault at 000000000000008 rip 0000002a9b49cf6b rsp
0000007fbfeeee00 error 4

But other behaviors could mean something other than anaconda is at fault:

A text mode install works, but if you boot to runlevel 5, X comes to a black
screen with the X cursor moveable and seems to go no farther.

If you boot to runlevel 3 and then do init 5, the login screen comes up, but if
you login, there is a cycle of gnome-panel crashes and you can't do anything. If
you run system-config-display, a blue background image comes up, and a dialog
background briefly flashes up, then disappears and you're stuck with the blue
background and moveable arrow cursor. If I run startx from runlevel 3, it goes
right to a cycle of gnome-panel and nautilus crash messages, clicking through
them after a bit, it stops painting with the cursor moveable.

Gary Case tried the previous rel-eng compose 0505.0 and graphical install worked
fine.

Version-Release number of selected component (if applicable):
anaconda-10.1.1.89-1
xorg-x11-6.8.2-1.EL.44
kernel-2.6.9-70.EL.src.rpm

Since 0505.0, which apparently worked, only anaconda changed (of those three):
anaconda-10.1.1.88-1

How reproducible:
Reproduced on two Tylersburg EP developement systems, by gcase and myself.
Comment 1 Ronald Pacheco 2008-05-13 21:53:16 EDT
We have one system in Westford with Geoff and John V, and another with Gary Case.

Geoff, do we have similar issues with the Tylersburg HEDT desktop unit?  (IIRC,
they have a different graphics device installed.)
Comment 2 Geoff Gustafson 2008-05-13 22:01:31 EDT
Right, the desktop version has no integrated graphics, and comes with a fancy
nVidia card. It works fine on 5.2, but hangs on 4.6, seems to be related to
graphics. Should be unrelated to this.
Comment 3 Gary Case 2008-05-14 16:17:14 EDT
It appears that this problem is not restricted to the matrox cards. It looks
like a generic problem with this build of RHEL4U7. A completely different system
with an ATI ES1000 chip also fails, as does one with an Intel 82Q35 integrated
graphics controller.
Comment 4 Denise Dumas 2008-05-14 16:34:16 EDT
Could this be a dup of 446045?
Comment 5 Chris Lumens 2008-05-15 00:11:11 EDT
Seems likely, yes.
Comment 6 Larry Troan 2008-05-16 08:14:08 EDT
From Kevin Martin in bug 446045 ...........
> I cannot tell if 446129 is related or not because it does not have any
> PCI IDs listed for the G200 there.

Setting this bug as a pre-req to bug 446129 until the situation is clarified.
Comment 8 Alexander Todorov 2008-05-16 08:20:34 EDT
(In reply to comment #6)
> From Kevin Martin in bug 446045 ...........
> > I cannot tell if 446129 is related or not because it does not have any
> > PCI IDs listed for the G200 there.
> 
> Setting this bug as a pre-req to bug 446129 until the situation is clarified.

Larry,
I think this is a dup of 446045
Comment 9 Alexander Todorov 2008-05-16 08:21:42 EDT
(In reply to comment #8)
> (In reply to comment #6)
> > From Kevin Martin in bug 446045 ...........
> > > I cannot tell if 446129 is related or not because it does not have any
> > > PCI IDs listed for the G200 there.
> > 
> > Setting this bug as a pre-req to bug 446129 until the situation is clarified.
> 
> Larry,
> I think this is a dup of 446045

In order to verify if the problem is anaconda itself or the gtk2 bug please try
one of the 0514.0 or 0515.0 trees.

Thanks
Comment 11 Peter Jones 2008-06-10 10:44:40 EDT
Please test this against a newer tree and report if you're still seeing the bug?
 We think this is a dupe of #446045, but there's no way to be sure without testing.
Comment 12 Geoff Gustafson 2008-06-10 11:22:20 EDT
John has this box and is taking over for me, so setting NEEDINFO to him.
Comment 15 John Villalovos 2008-06-30 16:39:34 EDT
I just tried to install RHEL 4.7 snapshot 4 and the anaconda graphical installer
came up fine.  I think this bug is fixed.
Comment 16 John Jarvis 2008-07-16 16:32:15 EDT
duping to 446045 and removing from 4.8 list

*** This bug has been marked as a duplicate of 446045 ***

Note You need to log in before you can comment on or make changes to this bug.