Bug 446098 - PackageKit interpolates yum config variables when modifying repo files
PackageKit interpolates yum config variables when modifying repo files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 447645 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 14:41 EDT by Will Woods
Modified: 2008-11-17 12:52 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.2.17-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 22:11:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-05-12 14:41:31 EDT
When you modify a repo with PackageKit (by using gpk-repo, for instance), it
interpolates all of the yum config variables ($releasever, $basearch, etc) in
the repo file. This isn't a good idea and can lead to some subtle and nasty repo
problems. 

An example: if you have a repo with a URL like:
  http://some.repo.tld/pub/fedora/releases/$releasever/$basearch/
If you disable it while $releasever is 8.92, the URL will be rewritten as:
  http://some.repo.tld/pub/fedora/releases/8.92/i386/
If you then re-enable it once the release has been updated to 9, the repo will
still be unusable - releases/8.92/i386 still doesn't exist.
Comment 1 Bug Zapper 2008-05-14 07:03:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Richard Hughes 2008-05-20 04:11:33 EDT
All we do is:

repo = self.yumbase.repos.getRepo(repoid)
if enable == 'false':
    if repo.isEnabled():
        repo.disablePersistent()
else:
    if not repo.isEnabled():
        repo.enablePersistent()

So we don't parse the strings at all. Re-assigning to yum.
Comment 3 Tim Lauridsen 2008-06-02 14:42:44 EDT
I am testing a fix at the monent, to make repo.disablePersistent() and
repo.enablePersistent() work without merging all the yum config vars.


 
Comment 4 Tim Lauridsen 2008-06-03 04:56:47 EDT
fixed upstream
Comment 5 Fedora Update System 2008-07-09 10:51:08 EDT
yum-3.2.17-1.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-07-22 13:28:43 EDT
yum-3.2.17-2.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-07-23 22:11:07 EDT
yum-3.2.17-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-08-07 13:17:00 EDT
yum-3.2.18-1.fc8 has been submitted as an update for Fedora 8
Comment 9 Fedora Update System 2008-08-27 14:02:36 EDT
yum-3.2.19-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/yum-3.2.19-1.fc8
Comment 10 Fedora Update System 2008-09-10 02:58:55 EDT
yum-3.2.19-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Chris Lumens 2008-11-17 12:52:25 EST
*** Bug 447645 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.