Bug 447645 - Upgrade fails to update fedora-release & other packages
Upgrade fails to update fedora-release & other packages
Status: CLOSED DUPLICATE of bug 446098
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 18:26 EDT by Stephen Cuppett
Modified: 2008-11-17 12:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 12:52:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upgrade log (65.48 KB, text/plain)
2008-05-21 17:36 EDT, Stephen Cuppett
no flags Details

  None (edit)
Description Stephen Cuppett 2008-05-20 18:26:12 EDT
Description of problem:

After an install of Fedora 9 on x86_64 (upgrade from Fedora 8): cups will not
start due to the following message:

[root@home init.d]# ./cups start
Starting cups: cupsd: error while loading shared libraries: libldap-2.3.so.0:
cannot open shared object file: No such file or directory

An inspection of /usr/lib reveals that it's not there...

[root@home lib]# ls -l libldap*
lrwxrwxrwx 1 root root     20 2008-05-13 14:19 libldap-2.4.so.2 ->
libldap-2.4.so.2.0.4
-rwxr-xr-x 1 root root 265068 2008-03-05 08:04 libldap-2.4.so.2.0.4
-rw-r--r-- 1 root root 425974 2008-03-05 08:04 libldap.a
lrwxrwxrwx 1 root root     22 2008-05-13 14:19 libldap_r-2.4.so.2 ->
libldap_r-2.4.so.2.0.4
-rwxr-xr-x 1 root root 286320 2008-03-05 08:04 libldap_r-2.4.so.2.0.4
-rw-r--r-- 1 root root 466784 2008-03-05 08:04 libldap_r.a
lrwxrwxrwx 1 root root     22 2008-05-13 14:30 libldap_r.so ->
libldap_r-2.4.so.2.0.4
lrwxrwxrwx 1 root root     20 2008-05-13 14:30 libldap.so -> libldap-2.4.so.2.0.4

Version-Release number of selected component (if applicable):

[root@home lib]# rpm -q cups
cups-1.3.7-2.fc8.x86_64
[root@home lib]# rpm -q openldap openldap-clients
openldap-2.4.8-3.fc9.x86_64
openldap-2.4.8-3.fc9.i386
openldap-clients-2.4.8-3.fc9.x86_64
[root@home lib]#

I noticed from above that I have cups-1.3.7-2.*FC8*.x86_64?  What?

So I did some more looking, and everything yum.repos.d has "8"s in it.  Sure
enough fedora-release is sitting at 8...:

[root@home lib]# rpm -e cups
error: Failed dependencies:
        /usr/bin/lp is needed by (installed) redhat-lsb-3.1-19.fc8.x86_64
        /usr/bin/lpr is needed by (installed) redhat-lsb-3.1-19.fc8.x86_64
        lpr is needed by (installed) kdegraphics-4.0.3-3.fc9.x86_64
        cups is needed by (installed) libgnomecups-0.2.3-3.fc9.x86_64
        cups is needed by (installed) bluez-utils-cups-3.30-2.fc9.x86_64
        cups is needed by (installed) hal-cups-utils-0.6.16-3.fc9.x86_64

[root@home lib]# rpm -e cups --nodeps
warning: /etc/cups/printers.conf saved as /etc/cups/printers.conf.rpmsave

[root@home lib]# yum install cups
Loaded plugins: priorities, refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package cups.x86_64 1:1.3.7-2.fc8 set to be updated
--> Processing Dependency: libldap-2.3.so.0()(64bit) for package: cups
--> Finished Dependency Resolution
1:cups-1.3.7-2.fc8.x86_64 from updates has depsolving problems
  --> Missing Dependency: libldap-2.3.so.0()(64bit) is needed by package
1:cups-1.3.7-2.fc8.x86_64 (updates)
Error: Missing Dependency: libldap-2.3.so.0()(64bit) is needed by package
1:cups-1.3.7-2.fc8.x86_64 (updates)

[root@home lib]# cd /etc/yum.repos.d/
[root@home yum.repos.d]# grep -n '8' *
adobe-linux-i386.repo:1:[adobe-linux-i386]
adobe-linux-i386.repo:3:baseurl=http://linuxdownload.adobe.com/linux/i386/
Fedora-install-media.repo:2:name=Fedora 8
Fedora-install-media.repo:3:mediaid=1194015916.783841
fedora.repo:2:name=Fedora 8 - x86_64
fedora.repo:4:#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/x86_64/os/
fedora.repo:5:mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-8&arch=x86_64
fedora.repo:11:name=Fedora 8 - x86_64 - Debug
fedora.repo:13:#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/x86_64/debug/
fedora.repo:14:mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-debug-8&arch=x86_64
fedora.repo:20:name=Fedora 8 - Source
fedora.repo:22:#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/source/SRPMS/
fedora.repo:23:mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-source-8&arch=x86_64
fedora-updates.repo:2:name=Fedora 8 - x86_64 - Updates
fedora-updates.repo:4:#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/8/x86_64/
fedora-updates.repo:5:mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f8&arch=x86_64
fedora-updates.repo:11:name=Fedora 8 - x86_64 - Updates - Debug
fedora-updates.repo:13:#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/8/x86_64/debug/
fedora-updates.repo:14:mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-debug-f8&arch=x86_64
fedora-updates.repo:20:name=Fedora 8 - Updates Source
fedora-updates.repo:22:#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/8/SRPMS/
fedora-updates.repo:23:mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-source-f8&arch=x86_64

[root@home yum.repos.d]# rpm -q yum
yum-3.2.14-10.fc9.noarch

[root@home yum.repos.d]# yum install redhat-release
Loaded plugins: priorities, refresh-packagekit
Setting up Install Process
Parsing package install arguments
Package matching fedora-release-8-5.noarch already installed. Checking for update.
Nothing to do


How reproducible:

Not sure, I only did this upgrade once on x86_64.

Steps to Reproduce:
1.  Install Fedora 8 x86_64
2.  Fully patch
3.  Run upgrade of Fedora 9 x86_64
  
Actual results:

In addition to fedora-release and cups, the following packages were not updated:

[root@home yum.repos.d]# vi fedora-updates.repo
[root@home yum.repos.d]# yum check-update
Loaded plugins: priorities, refresh-packagekit
updates-source                                           | 2.1 kB     00:00
fedora                                                   | 2.4 kB     00:00
primary.sqlite.bz2                                       | 7.6 MB     00:33
fedora-source                                            | 2.1 kB     00:00
updates                                                  | 2.3 kB     00:00
Not using downloaded repomd.xml because it is older than what we have

PyQt.x86_64                              3.17.4-4.fc9           fedora
PyQt-devel.x86_64                        3.17.4-4.fc9           fedora
aalib.x86_64                             1.4.0-0.15.rc5.fc9     fedora
akode.x86_64                             2.0.2-5.fc9            fedora
akode-pulseaudio.x86_64                  2.0.2-5.fc9            fedora
ant-javadoc.x86_64                       1.7.0-1jpp.4.fc9       fedora
antlr-javadoc.x86_64                     2.7.7-1jpp.7.fc9       fedora
apcupsd.x86_64                           3.14.3-2.1.fc9         fedora
aspell.x86_64                            12:0.60.5-5.fc9        fedora
aspell-en.x86_64                         50:6.0-9.fc9           fedora
autofs.x86_64                            1:5.0.3-11             fedora
avalon-framework-javadoc.x86_64          4.1.4-3jpp.14.fc9      fedora
avalon-logkit-javadoc.x86_64             1.2-5jpp.5.fc9         fedora
bcel-javadoc.x86_64                      5.2-4jpp.2.fc9         fedora
classpathx-jaf-javadoc.x86_64            1.0-11jpp.1.fc9        fedora
classpathx-mail-javadoc.x86_64           1.1.1-5jpp.3           fedora
cmake.x86_64                             2.4.8-2.fc9            fedora
compiz-kde.x86_64                        0.7.2-3.fc9            fedora
compiz-manager.noarch                    0.6.0-7.fc9            fedora
cryptix-asn1-javadoc.x86_64              20011119-8jpp.3        fedora
cryptix-javadoc.x86_64                   3.2.0-10jpp.2          fedora
cvsps.x86_64                             2.1-6.fc9              fedora
dejavu-lgc-fonts.noarch                  2.24-3.fc9             fedora
dia.x86_64                               1:0.96.1-6.fc9         fedora
dialog.x86_64                            1.1-4.20071028.fc9     fedora
ekiga.x86_64                             2.0.11-3.fc9           fedora
emacs-git.x86_64                         1.5.4.5-3.fc9          fedora
enca.x86_64                              1.9-4.fc9              fedora
fontforge.x86_64                         20080309-1.fc9         fedora
fontforge.i386                           20080309-1.fc9         fedora
fribidi.x86_64                           0.19.1-2.fc9           fedora
gimp-help.noarch                         2.4.1-1.fc9            fedora
git.x86_64                               1.5.4.5-3.fc9          fedora
git-arch.x86_64                          1.5.4.5-3.fc9          fedora
git-cvs.x86_64                           1.5.4.5-3.fc9          fedora
git-email.x86_64                         1.5.4.5-3.fc9          fedora
git-gui.x86_64                           1.5.4.5-3.fc9          fedora
git-svn.x86_64                           1.5.4.5-3.fc9          fedora
gitk.x86_64                              1.5.4.5-3.fc9          fedora
glib.x86_64                              1:1.2.10-29.fc9        fedora
glib-java.x86_64                         0.2.6-12.fc9           fedora
gnu-getopt-javadoc.x86_64                1.0.12-4jpp.1          fedora
gocr.x86_64                              0.45-2.fc9             fedora
gphoto2-devel.i386                       2.4.0-10.fc9           fedora
gtk+.x86_64                              1:1.2.10-61.fc9        fedora
gutenprint-plugin.x86_64                 5.0.2-2.fc9            fedora
hplip-gui.x86_64                         2.8.2-2.fc9            fedora
htdig.x86_64                             4:3.2.0-0.1.b6.fc9     fedora
imlib.x86_64                             1:1.9.15-7.fc9         fedora
jakarta-commons-beanutils-javadoc.x86_64 1.7.0-6jpp.1           fedora
jakarta-commons-collections-javadoc.x86_ 3.2-2jpp.2.fc9         fedora
jakarta-commons-daemon-javadoc.x86_64    1:1.0.1-6jpp.5.fc9     fedora
jakarta-commons-dbcp-javadoc.x86_64      1.2.1-11jpp.3.fc9      fedora
jakarta-commons-digester-javadoc.x86_64  1.7-7jpp.2             fedora
jakarta-commons-el-javadoc.x86_64        1.0-9jpp.2.fc9         fedora
jakarta-commons-fileupload-javadoc.x86_6 1:1.0-7jpp.2.fc9       fedora
jakarta-commons-lang-javadoc.x86_64      2.3-2jpp.1.fc9         fedora
jakarta-commons-launcher-javadoc.x86_64  1.1-2jpp.3.fc9         fedora
jakarta-commons-logging-javadoc.x86_64   1.0.4-7jpp.5.fc9       fedora
jakarta-commons-modeler-javadoc.x86_64   2.0-4jpp.2.fc9         fedora
jakarta-commons-pool-javadoc.x86_64      1.3-10jpp.3.fc9        fedora
jakarta-commons-validator-javadoc.x86_64 1.1.4-6jpp.2.fc9       fedora
jakarta-oro-javadoc.x86_64               2.0.8-4jpp.1           fedora
jakarta-taglibs-standard-javadoc.x86_64  1.1.1-9jpp.1.fc9       fedora
java-1.5.0-gcj-devel.x86_64              1.5.0.0-21.fc9         fedora
java-1.5.0-gcj-javadoc.x86_64            1.5.0.0-21.fc9         fedora
java-1.5.0-gcj-src.x86_64                1.5.0.0-21.fc9         fedora
java_cup-javadoc.x86_64                  1:0.10-0.k.6jpp.2      fedora
jdepend-javadoc.x86_64                   2.6-7jpp.3             fedora
jlex-javadoc.x86_64                      1.2.6-6jpp.1           fedora
junit-javadoc.x86_64                     3.8.2-4jpp.3.fc9       fedora
kdebase-devel.x86_64                     6:4.0.3-9.fc9          fedora
kdegraphics-devel.x86_64                 7:4.0.3-3.fc9          fedora
kdenetwork-devel.x86_64                  7:4.0.3-6.fc9          fedora
kdepim-devel.x86_64                      6:3.5.9-9.fc9          fedora
kdiff3.x86_64                            0.9.92-13.fc9          fedora
kernel-devel.x86_64                      2.6.25-14.fc9          fedora
kudzu-devel.x86_64                       1.2.85-1               fedora
lcms-devel.x86_64                        1.17-4.fc9             fedora
lcms-devel.i386                          1.17-4.fc9             fedora
ldapjdk-javadoc.x86_64                   4.18-1.fc9             fedora
libao-devel.i386                         0.8.8-4.fc9            fedora
libao-devel.x86_64                       0.8.8-4.fc9            fedora
libcaca.x86_64                           0.99-0.4.beta11.fc9    fedora
libcompizconfig.x86_64                   0.7.2-1.fc9            fedora
libdc1394.x86_64                         2.0.1-4.fc9            fedora
libdvdnav.x86_64                         4.1.1-6.fc9            fedora
libexif-devel.i386                       0.6.16-1.fc9           fedora
libgcj-src.x86_64                        4.3.0-8                fedora
libieee1284-devel.x86_64                 0.2.11-3.fc9           fedora
libieee1284-devel.i386                   0.2.11-3.fc9           fedora
libnemesi.x86_64                         0.6.4-0.3.rc2.fc9      fedora
libpaper.x86_64                          1.1.23-2.fc9           fedora
libsane-hpaio.x86_64                     2.8.2-2.fc9            fedora
libsysfs.i386                            2.1.0-3.fc9            fedora
libuninameslist.x86_64                   0.0-8.20060907         fedora
libuninameslist.i386                     0.0-8.20060907         fedora
libusb-devel.x86_64                      0.1.12-15.fc9          fedora
libusb-devel.i386                        0.1.12-15.fc9          fedora
libxml.i386                              1:1.8.17-19.fc9        fedora
libxml.x86_64                            1:1.8.17-19.fc9        fedora
libxml-devel.x86_64                      1:1.8.17-19.fc9        fedora
libxml-devel.i386                        1:1.8.17-19.fc9        fedora
lirc.x86_64                              0.8.3-0.3.pre2.fc9     fedora
lksctp-tools.x86_64                      1.0.7-3.fc9            fedora
log4j-javadoc.x86_64                     1.2.14-4jpp.1.fc9      fedora
mercurial.x86_64                         1.0-4.fc9              fedora
mikmod.x86_64                            3.2.2-8.beta1.fc9      fedora
nas.x86_64                               1.9.1-4.fc9            fedora
netembryo.x86_64                         0.0.5-2.fc9            fedora
opal.x86_64                              2.2.11-3.fc9           fedora
opencdk.i386                             0.6.6-1.fc9            fedora
opencdk.x86_64                           0.6.6-1.fc9            fedora
opencdk-devel.x86_64                     0.6.6-1.fc9            fedora
opencdk-devel.i386                       0.6.6-1.fc9            fedora
perl-CPAN.x86_64                         1.9205-20.fc9          fedora
perl-ExtUtils-Embed.x86_64               1.27-20.fc9            fedora
perl-Git.x86_64                          1.5.4.5-3.fc9          fedora
perl-Net-IP.noarch                       1.25-8.fc9             fedora
perl-TermReadKey.x86_64                  2.30-6.fc9             fedora
php-pear.noarch                          1:1.7.1-2.fc9          fedora
php-soap.x86_64                          5.2.5-7.fc9            fedora
poppler-qt.x86_64                        0.8.0-3.fc9            fedora
postgresql-devel.x86_64                  8.3.1-1.fc9            fedora
puretls-javadoc.x86_64                   0.9-0.2.b5.5jpp.1.fc9  fedora
pwlib.x86_64                             1.10.10-6.fc9          fedora
python-exif.noarch                       1.0.7-4.fc9            fedora
qca-tls.x86_64                           1.0-13.fc9             fedora
qt-devel.i386                            1:4.3.4-11.fc9         fedora
regexp-javadoc.x86_64                    1.5-2jpp.1.fc9         fedora
sane-backends-devel.x86_64               1.0.19-10.fc9          fedora
sane-backends-devel.i386                 1.0.19-10.fc9          fedora
selinux-policy-devel.noarch              3.3.1-42.fc9           fedora
subversion-perl.x86_64                   1.4.6-7                fedora
system-config-language.noarch            1.2.15-3.fc9           fedora
thunderbird.x86_64                       2.0.0.14-1.fc9         fedora
tla.x86_64                               1.3.5-5.fc9            fedora
transfig.x86_64                          1:3.2.5-2.fc9          fedora
wine.i386                                0.9.58-1.fc9           fedora
wine-capi.i386                           0.9.58-1.fc9           fedora
wine-cms.i386                            0.9.58-1.fc9           fedora
wine-core.i386                           0.9.58-1.fc9           fedora
wine-esd.i386                            0.9.58-1.fc9           fedora
wine-jack.i386                           0.9.58-1.fc9           fedora
wine-ldap.i386                           0.9.58-1.fc9           fedora
wine-nas.i386                            0.9.58-1.fc9           fedora
wine-tools.i386                          0.9.58-1.fc9           fedora
wine-twain.i386                          0.9.58-1.fc9           fedora
xalan-j2-javadoc.x86_64                  2.7.0-7jpp.2.fc9       fedora
xchat.x86_64                             1:2.8.4-15.fc9         fedora
xerces-j2-javadoc-apis.x86_64            2.7.1-10jpp.1.fc9      fedora
xerces-j2-javadoc-impl.x86_64            2.7.1-10jpp.1.fc9      fedora
xerces-j2-javadoc-other.x86_64           2.7.1-10jpp.1.fc9      fedora
xerces-j2-javadoc-xni.x86_64             2.7.1-10jpp.1.fc9      fedora
xine-lib-arts.x86_64                     1.1.12-2.fc9           fedora
xml-commons-apis-javadoc.x86_64          1.3.04-1jpp.1.fc9      fedora
xml-commons-which-javadoc.x86_64         1:1.0-1.b2.0jpp.2      fedora
xmlrpc-c.x86_64                          1.13.8-2.fc9           fedora
xmms-libs.x86_64                         1:1.2.10-38.fc9        fedora
xorg-x11-docs.noarch                     1.3-2.fc9              fedora
xorg-x11-drv-ark.x86_64                  0.7.0-1.fc9            fedora
xorg-x11-drv-avivo.x86_64                0.0.1-7.fc9            fedora
xorg-x11-drv-chips.x86_64                1.2.0-1.fc9            fedora
xorg-x11-drv-s3.x86_64                   0.6.0-1.fc9            fedora
xorg-x11-drv-tseng.x86_64                1.2.0-1.fc9            fedora
yum-priorities.noarch                    1.1.13-2.fc9           fedora
yum-updatesd.noarch                      1:0.9-1.fc9            fedora
[root@home yum.repos.d]#

Expected results:

All packages should have been upgraded appropriately or removed if they had no
counterparts and conflicted with packages that needed to be upgraded.

Additional info:
Comment 1 Stephen Cuppett 2008-05-20 18:52:10 EDT
Sorry, I originally started this as cups, but then realized I had much bigger
problems with package versions.

Workaround: in the above I was able to get that list of packages by editing
fedora.repo and fedora-updates.repo in /etc/yum.repos.d to have 9 and fc9 where
applicable instead of 8 and fc8.
Comment 2 Chris Lumens 2008-05-21 12:58:23 EDT
Please attach /var/log/anaconda.log and /root/upgrade.log to this bug report.
Comment 3 Stephen Cuppett 2008-05-21 17:36:38 EDT
Created attachment 306318 [details]
Upgrade log
Comment 4 Stephen Cuppett 2008-05-21 17:36:58 EDT
anaconda.log was empty.
Comment 5 Chris Lumens 2008-11-17 12:52:25 EST

*** This bug has been marked as a duplicate of bug 446098 ***

Note You need to log in before you can comment on or make changes to this bug.