Bug 446190 - Fonts in OpenOffice.org are incorrect for Romanian language
Fonts in OpenOffice.org are incorrect for Romanian language
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 08:32 EDT by Răzvan Sandu
Modified: 2008-05-13 09:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 09:15:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-05-13 08:32:24 EDT
Description of problem:

Various fonts that are present in OpenOffice.org's collection are incorrect for
Romanian language (Unicode UTF-8).

By pressing AltGr + s or AltGr + t, incorrect glyphs are inserted into the document:

- "T with cedilla below" (Unicode 0162) instead of "T with comma below" (Unicode
021A)
- "t with cedilla below" (Unicode 0163) instead of "t with comma below" (Unicode
021B)
- "S with cedilla below" (Unicode 015E) instead of "S with comma below" (Unicode
0218)
- "s with cedilla below" (Unicode 015F) instead of "s with comma below" (Unicode
0219)


Cedilla-below characters *are not* part of the Romanian language (it's only a
historical bug).


Version-Release number of selected component (if applicable):
openoffice.org-core-2.4.0-12.8.fc9.i386


How reproducible:
Always.

Steps to Reproduce:
1. Install fresh Fedora 9.
2. Set system to Romanian using system-config-language
3. Set keyboard to Romanian using system-config-keyboard
4. Open OpenOffice.org Writer.
5. Press AltGr + s and AltGr + t (with Shift for capitals) to insert Romanian
diacritics.

  
Actual results:
Cedilla-below characters are inserted instead of their comma-below counterparts.

Expected results:
Using the *default* keymap for Romanian language (which was recently corrected,
see http://bugs.freedesktop.org/show_bug.cgi?id=13277 ,comment no. 83),
comma-below characters are to be inserted.

This is according to official Romanian national standards.

Additional info:
Comment 1 Caolan McNamara 2008-05-13 08:41:43 EDT
And does this happen *just* for OpenOffice.org ?
Comment 2 Răzvan Sandu 2008-05-13 08:59:18 EDT
No, of course not.


This is a historical bug for Romanian implementations, that have been recently
been corrected both at FreeDesktop.org (Linux) *and* in Windows (Vista and XP).

The real problem is that many popular fonts include incorrect glyphs for
Romanian (cedilla-below instead of comma-below). There is no cedilla-below in
Romanian.

I've filled this bug to OpenOffice.org (too) because it is a main source of
documents, day-by-day.

*Please* help us Romanian writers to interrupt the flow of incorrectly-generated
documents for our language (in both Linux and Windows) !


There are other bugs opened on this matter, too, at system-config-keyboard,
system-config-language, anaconda and various individual font packages.


Many thanks,
Răzvan
Comment 3 Răzvan Sandu 2008-05-13 09:05:11 EDT
Please see bug #440992, too.
Comment 4 Caolan McNamara 2008-05-13 09:15:40 EDT
Has nothing to do with OOo, 

a) If AltGr + s and AltGr + t  for a layout generate the wrong code point then
its some generic keyboard map to make them generate the right one and then OOo
will work fine out of the box with no changes on my side.
b) If some fonts contain the wrong glyph at a given code-point then its an issue
for the font to fix them, and again OOo will work fine out of the box

not-a-bug in OOo itself AFAICS
Comment 5 Răzvan Sandu 2008-05-13 09:40:29 EDT
Point a) above was recently fixed.

For point b), please tell me what font packages OpenOffice.org uses when system
is set to Romanian. I'll file bugs for those specific packages.

Thanks a lot,
Răzvan
Comment 6 Caolan McNamara 2008-05-13 09:57:23 EDT
a) was it fixed *in fedora*
b) whatever the user selects to use, i.e. possibly all of them. But the default
is generally "Liberation Serif".

Note You need to log in before you can comment on or make changes to this bug.