Bug 446240 - libc-client: incomplete list of obsoletes
libc-client: incomplete list of obsoletes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: uw-imap (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 13:16 EDT by Thomas Moschny
Modified: 2008-05-19 10:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2007a1-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 10:20:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Moschny 2008-05-13 13:16:40 EDT
Description of problem:

libc-client doesn't properly obsolete all older versions of libc-clientXXXX 
out there, makes yum upgrade f8->f9 fail.

rpm -q libc-client2006-2006k-1.fc8.x86_64
libc-client2006-2006k-1.fc8.x86_64

rpm -q --obsoletes -p libc-client-2007a1-2.fc9.x86_64.rpm
libc-client2004d < 1:2004d-2
libc-client2004e < 2004e-2
libc-client2004g < 2004g-7
libc-client2006 < 2006k-1
libc-client2007 < 2007-2
Comment 1 Rex Dieter 2008-05-13 14:59:46 EDT
> makes yum upgrade f8->f9 fail.

it shouldn't.  what makes you think this caused the failure?
Comment 2 Rex Dieter 2008-05-13 15:00:29 EDT
otherwise, yes, I agree the Obsoletes is wrong here.
Comment 3 Thomas Moschny 2008-05-13 16:04:39 EDT
(In reply to comment #1)
> > makes yum upgrade f8->f9 fail.
> 
> it shouldn't.  what makes you think this caused the failure?

Sure it does. Because of the missing obsoletes, libc-client is not considered to
be a replacement for libc-client2006. This itself is not the problem. But
libc-client2006 has dependencies (libssl, libcrypto). This causes the problems,
because these dependencies also cannot be updated.

yum upgrade gives:

Error: Missing Dependency: libcrypto.so.6()(64bit) is needed by package
libc-client2006-2006k-1.fc8.x86_64 (installed)
Error: Missing Dependency: libssl.so.6()(64bit) is needed by package
libc-client2006-2006k-1.fc8.x86_64 (installed)

This can of course be solved by manually deinstalling libc-client2006 and
installing libc-client.
Comment 4 Jef Spaleta 2008-05-13 16:09:40 EDT
since the obsoletes dont work as expected  someone with an f8 system with
libc-client2006-2006k installed doesn't actually pull the newer libc-client for
f8 as an update which obsoletes libc-client2006-2006k.

So right there you have a problem without invoking the F9 upgrade path.

But if you go to do the F9 upgrade via yum from such a system starting point
with libc-client2006-2006k installed you get a dep resolution error because the
things which require libc-client2006 = 2006k-1 cant be fulfilled.

The fix will involve pushing both F8 and F9 updates with corrected obsoletes I
think.

-jef
Comment 5 Rex Dieter 2008-05-13 16:11:00 EDT
ah rats, thx.
Comment 6 Fedora Update System 2008-05-13 16:37:27 EDT
uw-imap-2007a1-3.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-05-14 18:14:30 EDT
uw-imap-2007a1-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Thomas Moschny 2008-05-14 18:29:07 EDT
Shouldn't we also have an update for F8?
Comment 9 Rex Dieter 2008-05-15 00:33:12 EDT
Strictly, yes, but it's not required to resolve the F8->F9 upgrade problem.
Comment 10 Thomas Moschny 2008-05-15 06:33:05 EDT
(In reply to comment #9)
> Strictly, yes, but it's not required to resolve the F8->F9 upgrade problem.

That's right. But F8 users won't get the updated version, and that's also one
aspect of this ticket.
Comment 11 Rex Dieter 2008-05-15 07:36:07 EDT
Nod.
Comment 12 Fedora Update System 2008-05-15 07:51:33 EDT
uw-imap-2007a1-3.fc8 has been submitted as an update for Fedora 8
Comment 13 Fedora Update System 2008-05-15 07:56:25 EDT
uw-imap-2007a1-3.fc7 has been submitted as an update for Fedora 7
Comment 14 Fedora Update System 2008-05-17 18:22:26 EDT
uw-imap-2007a1-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2008-05-17 18:23:57 EDT
uw-imap-2007a1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Dmitry Butskoy 2008-05-19 10:12:24 EDT
You have broked Fedora 7 :(

yum log is:

--> Processing Dependency: libc-client.so.2006 for package: php-imap
--> Finished Dependency Resolution
php-imap-5.2.4-1.fc7.i386 from installed has depsolving problems
--> Missing Dependency: libc-client.so.2006 is needed by package
php-imap-5.2.4-1.fc7.i386 (installed)
Error: Missing Dependency: libc-client.so.2006 is needed by package
php-imap-5.2.4-1.fc7.i386 (installed)


it seems that libc-client-2007a1-3.fc7 (a subpackage of uw-imap-2007a1-3.fc7)
now obsoletes libc-client2006-2006k-1.fc7, but the latter is still needed by the
current F7's php-imap ...
Comment 17 Rex Dieter 2008-05-19 10:20:25 EDT
Go see bug #447184, php needs to issue it's own update to address this.

Note You need to log in before you can comment on or make changes to this bug.