Bug 447184 - uw-imap/libc-client update breaks php dependencies
Summary: uw-imap/libc-client update breaks php dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 447334 447802 447849 448976 449373 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-18 16:09 UTC by Michal Jaegermann
Modified: 2008-09-06 17:50 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-06 17:50:46 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2008-05-18 16:09:07 UTC
Description of problem:

A subpackage libc-client-2007a1-3.fc8 puts on a list of obsoletes,
among others, libc-client2006 < 2006k-2.  The catch is that
php-imap for F8 lists libc-client.so.2006 among its dependencies
and even in koji uw-imap-2006k-2 has only an fc9 build.

That breakage is apparently caused by a "fix" to a bug #446240.

Version-Release number of selected component (if applicable):
uw-imap-2007a1-3.fc8

Comment 1 Rex Dieter 2008-05-19 14:02:04 UTC
See:
https://bugzilla.redhat.com/show_bug.cgi?id=438161#c10
(and bug #438160)

php was going to issue it's own, separate update.

Comment 2 Dmitry Butskoy 2008-05-19 14:33:48 UTC
Please, don't forget to update for Fedora 7 too, the issue breaks updates for F7
as well...

Comment 3 Rex Dieter 2008-05-19 14:43:14 UTC
Joe, sorry for the collateral damage here, I had *ass*umed a php update was in
the pipeline.

Comment 4 Tim Jackson 2008-05-20 08:15:07 UTC
Do I take it that simply bumping the release and rebuilding will do the trick?

Comment 5 Tim Jackson 2008-05-20 08:15:39 UTC
*** Bug 447334 has been marked as a duplicate of this bug. ***

Comment 6 Tim Jackson 2008-05-20 11:29:21 UTC
I did a quick bump and scratch build for F-8 and the deps now read:

libc-client.so.2007 

so I guess that is OK

Comment 7 Tim Jackson 2008-05-20 14:41:41 UTC
Actually the updates in testing are built against the 2007 version; they just
need pushing to stable
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-3606
https://admin.fedoraproject.org/updates/F8/FEDORA-2008-3864
https://admin.fedoraproject.org/updates/F7/FEDORA-2008-1734

Comment 8 Remi Collet 2008-05-22 04:59:35 UTC
*** Bug 447802 has been marked as a duplicate of this bug. ***

Comment 9 Rex Dieter 2008-05-22 12:41:27 UTC
*** Bug 447849 has been marked as a duplicate of this bug. ***

Comment 10 Tim Jackson 2008-05-23 12:49:45 UTC
I was going to make a request to stable but have just discovered Joe didn't
actually approve me for the stable branches before he went away.

I have made an offline cvsadmin request to temporarily grant me commit access.

Alternatively if some more people can test the update in testing and give it
some more karma it will get pushed automatically.

Comment 11 Kevin Fenzi 2008-05-23 16:01:31 UTC
Tim: you should have access on all branches from what I can see... 

Note that the updates listed in comment #7 are submitted by Joe and so only he
or bodhi admins can likely request they be pushed to stable. 
Do you need those pushed to stable? Or were you doing more builds? 
Also, note the comments on those about syck-php needing rebuilt.. 

Let me know if I can help move this along any way...

Comment 12 Rex Dieter 2008-05-29 19:24:17 UTC
*** Bug 448976 has been marked as a duplicate of this bug. ***

Comment 13 Rex Dieter 2008-06-02 16:48:56 UTC
*** Bug 449373 has been marked as a duplicate of this bug. ***

Comment 14 Rex Dieter 2008-09-06 17:50:46 UTC
This should all be sorted out by now.


Note You need to log in before you can comment on or make changes to this bug.