Bug 446281 - Preupgrade fails for the upgrade from fedora 8 to fedora 9
Preupgrade fails for the upgrade from fedora 8 to fedora 9
Status: CLOSED DUPLICATE of bug 446244
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 17:23 EDT by James Begley
Modified: 2008-05-13 17:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 17:31:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Begley 2008-05-13 17:23:19 EDT
Description of problem:
Preupgrade fails for the upgrade from fedora 8 to fedora 9.  Running preupgrade 
results in a python crash.

Version-Release number of selected component (if applicable):
[james@jumbovaio Desktop]$ rpm -qa | grep preupgrade
preupgrade-0.9.3-2.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Run preupgrade from a fedora 8 machine
2. Attempt to upgrade to fedora 9
3. Wait for preupgrade to download all the required packages (the progress 
meter gets to the last step, with progess given as 90.0%)
4. Watch preupgrade crash
  
Actual results:
[root@jumbovaio Desktop]# preupgrade
Loading "fastestmirror" plugin
Loading "priorities" plugin
Loading "skip-broken" plugin
Loading mirror speeds from cached hostfile
 * anaconda-upgrade: ftp.quicknet.nl
Loading mirror speeds from cached hostfile
 * anaconda-upgrade: ftp.quicknet.nl
No package matched to remove
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in 
on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 349, in main_preupgrade
    self.pu.retrieve_treeinfo()
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 390, in 
retrieve_treeinfo
    raise PUError, "Cannot find any kernel/initrd section for this arch in 
treeinfo"
preupgrade.PUError: Cannot find any kernel/initrd section for this arch in 
treeinfo

Expected results:
Preupgrade completes without crashing

Additional info:
Comment 1 Will Woods 2008-05-13 17:31:30 EDT

*** This bug has been marked as a duplicate of 446244 ***

Note You need to log in before you can comment on or make changes to this bug.