Bug 446244 - preupgrade should look in instrepo for .treeinfo rather than distrepo
preupgrade should look in instrepo for .treeinfo rather than distrepo
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 446281 446304 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 13:49 EDT by Chris January
Modified: 2008-05-14 18:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.9.3-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 18:13:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to change distrepo to instrepo. (945 bytes, patch)
2008-05-13 13:50 EDT, Chris January
no flags Details | Diff

  None (edit)
Description Chris January 2008-05-13 13:49:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

Description of problem:
preupgrade looks for .treeinfo in distrepo. There is in .treeinfo in distrepo for Fedora 9. preupgrade should be looking in instrepo. See attached patch.

Version-Release number of selected component (if applicable):
preupgrade-0.9.3-2

How reproducible:
Always


Steps to Reproduce:
1. Install Fedora 8.
2. Install preupgrade-0.9.3.
3. Enable Fedora 9 in preupgrade.
4. Launch preupgrade.
5. Select Fedora 9.
6. Wait for files to download, etc.
7. GUI will hang on last stage

Actual Results:
GUI hands on last stage with "Downloading installer metadata".

Expected Results:
Wizard complete successfully.

Additional info:
Comment 1 Chris January 2008-05-13 13:50:12 EDT
Created attachment 305273 [details]
Patch to change distrepo to instrepo.
Comment 2 Will Woods 2008-05-13 14:12:17 EDT
This snuck by because distrepo == instrepo for rawhide and F9 before today.
Patch applied in bzr - look for an update soon.

Comment 3 Will Woods 2008-05-13 14:13:51 EDT
Oh - and thanks for the patch!
Comment 4 Fedora Update System 2008-05-13 16:08:01 EDT
preupgrade-0.9.3-3.fc8 has been submitted as an update for Fedora 8
Comment 5 Will Woods 2008-05-13 17:31:31 EDT
*** Bug 446281 has been marked as a duplicate of this bug. ***
Comment 6 Seth Vidal 2008-05-13 20:50:53 EDT
*** Bug 446304 has been marked as a duplicate of this bug. ***
Comment 7 James Begley 2008-05-14 03:57:39 EDT
Installing preupgrade-0.9.3-3.fc8 from koji seems to have fixed things, 
thanks.  I've now successfully upgraded to fedora 9.
Comment 8 Fedora Update System 2008-05-14 18:13:40 EDT
preupgrade-0.9.3-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.