Bug 446331 - yum throws "TypeError: More items found in D-Bus signature..." traceback
yum throws "TypeError: More items found in D-Bus signature..." traceback
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 446282 447506 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 00:39 EDT by Michal Jaegermann
Modified: 2014-01-21 18:02 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 12:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-05-14 00:39:52 EDT
Description of problem:

At the end of a series of rawhide updates yum wrote:
.....
  Cleanup   : system-config-users          ##################### [489/489]
Unable to look at what's on dbus
ERROR:dbus.connection:Unable to set arguments () according to signature u's':
<type 'exceptions.TypeError'>: More items found in D-Bus signature than in
Python arguments
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 432, in doTransaction
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 790, in
runTransaction
    self.plugins.run('posttrans')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 175, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/refresh-packagekit.py", line 37, in posttrans_hook
    packagekit_iface.StateHasChanged('posttrans')
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 597, in
call_blocking
    message.append(signature=signature, *args)
TypeError: More items found in D-Bus signature than in Python arguments

That update includes an update to dbus-1.2.1-3.fc10 and I see that
I have two dbus-daemon processes running:
1949 started on a boot (shown by ps as 'dbus-daemon --system')
and '/bin/dbus-daemon --fork --print-pid 15 --print-address 17 --session'
with pid of 2385 started a short time later.  Thus both will be
from dbus-1.2.1-1.fc9.

It appears that an update was actually successful and 'package-cleanup'
does not report any problems - AFAICS.  Only that traceback.

Version-Release number of selected component (if applicable):
yum-3.2.14-10.fc9
dbus-1.2.1-3.fc10 (currently)

How reproducible:
don't know
Comment 1 Richard Hughes 2008-05-14 04:20:27 EDT
Cheers for reporting this bug -- it's harmless but needs to be fixed as it's
pretty scary-looking. I've fixed this in
2ccd2e3503eeaca3b634ec05a97b8a297edb7958 -- I'll build a new PackageKit 0.1.x
snapshot.
Comment 2 Richard Hughes 2008-05-14 04:20:51 EDT
*** Bug 446282 has been marked as a duplicate of this bug. ***
Comment 3 Robin Norwood 2008-05-20 10:26:19 EDT
*** Bug 447506 has been marked as a duplicate of this bug. ***
Comment 4 Richard Hughes 2008-05-22 12:29:37 EDT
Should be fixed if you update to the latest yum-packagekit in
fedora-updates-testing.

Note You need to log in before you can comment on or make changes to this bug.