Bug 446282 - dbus.connection:Unable to set arguments () according to signature u's'
dbus.connection:Unable to set arguments () according to signature u's'
Status: CLOSED DUPLICATE of bug 446331
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 459474 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-05-13 17:35 EDT by Nicolas Mailhot
Modified: 2014-01-21 18:02 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 04:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-05-13 17:35:51 EDT
Just hit this at the end of the rawhide update (right after the F9 unfreeze)

  Nettoyage : system-config-users          ##################### [453/453] 
ERROR:dbus.connection:Unable to set arguments () according to signature u's':
<type 'exceptions.TypeError'>: More items found in D-Bus signature than in
Python arguments
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 432, in doTransaction
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 790, in
runTransaction
    self.plugins.run('posttrans')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 175, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/refresh-packagekit.py", line 37, in posttrans_hook
    packagekit_iface.StateHasChanged('posttrans')
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 597, in
call_blocking
    message.append(signature=signature, *args)
TypeError: More items found in D-Bus signature than in Python arguments
Comment 1 Seth Vidal 2008-05-13 17:39:32 EDT
pretty sure this goes to PackageKit for yum-packagekit

reassigning
Comment 2 Richard Hughes 2008-05-14 04:20:49 EDT

*** This bug has been marked as a duplicate of 446331 ***
Comment 3 Bug Zapper 2008-05-14 07:05:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Richard Hughes 2008-08-19 12:38:43 EDT
*** Bug 459474 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.