Bug 446360 - Upgrade install from Fedora 8 to 9 leaves crond out of runlevels
Upgrade install from Fedora 8 to 9 leaves crond out of runlevels
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 448010 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 06:14 EDT by Stephen Cuppett
Modified: 2008-05-28 22:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0-6.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 22:43:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Cuppett 2008-05-14 06:14:02 EDT
Description of problem:

Yesterday (5/13/2008) I upgraded from a fully patched version of Fedora 8 to
Fedora 9 for x86_64.  After the upgrade crond was no longer part of any
runlevel.  The crontabs were okay, they just weren't running.  

"chkconfig --list crond" indicated that crond was supported by not installed,
use chkconfig --add.  chkconfig --add did the trick and got it back to working.

How reproducible:

I assume every migration of x86_64 from 8 to 9 (at least) would suffer from this.

Steps to Reproduce:
1.  Install and patch Fedora 8 x86_64, ensure crond is in runlevels
2.  Run DVD upgrade to Fedora 9 x86_64
3.  Observe crond not in any runlevels.
  
Actual results:

No crond in runlevels

Expected results:

Crond would remain in runlevels after upgrade if present before upgrade.
Comment 1 Marcela Mašláňová 2008-05-14 07:19:52 EDT
rpm -q cronie

I had problems with postinstall script, which should be solved in version
cronie-1.0-5. So please run yum update for 0updates and let me know, if there
are still problems.
Comment 2 Stephen Cuppett 2008-05-14 07:45:56 EDT
Right after installing last night, yum did prompt me and do an update.

[cuppett@home ~]$ rpm -q cronie
cronie-1.0-5.fc9.x86_64

However, it was this morning that I noticed crond wasn't in the runlevels and
had to fix it.  This was after the new RPM came down if it was part of that
update...

I looked at yum.log and cronie didn't appear in it..

May 13 13:30:49 emacs - 22.1-11.fc8.x86_64: extra callback for package emacs -
22.1-11.fc8.x86_64 in state 10
May 13 19:31:10 Installed: 1:faad2-libs-2.6.1-3.lvn9.x86_64
May 13 19:31:10 Updated: xvidcore-1.1.3-3.lvn9.x86_64
May 13 19:31:11 Installed: lksctp-tools-1.0.7-2.fc8.x86_64
May 13 19:31:11 Installed: netembryo-0.0.5-1.fc8.x86_64
May 13 19:31:12 Installed: libnemesi-0.6.4-0.1.rc2.fc8.x86_64
May 13 19:31:14 Updated: mplayer-1.0-0.93.20080211svn.lvn9.x86_64
May 13 19:31:19 Updated: gnome-mplayer-0.6.1-1.lvn9.x86_64
May 13 19:31:19 Updated: x264-0.0.0-0.12.20080227.lvn9.x86_64
May 13 19:31:20 Installed: libdc1394-2.0.1-3.fc8.x86_64
May 13 19:31:21 Updated: ffmpeg-libs-0.4.9-0.45.20080113.lvn9.x86_64
May 13 19:31:24 Updated: gecko-mediaplayer-0.6.1-1.lvn9.x86_64
May 13 19:31:25 Updated: livna-release-9-1.noarch
May 13 19:31:25 Updated: ffmpeg-0.4.9-0.45.20080113.lvn9.x86_64
May 13 19:31:26 Erased: faad2

[root@home cuppett]# cd /var/log/
[root@home log]# grep -n 'cronie' *
[root@home log]# ls -la yum*
-rw------- 1 root root 10254 2008-05-13 21:40 yum.log
-rw-r--r-- 1 root root 40560 2008-03-20 01:33 yum.log-20080320
-rw------- 1 root root 30950 2008-04-05 14:40 yum.log-20080406
Comment 3 Marcela Mašláňová 2008-05-20 07:52:17 EDT
Now it should be working also after upgrade.
Comment 4 Fedora Update System 2008-05-20 08:08:07 EDT
cronie-1.0-6.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-05-21 06:54:49 EDT
cronie-1.0-6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cronie'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4146
Comment 6 Marcela Mašláňová 2008-05-26 02:58:20 EDT
*** Bug 448010 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-05-28 22:43:30 EDT
cronie-1.0-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.