Bug 448010 - cron not enabled after f8->f9 upgrade
cron not enabled after f8->f9 upgrade
Status: CLOSED DUPLICATE of bug 446360
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 16:55 EDT by Jon Burgess
Modified: 2008-05-26 02:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-26 02:58:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Burgess 2008-05-22 16:55:47 EDT
Description of problem:
After upgrading to F9 cron jobs are no longer being executed

Version-Release number of selected component (if applicable):
F9: cronie-1.0-5.fc9.x86_64
(F8 before upgrade: vixie-cron-4.2-8.fc8.x86_64.rpm)

How reproducible:
Every time

Steps to Reproduce:
1. Take F9 system. Remove cronie (rpm --erase --nodeps cronie)
2. Install F8 vixie-cron, verify that the service is enabled
3. Upgrade to F9 cronie. Check services and find cronie is not enabled
  
Actual results:
# rpm --erase --nodeps cronie
# rpm -ivh f8-dvd/Packages/vixie-cron-4.2-3.fc8.x86_64.rpm
# chkconfig --list crond
crond           0:off   1:off   2:on    3:on    4:on    5:on    6:off
# rpm -Uvh f9-dvd/Packages/cronie-1.0-5.fc9.x86_64.rpm
# chkconfig --list crond
service crond supports chkconfig, but is not referenced in any runlevel (run
'chkconfig --add crond')

Expected results:
crond service should be enabled after F9 upgrade. 'chkconfig --add crond' does
fix it

Additional info:
The cronie postinstall adds itself as a service...
# rpm -q --scripts cronie
postinstall scriptlet (using /bin/sh):
    /sbin/chkconfig --add crond

but it looks like this is undone by the preuninstall of the vixe-cron that it
obsoletes:
# rpm -q --scripts -p dvd/Packages/vixie-cron-4.2-3.fc8.x86_64.rpm
preuninstall scriptlet (using /bin/sh):
if [ $1 = 0 ]; then
        /sbin/service crond stop >/dev/null 2>&1 || :
        /sbin/chkconfig --del crond
fi

I'm not really sure how this could be easily fixed due to not being able to
retrospectively fix the vixie-cron scripts. Maybe it just needs to get
documented as a common upgrade issue (or maybe the cronie package could be
bumped a release, it looks like this ought to get the service added on the
upgrade... but that would not help anyone that managed to upgrade from F8
directly to the new package).
Comment 1 Marcela Mašláňová 2008-05-26 02:58:19 EDT

*** This bug has been marked as a duplicate of 446360 ***

Note You need to log in before you can comment on or make changes to this bug.