Bug 446495 - anaconda exception in Live copy to drive
anaconda exception in Live copy to drive
Status: CLOSED DUPLICATE of bug 442356
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 16:38 EDT by Bruce Kelley
Modified: 2008-06-10 21:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 21:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Text file copy of exception report (594.28 KB, text/plain)
2008-05-14 16:38 EDT, Bruce Kelley
no flags Details

  None (edit)
Description Bruce Kelley 2008-05-14 16:38:08 EDT
Description of problem:
During install to disk from Live CD, after the drive selection and about half 
way through the copy to disk, I get an anaconda exception which terminates the 
installation:
------------------------------
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/livecd.py", line 191, in doInstall
    buf = os.read(osfd, readamt)
  File "/usr/lib/anaconda/backend.py", line 215, in doInstall
    return anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1278, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 80, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1299, in handleRenderCallback
    self.currentWindow.renderCallback()
OSError: [Errno 5] Input/output error
(Entire exception report attached.)
------------------------------
Hardware is Supermicro 6011D with two P3 processors, 2GB of RAM, Adaptec AIC-
7899W (hardware RAID removed), two 36GB SCSI drives on the 7899's A port, Intel 
82559 ethernet. (http://www.supermicro.com/products/system/1U/6011/SYS-
6011D.cfm for hardware reference.)

I did verify that the Live Install media is good with the built-in check.

Version-Release number of selected component (if applicable):
(Fedora-9-i686-Live.iso from 5/13/08)

How reproducible:
Always (3 for 3, same place, same result)

Steps to Reproduce:
0. Low level format two identical SCSI hard drives (format shows no errors)
1. Boot Live CD
2. Install to Disk
2. Select language, etc. (english, US, Los Angeles time zone)
3. Set up hardcoded IP address, etc, for network
4. Custom hard drive setup, set up RAID arrays on two identical 36GB SCSI 
drives:
   dev/md0: 1984 MB - boot
   dev/md1: 30976 MB - /
   dev/sda3: 2040 MB - swap (no raid here)
5. Proceed when it warns about deleting all data on drives.
6. Watch the progress bar inch across until about half-way, we get the anaconda 
exception pop-up. Details attached.

Actual results:
"anaconda None exception" and installation failed.

Expected results:
successful installation!

Additional info:
Comment 1 Bruce Kelley 2008-05-14 16:38:08 EDT
Created attachment 305405 [details]
Text file copy of exception report
Comment 2 Chris Lumens 2008-05-15 13:16:10 EDT
Can you also attach /tmp/syslog to this bug report?  Thanks.
Comment 3 Bruce Kelley 2008-05-15 13:24:35 EDT
Sorry, since it won't boot, I can't do that.
Comment 4 Chris Lumens 2008-05-15 13:30:39 EDT
You'd find /tmp/syslog while the live CD is running, not after you have
installed.  Or are you saying that the live CD itself will no longer boot?
Comment 5 Paul Wittle 2008-05-27 16:46:42 EDT
I'm also having a similar problem at the end of copying from CD2. The computer
is not connected to the internet and it will not let me save to a disk so I
can't put the report on here but I'd love to see the answer when you have one. 
Comment 6 Chris Lumens 2008-06-10 21:51:50 EDT

*** This bug has been marked as a duplicate of 442356 ***

Note You need to log in before you can comment on or make changes to this bug.