This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 442356 - cannot switch keyboard layout from US-International to US-English
cannot switch keyboard layout from US-International to US-English
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
: 446495 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-14 11:14 EDT by Jon Stanley
Modified: 2009-01-07 13:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 11:40:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Stanley 2008-04-14 11:14:04 EDT
In QA for bug 440499, I used system-config-keyboard to switch the keyboard
layout from US English to US International.  I then tried immediately switching
back to US English, got this python traceback and the window won't close (will
post in another comment from the VM itself since copy/paste won't work outside
my VM :) )
Comment 1 Jon Stanley 2008-04-14 11:16:05 EDT
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz
Parse error on line 14 of section InputDevice in file /etc/X11/xorg.conf
	This section must have an Identifier line.
Traceback (most recent call last):
  File "/usr/share/system-config-keyboard/keyboard_gui.py", line 226, in _okClicked
    return self.apply(None, False)
  File "/usr/share/system-config-keyboard/keyboard_gui.py", line 117, in apply
    keyboardBackend.modifyXconfig(fullname, layout, model, variant, options)
  File "/usr/share/system-config-keyboard/keyboard_backend.py", line 39, in
modifyXconfig
    xconfig.comment = '# This configuration file was broken by
system-config-keyboard'
AttributeError: 'NoneType' object has no attribute 'comment'
Comment 2 Jon Stanley 2008-04-14 11:22:38 EDT
I see, it does indeed create a malformed X configuration as stated in the traceback:

# Keyboard added by system-config-keyboard      Identifier  "Keyboard0"

This has the US International layout in it, and it seems like s-c-k (or probably
anything else) can't grok that anymore.

The comment and 'Identifier' should be on separate lines.
Comment 3 Jon Stanley 2008-04-14 11:28:07 EDT
Yeah, X won't start with this config (not surprisingly)
Comment 4 Lubomir Kundrak 2008-04-14 11:40:22 EDT
Use a more recent build.
Comment 5 Jon Stanley 2008-04-14 14:37:22 EDT
confirmed working in system-config-keyboard-1.2.15-2.fc9 - but that didn't make
today's rawhide even though it's tagged.  I'll follow up on that.
Comment 6 Chris Lumens 2008-06-10 21:51:51 EDT
*** Bug 446495 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.