Bug 446540 - Multiple identical popups re critical updates
Multiple identical popups re critical updates
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 449865 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 19:43 EDT by David Timms
Modified: 2008-06-04 04:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 05:18:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
multiple notifications after method A (176.49 KB, image/png)
2008-05-14 19:43 EDT, David Timms
no flags Details
result of method B above (74.35 KB, image/png)
2008-05-14 19:47 EDT, David Timms
no flags Details
another example on F9GA (144.41 KB, image/png)
2008-05-15 07:29 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2008-05-14 19:43:04 EDT
Description of problem:
The critical update popup can be invoked multiple times, filling up the screen.
It's a bit ugly ;-)

Version-Release number of selected component (if applicable):
seen in rawhide just before release, and now in F9 GA.
gnome-packagekit-0.1.12-12.20080430.fc9.i386
PackageKit-0.1.12-10.20080505.fc9.i386
PackageKit-libs-0.1.12-10.20080505.fc9.i386
yum-packagekit-0.1.12-10.20080505.fc9.i386

How reproducible: since it occurs autonomously not that easy. It depends on what
PK is doing {that you can't see}

Steps to Reproduce:
A:
1. click check updates from the PK applet icon after being notified that they exist.
2. unselect all
3. check a package of interest
4. apply an update that does not include the critical update

B:
1. F9, login to gnome session. 
2. {possibly there was already one noti before screen saver kicked in, but I
wasn't there to see if that was the case.}
3. wait until screen saver.
4. move mouse/hit key
5. type password.
  
Actual results:
A: 
After seeing a second copy if the notification, I repeated the process multiple
times to see if it could be reproduced - see the attachment.

B:
two critical warning dialogs are shown, one at the bottom, the other at top centre.

Expected results:
PK should keep track of it's bits. One ominous {yet totally irrelevant} warning
is quite enough.
Comment 1 David Timms 2008-05-14 19:43:04 EDT
Created attachment 305418 [details]
multiple notifications after method A
Comment 2 David Timms 2008-05-14 19:47:00 EDT
Created attachment 305419 [details]
result of method B above
Comment 3 David Timms 2008-05-15 07:29:36 EDT
Created attachment 305472 [details]
another example on F9GA

These dialogs do go away if clicked anywhere in their area.
Noticed the first one bottom-right.
Next top-centre.
right-centre.
right-top.
right-top-over-clock.
bottom right {second overlaid}.
Comment 4 Richard Hughes 2008-05-28 05:18:48 EDT
I've fixed the multiple notifications thing in git master. Thanks for the report.
Comment 5 Richard Hughes 2008-06-04 04:04:10 EDT
*** Bug 449865 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.