Bug 446575 - All themes show up twice
All themes show up twice
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase3 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 02:35 EDT by Stefan Neufeind
Modified: 2008-06-06 03:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.5.9-14.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 03:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-05-15 02:35:35 EDT
Under Appearance > Themes the list contains all theme-names "twice".

(This installation is an upgrade from Fedora 8 - if that makes a difference maybe.)
Comment 1 Steven M. Parrish 2008-05-15 07:31:27 EDT
On a clean F9 install this is working just fine.  Sounds like an issue with the
upgrade process.
Comment 2 Rex Dieter 2008-05-15 07:33:43 EDT
This one is an upstream bug, in that kde4 lists kde3 themes too.

Of the: annoying but mostly harmless variety.
Comment 3 Stefan Neufeind 2008-05-15 08:03:46 EDT
So how could I find out which are are kde3-themes, which I guess I'd like to
remove now after having upgraded?
Comment 4 Rex Dieter 2008-05-15 08:19:37 EDT
The other themes are in kdebase3
Comment 5 Stefan Neufeind 2008-05-15 08:31:29 EDT
ah, and so I can't remove those since they are needed by kde3-applications?
Trying to uninstall kdebase3 rpm tells me that "kdebluetooth" needs
/usr/bin/kdesu from kdebase3. But why would it work on a fresh install of F9
instead then? Using e.g. kdebluettoth-1.0-0.41.beta8.fc9.x86_64 - so that's no
left-over from F8 either.
Comment 6 Steven M. Parrish 2008-05-15 09:08:51 EDT
Just double checked my installation and kdebase3 is currently not installed, so
that explains why I dont have dupes.
Comment 7 Kevin Kofler 2008-05-16 09:23:54 EDT
Could OnlyShowIn=KDE3 (see bug 446466) help here too?
Comment 8 Rex Dieter 2008-05-16 09:31:06 EDT
I don't think themes or widget styles (which have the same problem) are
controlled via .desktop files.

See
/usr/share/apps/kthememanager/themes
not sure why kde4's thememanager is looking here too, but we could well just
omit this from packaging.
 
Comment 9 Rex Dieter 2008-05-16 09:32:12 EDT
I'll make the change and roll this into our pending kdelibs3/kdebase3 update.
Comment 10 Fedora Update System 2008-05-17 18:25:02 EDT
kdebase3-3.5.9-14.fc9, kdelibs3-3.5.9-11.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase3 kdelibs3'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4089
Comment 11 Fedora Update System 2008-06-06 03:45:58 EDT
kdelibs3-3.5.9-14.fc9, kdebase3-3.5.9-14.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.