Bug 446577 - Trackpoint scrolling issue
Trackpoint scrolling issue
Status: CLOSED DUPLICATE of bug 446627
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 03:03 EDT by Jean-Christophe Baptiste
Modified: 2018-04-11 14:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 21:47:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf : Xorg not reading the trackpoint parameters (1.64 KB, text/plain)
2008-05-15 03:03 EDT, Jean-Christophe Baptiste
no flags Details
xorg.0.log : Xorg not reading the trackpoint parameters (JC) (16.71 KB, text/plain)
2008-05-17 03:23 EDT, Jean-Christophe Baptiste
no flags Details
Xorg.conf with nonworking EmulateWheel (1.02 KB, application/octet-stream)
2008-05-20 12:43 EDT, Pancrazio `ezio' de Mauro
no flags Details
X logs with nonworking EmulateWheel (38.19 KB, application/octet-stream)
2008-05-20 12:44 EDT, Pancrazio `ezio' de Mauro
no flags Details
xorg.conf with working EmulateWheel (1.02 KB, application/octet-stream)
2008-05-20 12:48 EDT, Pancrazio `ezio' de Mauro
no flags Details
X logs with working EmulateWheel (31.46 KB, application/octet-stream)
2008-05-20 12:50 EDT, Pancrazio `ezio' de Mauro
no flags Details

  None (edit)
Description Jean-Christophe Baptiste 2008-05-15 03:03:04 EDT
Description of problem:


Version-Release number of selected component (if applicable): 7.3


How reproducible:


Steps to Reproduce:
Always reproducible.
  
Actual results:
Scrolling with the trackpoint of my Thinkpad T61 laptop does not work.

Expected results:
Middle button should allow scrolling.

Additional info:
I attach my xorg.conf, though I have tried all possible variants using the tips
I found on the web.
It is like the parameters are not read at all by Xorg.
Comment 1 Jean-Christophe Baptiste 2008-05-15 03:03:04 EDT
Created attachment 305447 [details]
xorg.conf : Xorg not reading the trackpoint parameters
Comment 2 Dag 2008-05-15 04:43:27 EDT
same here with an IBM X31 laptop, the Xorg emulatewheel worked for 2 years but
now it's simply ignored by Xorg:

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "PS/2"
        Option      "Emulate3Buttons" "no"
        Option      "ZAxisMapping" "4 5"
        Option      "EmulateWheel" "true"
        Option      "EmulateWheelButton" "2"
        Option      "EmulateInertia" "50"
EndSection
Comment 3 Jean-Christophe Baptiste 2008-05-16 11:02:08 EDT
There is my xorg.0.log :

(II) Synaptics touchpad driver version 0.14.6 (1406)
(--) Touchpad auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(--) Touchpad touchpad found
(**) Touchpad: always reports core events
(WW) <default pointer>: No Device specified, looking for one...
(II) <default pointer>: Setting Device option to "/dev/input/mice"
(--) <default pointer>: Device: "/dev/input/mice"
(==) <default pointer>: Protocol: "Auto"
(**) Option "CorePointer"
(**) <default pointer>: always reports core events
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
(**) <default pointer>: Sensitivity: 1
(II) evaluating device (<default pointer>)
(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(II) evaluating device (Touchpad)
(II) XINPUT: Adding extended input device "Touchpad" (type: MOUSE)
(II) evaluating device (Keyboard0)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) <default pointer>: Setting mouse protocol to "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded
(--) Touchpad auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(--) Touchpad touchpad found
(II) LoadModule: "evdev"

(II) Loading /usr/lib64/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
	compiled for 0.0.0, module version = 1.0.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 2.0
(**) Microsoft Microsoft Wireless Optical Mouse? 1.00: always reports core events
(**) Microsoft Microsoft Wireless Optical Mouse? 1.00: Device: "/dev/input/event12"
(II) Microsoft Microsoft Wireless Optical Mouse? 1.00: Found x and y relative axes
(II) Microsoft Microsoft Wireless Optical Mouse? 1.00: Found mouse buttons
(II) Microsoft Microsoft Wireless Optical Mouse? 1.00: Configuring as mouse
(II) XINPUT: Adding extended input device "Microsoft Microsoft Wireless Optical
Mouse? 1.00" (type: MOUSE)
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event0"
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Found mouse buttons
(II) Macintosh mouse button emulation: Configuring as mouse
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation"
(type: MOUSE)
(**) TPPS/2 IBM TrackPoint: always reports core events
(**) TPPS/2 IBM TrackPoint: Device: "/dev/input/event3"
(II) TPPS/2 IBM TrackPoint: Found x and y relative axes
(II) TPPS/2 IBM TrackPoint: Found mouse buttons
(II) TPPS/2 IBM TrackPoint: Configuring as mouse
(II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE)
(II) Synaptics touchpad driver version 0.14.6 (1406)
(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(--) SynPS/2 Synaptics TouchPad touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: MOUSE)
(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(WW) SynPS/2 Synaptics TouchPad can't grab event device, errno=16
(--) SynPS/2 Synaptics TouchPad touchpad found

I don't get any output :
# cat /dev/input/event{0,2}
# cat /dev/input/mice

What is going on ?
Comment 4 Matěj Cepl 2008-05-16 18:30:20 EDT
Please, *attach* *complete* /var/log/Xorg.*.log? Thank you
Comment 5 Jean-Christophe Baptiste 2008-05-17 03:23:12 EDT
Created attachment 305788 [details]
xorg.0.log : Xorg not reading the trackpoint parameters (JC)

There is mine.
Comment 6 Pancrazio `ezio' de Mauro 2008-05-18 17:26:59 EDT
Same behaviour with my Lenovo Thinkpad X60s, it doesn't seem to be x86_64
specific. Let me know if you need further logs/configuration files.
Comment 7 Matěj Cepl 2008-05-19 12:31:57 EDT
Yes, Pancrazio, I would need yours /etc/X11/xorg.conf and /var/log/Xorg.*.log,
otherwise I will have to close this bug -- attachment 305788 [details] is generated with
binary only nvidia drivers, which we don't support.
Comment 8 Stepan Lendak 2008-05-20 03:51:35 EDT
solution is here (not tested):

http://vbraun.name/cms/node/7
Comment 9 Pancrazio `ezio' de Mauro 2008-05-20 12:43:25 EDT
Created attachment 306151 [details]
Xorg.conf with nonworking EmulateWheel
Comment 10 Pancrazio `ezio' de Mauro 2008-05-20 12:44:57 EDT
Created attachment 306152 [details]
X logs with nonworking EmulateWheel
Comment 11 Pancrazio `ezio' de Mauro 2008-05-20 12:46:36 EDT
Solution mentioned in Comment #9 works for me, not sure whether we should call
it solution or workaround though

ezio
Comment 12 Pancrazio `ezio' de Mauro 2008-05-20 12:48:42 EDT
Created attachment 306153 [details]
xorg.conf with working EmulateWheel
Comment 13 Pancrazio `ezio' de Mauro 2008-05-20 12:50:40 EDT
Created attachment 306155 [details]
X logs with working EmulateWheel
Comment 14 Pancrazio `ezio' de Mauro 2008-05-20 12:52:45 EDT
Attaching configuration and logs as per instructions in Comment #8, you can
actually see that X loads the "evdev" module, which isn't loaded using the
configuration file in comment #9
Comment 15 Peter Hutterer 2008-07-14 21:47:12 EDT
What you are seeing is a side-effect of the input hotplug mechanism.

When the server starts up, it setups up the devices in the config file. Then it
sets up up devices as received by HAL. When this happens, all devices are set up
again with the evdev driver. This driver does not (yet) have a EmulateWheel
option, and thus it ceases working.

evdev also grabs the event device to make sure no other process can receive
input events (to avoid getting duplicate events in /dev/input/mice). Hence why
you don't see output in /dev/input/mice or /dev/input/event* after the server
has started up.
so although your mouse is still configured, it won't receive events anymore.

Marking as a duplicate of 446627.

*** This bug has been marked as a duplicate of 446627 ***

Note You need to log in before you can comment on or make changes to this bug.